messages from 2024-02-08 03:18:58 to 2024-02-22 15:20:16 UTC [more...]
[PATCH v2 00/25] fs: use type-safe uid representation for filesystem capabilities
2024-02-22 15:20 UTC (42+ messages)
` [PATCH v2 01/25] mnt_idmapping: split out core vfs[ug]id_t definitions into vfsid.h
` [PATCH v2 02/25] mnt_idmapping: include cred.h
` [PATCH v2 03/25] capability: add static asserts for comapatibility of vfs_cap_data and vfs_ns_cap_data
` [PATCH v2 04/25] capability: rename cpu_vfs_cap_data to vfs_caps
` [PATCH v2 05/25] capability: use vfsuid_t for vfs_caps rootids
` [PATCH v2 06/25] capability: provide helpers for converting between xattrs and vfs_caps
` [PATCH v2 07/25] capability: provide a helper for converting vfs_caps to xattr for userspace
` [PATCH v2 08/25] xattr: add is_fscaps_xattr() helper
` [PATCH v2 09/25] commoncap: use is_fscaps_xattr()
` [PATCH v2 10/25] xattr: "
` [PATCH v2 11/25] security: add hooks for set/get/remove of fscaps
` [PATCH v2 12/25] selinux: add hooks for fscaps operations
` [PATCH v2 13/25] smack: "
` [PATCH v2 14/25] evm: add support for fscaps security hooks
` [PATCH v2 15/25] security: call evm fscaps hooks from generic "
` [PATCH v2 16/25] fs: add inode operations to get/set/remove fscaps
` [PATCH v2 17/25] fs: add vfs_get_fscaps()
` [PATCH v2 18/25] fs: add vfs_set_fscaps()
` [PATCH v2 19/25] fs: add vfs_remove_fscaps()
` [PATCH v2 20/25] ovl: add fscaps handlers
` [PATCH v2 21/25] ovl: use vfs_{get,set}_fscaps() for copy-up
` [PATCH v2 22/25] fs: use vfs interfaces for capabilities xattrs
` [PATCH v2 23/25] commoncap: remove cap_inode_getsecurity()
` [PATCH v2 24/25] commoncap: use vfs fscaps interfaces
` [PATCH v2 25/25] vfs: return -EOPNOTSUPP for fscaps from vfs_*xattr()
[PATCH 1/3] libsepol: ensure transitivity in compare functions
2024-02-22 15:14 UTC (2+ messages)
[PATCH] checkpolicy, libsepol: Fix potential double free of mls_level_t
2024-02-21 21:12 UTC (3+ messages)
[PATCH v2] checkpolicy, libsepol: Fix potential double free of mls_level_t
2024-02-21 21:07 UTC
[PATCH 5.4,4.19] lsm: new security_file_ioctl_compat() hook
2024-02-21 10:52 UTC (2+ messages)
[PATCH testsuite] tests/inet_socket: test CALIPSO also with datagram protocols
2024-02-19 20:49 UTC (2+ messages)
[PATCH PR#420 v2] audit2allow: CIL output mode
2024-02-19 20:18 UTC
[PATCH PR#420] audit2allow: CIL output mode
2024-02-18 20:51 UTC
[PATCH] Always build for LFS mode on 32-bit archs
2024-02-18 3:08 UTC (4+ messages)
[PATCH v10 00/25] security: Move IMA and EVM to the LSM infrastructure
2024-02-16 22:34 UTC (31+ messages)
` [PATCH v10 01/25] ima: Align ima_inode_post_setattr() definition with "
` [PATCH v10 02/25] ima: Align ima_file_mprotect() "
` [PATCH v10 03/25] ima: Align ima_inode_setxattr() "
` [PATCH v10 04/25] ima: Align ima_inode_removexattr() "
` [PATCH v10 05/25] ima: Align ima_post_read_file() "
` [PATCH v10 06/25] evm: Align evm_inode_post_setattr() "
` [PATCH v10 07/25] evm: Align evm_inode_setxattr() "
` [PATCH v10 08/25] evm: Align evm_inode_post_setxattr() "
` [PATCH v10 09/25] security: Align inode_setattr hook definition with EVM
` [PATCH v10 10/25] security: Introduce inode_post_setattr hook
` [PATCH v10 11/25] security: Introduce inode_post_removexattr hook
` [PATCH v10 12/25] security: Introduce file_post_open hook
` [PATCH v10 13/25] security: Introduce file_release hook
` [PATCH v10 14/25] security: Introduce path_post_mknod hook
` [PATCH v10 15/25] security: Introduce inode_post_create_tmpfile hook
` [PATCH v10 16/25] security: Introduce inode_post_set_acl hook
` [PATCH v10 17/25] security: Introduce inode_post_remove_acl hook
` [PATCH v10 18/25] security: Introduce key_post_create_or_update hook
` [PATCH v10 19/25] integrity: Move integrity_kernel_module_request() to IMA
` [PATCH v10 20/25] ima: Move to LSM infrastructure
` [PATCH v10 21/25] ima: Move IMA-Appraisal "
` [PATCH v10 22/25] evm: Move "
` [PATCH v10 23/25] evm: Make it independent from 'integrity' LSM
` [PATCH v10 24/25] ima: "
` [PATCH v10 25/25] integrity: Remove LSM
` [PATCH v10 0/25] security: Move IMA and EVM to the LSM infrastructure
[PATCH] python/semanage: Do not sort local fcontext definitions
2024-02-16 13:12 UTC (3+ messages)
[PATCH] Always build for LFS mode on 32-bit archs
2024-02-16 0:18 UTC
[PATCH v7 0/4] per-vma locks in userfaultfd
2024-02-15 22:19 UTC (6+ messages)
` [PATCH v7 1/4] userfaultfd: move userfaultfd_ctx struct to header file
` [PATCH v7 2/4] userfaultfd: protect mmap_changing with rw_sem in userfaulfd_ctx
` [PATCH v7 3/4] mm: add vma_assert_locked() for !CONFIG_PER_VMA_LOCK
` [PATCH v7 4/4] userfaultfd: use per-vma locks in userfaultfd operations
[PATCH v9 00/25] security: Move IMA and EVM to the LSM infrastructure
2024-02-15 15:02 UTC (59+ messages)
` [PATCH v9 10/25] security: Introduce inode_post_setattr hook
` [PATCH v9 11/25] security: Introduce inode_post_removexattr hook
` [PATCH v9 12/25] security: Introduce file_post_open hook
` [PATCH v9 13/25] security: Introduce file_release hook
` [PATCH v9 14/25] security: Introduce path_post_mknod hook
` [PATCH v9 15/25] security: Introduce inode_post_create_tmpfile hook
` [PATCH v9 16/25] security: Introduce inode_post_set_acl hook
` [PATCH v9 17/25] security: Introduce inode_post_remove_acl hook
` [PATCH v9 19/25] integrity: Move integrity_kernel_module_request() to IMA
` [PATCH v9 20/25] ima: Move to LSM infrastructure
` [PATCH v9 21/25] ima: Move IMA-Appraisal "
` [PATCH v9 22/25] evm: Move "
` [PATCH v9 23/25] evm: Make it independent from 'integrity' LSM
` [PATCH v9 24/25] ima: "
` [PATCH v9 25/25] integrity: Remove LSM
` [PATCH v9 0/25] security: Move IMA and EVM to the LSM infrastructure
[PATCH v6 0/3] per-vma locks in userfaultfd
2024-02-14 22:33 UTC (9+ messages)
` [PATCH v6 1/3] userfaultfd: move userfaultfd_ctx struct to header file
` [PATCH v6 2/3] userfaultfd: protect mmap_changing with rw_sem in userfaulfd_ctx
` [PATCH v6 3/3] userfaultfd: use per-vma locks in userfaultfd operations
[PATCH] python/semanage: Allow modifying records on "add"
2024-02-14 12:08 UTC (2+ messages)
` [PATCH v2] "
[PATCH v5 0/3] per-vma locks in userfaultfd
2024-02-13 20:40 UTC (19+ messages)
` [PATCH v5 1/3] userfaultfd: move userfaultfd_ctx struct to header file
` [PATCH v5 2/3] userfaultfd: protect mmap_changing with rw_sem in userfaulfd_ctx
` [PATCH v5 3/3] userfaultfd: use per-vma locks in userfaultfd operations
[PATCH 01/15] checkpolicy: add libfuzz based fuzzer
2024-02-13 20:39 UTC (28+ messages)
` [PATCH 02/15] checkpolicy: cleanup resources on parse error
` [PATCH 03/15] checkpolicy: cleanup identifiers on error
` [PATCH 04/15] checkpolicy: free ebitmap "
` [PATCH 05/15] checkpolicy: check allocation and free memory on error at type definition
` [PATCH 06/15] checkpolicy: clean expression on error
` [PATCH 07/15] checkpolicy: call YYABORT on parse errors
` [PATCH 08/15] checkpolicy: bail out on invalid role
` [PATCH 09/15] libsepol: use typedef
` [PATCH 10/15] libsepol: add copy member to level_datum
` [PATCH 12/15] checkpolicy: provide more descriptive error messages
` [PATCH 13/15] checkpolicy: free temporary bounds type
` [PATCH 14/15] checkpolicy: avoid assigning garbage values
` [PATCH 15/15] checkpolicy: misc policy_define.c cleanup
[PATCH v4 0/3] per-vma locks in userfaultfd
2024-02-12 22:53 UTC (15+ messages)
` [PATCH v4 1/3] userfaultfd: move userfaultfd_ctx struct to header file
` [PATCH v4 2/3] userfaultfd: protect mmap_changing with rw_sem in userfaulfd_ctx
` [PATCH v4 3/3] userfaultfd: use per-vma locks in userfaultfd operations
[PATCH testsuite] policy: fix testsuite_domain_type_minimal() to work with rpm-ostree
2024-02-12 9:58 UTC (2+ messages)
[PATCH v2 2/3] userfaultfd: protect mmap_changing with rw_sem in userfaulfd_ctx
2024-02-12 8:14 UTC (11+ messages)
Calls to vfs_setlease() from NFSD code cause unnecessary CAP_LEASE security checks
2024-02-08 14:28 UTC (4+ messages)
page: next (older) | prev (newer) | latest
- recent:[subjects (threaded)|topics (new)|topics (active)]
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox