messages from 2025-05-15 07:37:24 to 2025-06-05 18:43:40 UTC [more...]
[PATCH] Only set the initial SID for early-boot userspace tasks if the policy supports the new capability
2025-06-05 18:40 UTC (3+ messages)
[PATCH v2] security,fs,nfs,net: update security_inode_listsecurity() interface
2025-06-05 18:24 UTC (8+ messages)
[PATCH 1/2] fs: Provide function that allocates a secure anonymous inode
2025-06-05 18:23 UTC (3+ messages)
Intent to release 3.9
2025-06-05 17:24 UTC
Recent Linux kernel commit breaks Gnulib test suite
2025-06-05 16:53 UTC (4+ messages)
[PATCH] fs/xattr.c: fix simple_xattr_list()
2025-06-05 16:48 UTC
[PATCH selinux-testsuite 1/2] userns_child_exec: Propagate child exit value
2025-06-05 13:34 UTC (2+ messages)
` [PATCH selinux-testsuite 2/2] Add tests for checkpoint_restore in cap2_userns
selinuxproject.org down?
2025-06-02 12:21 UTC (4+ messages)
[RFC PATCH 0/29] Rework the LSM initialization
2025-05-30 22:03 UTC (18+ messages)
` [RFC PATCH 08/29] lsm: get rid of the lsm_names list and do some cleanup
` [RFC PATCH 25/29] ima,evm: move initcalls to the LSM framework
` [RFC PATCH 26/29] selinux: "
` [RFC PATCH 29/29] lsm: add support for counting lsm_prop support among LSMs
[PATCH v2 1/2] libselinux: prioritize local literal fcontext definitions
2025-05-30 12:30 UTC (2+ messages)
` [PATCH v2 2/2] libselinux: retain LIFO order for path substitutions
[PATCH 1/4] libsepol: update sort order for netifcon definitions
2025-05-30 11:48 UTC (4+ messages)
` [PATCH 2/4] libsepol: add netif_wildcard polcap
` [PATCH 3/4] checkpolicy: add support for wildcard netifcon names
` [PATCH 4/4] secilc/test: add test for wildcard netifcon statement
[PATCH v2 1/3] libsepol: support wildcard network interface names
2025-05-30 5:13 UTC (3+ messages)
` [PATCH v2 2/3] libsepol: Allow multiple policycap statements
` [PATCH v2 3/3] libsepol: Support genfs_seclabel_wildcard
[PATCH 1/2] libsepol: Allow multiple policycap statements
2025-05-30 2:53 UTC (6+ messages)
` [PATCH 2/2] libsepol: Support genfs_seclabel_wildcard
possible regression with filecon equivalency
2025-05-29 16:14 UTC (4+ messages)
SELinux kernel getting started guide
2025-05-28 17:27 UTC
[GIT PULL] selinux/selinux-pr-20250527
2025-05-28 15:41 UTC (2+ messages)
[PATCH v5] libsepol,checkpolicy: introduce neveraudit types
2025-05-23 17:25 UTC (2+ messages)
[PATCH v5 3/7] selinux: implement inode_file_[g|s]etattr hooks
2025-05-22 22:26 UTC (2+ messages)
[PATCH v5 2/7] lsm: introduce new hooks for setting/getting inode fsxattr
2025-05-22 22:26 UTC (2+ messages)
[PATCH v4] libsepol,checkpolicy: introduce neveraudit types
2025-05-22 16:06 UTC (2+ messages)
[PATCH v3] libsepol,checkpolicy: introduce neveraudit types
2025-05-21 17:42 UTC
[PATCH 1/2] selinux: introduce neveraudit types
2025-05-21 16:35 UTC (12+ messages)
` [PATCH 2/2] selinux: optimize selinux_inode_getattr/permission() based on neveraudit|permissive
[PATCH v2 1/2] selinux: introduce neveraudit types
2025-05-21 14:41 UTC (2+ messages)
` [PATCH v2 2/2] selinux: optimize selinux_inode_getattr/permission() based on neveraudit|permissive
[PATCH v5 0/7] fs: introduce file_getattr and file_setattr syscalls
2025-05-21 10:44 UTC (12+ messages)
[PATCH RESEND v17 1/3] lsm, selinux: Add setup_report permission to binder
2025-05-21 4:13 UTC (3+ messages)
` [PATCH "
[PATCH] SELinux: Add check for the user data passed to kcalloc in hashtab_init
2025-05-20 23:46 UTC (3+ messages)
[PATCH] selinux: add a 5 second sleep to /sys/fs/selinux/user
2025-05-20 21:22 UTC (2+ messages)
[RFC PATCH 4/6] selinux: improve network lookup failure warnings
2025-05-20 21:09 UTC (2+ messages)
` [PATCH RFC "
[PATCH v2] libsepol,checkpolicy: introduce neveraudit types
2025-05-20 19:54 UTC (2+ messages)
[PATCH] userspace: Make git ignore files '.vimrc' and 'tags'
2025-05-20 13:37 UTC (2+ messages)
[PATCH v2 00/49] SELinux namespace support
2025-05-20 12:06 UTC (53+ messages)
` [PATCH v2 01/49] selinux: restore passing of selinux_state
` [PATCH v2 02/49] selinux: introduce current_selinux_state
` [PATCH v2 03/49] selinux: support multiple selinuxfs instances
` [PATCH v2 04/49] selinux: dynamically allocate selinux namespace
` [PATCH v2 05/49] netstate,selinux: create the selinux netlink socket per network namespace
` [PATCH v2 06/49] selinux: support per-task/cred selinux namespace
` [PATCH v2 07/49] selinux: introduce cred_selinux_state() and use it
` [PATCH v2 08/49] selinux: add a selinuxfs interface to unshare selinux namespace
` [PATCH v2 09/49] selinuxfs: restrict write operations to the same "
` [PATCH v2 10/49] selinux: introduce a global SID table
` [PATCH v2 11/49] selinux: wrap security server interfaces to use the "
` [PATCH v2 12/49] selinux: update hook functions to use correct selinux namespace
` [PATCH v2 13/49] selinux: introduce cred_task_has_perm()
` [PATCH v2 14/49] selinux: introduce cred_has_extended_perms()
` [PATCH v2 15/49] selinux: introduce cred_self_has_perm()
` [PATCH v2 16/49] selinux: introduce cred_has_perm()
` [PATCH v2 17/49] selinux: introduce cred_ssid_has_perm() and cred_other_has_perm()
` [PATCH v2 18/49] selinux: introduce task_obj_perm()
` [PATCH v2 19/49] selinux: fix selinux_lsm_getattr() check
` [PATCH v2 20/49] selinux: update bprm hooks for selinux namespaces
` [PATCH v2 21/49] selinux: add kerneldoc to new permission checking functions
` [PATCH v2 22/49] selinux: convert selinux_file_send_sigiotask() to namespace-aware helper
` [PATCH v2 23/49] selinux: rename cred_has_perm*() to cred_tsid_has_perm*()
` [PATCH v2 24/49] selinux: convert additional checks to cred_ssid_has_perm()
` [PATCH v2 25/49] selinux: introduce selinux_state_has_perm()
` [PATCH v2 26/49] selinux: annotate selinuxfs permission checks
` [PATCH v2 27/49] selinux: annotate process transition "
` [PATCH v2 28/49] selinux: convert xfrm and netlabel "
` [PATCH v2 29/49] selinux: switch selinux_lsm_setattr() checks to current namespace
` [PATCH v2 30/49] selinux: add limits for SELinux namespaces
` [PATCH v2 31/49] selinux: fix namespace creation
` [PATCH v2 32/49] selinux: limit selinux netlink notifications to init namespace
` [PATCH v2 33/49] selinux: refactor selinux_state_create()
` [PATCH v2 34/49] selinux: make open_perms namespace-aware
` [PATCH v2 35/49] selinux: split cred_ssid_has_perm() into two cases
` [PATCH v2 36/49] selinux: set initial SID context for init to "kernel" in global SID table
` [PATCH v2 37/49] selinux: disallow writes to /sys/fs/selinux/user in non-init namespaces
` [PATCH v2 38/49] selinux: convert nlmsg_sock_has_extended_perms() to namespace-aware
` [PATCH v2 39/49] selinux: init inode from nearest initialized namespace
` [PATCH v2 40/49] selinux: allow userspace to detect non-init SELinux namespace
` [PATCH v2 41/49] selinux: exempt creation of init SELinux namespace from limits
` [PATCH v2 42/49] selinux: introduce a Kconfig option for SELinux namespaces
` [PATCH v2 43/49] selinux: eliminate global SID table if !CONFIG_SECURITY_SELINUX_NS
` [PATCH v2 44/49] selinux: maintain a small cache in the global SID table
` [PATCH v2 45/49] selinux: change /sys/fs/selinux/unshare to check current process state
` [PATCH v2 46/49] selinux: acquire/release SELinux state properly in socket hooks
` [PATCH v2 47/49] selinux: update cred_tsid_has_perm_noaudit() to return the combined avd
` [PATCH v2 48/49] selinux: repair security_fs_use() interface and its users
` [PATCH v2 49/49] selinux: style cleanups for node_sid prototypes
[PATCH v3 00/42] SELinux namespace support
2025-05-20 11:59 UTC (43+ messages)
` [PATCH v3 01/42] selinux: restore passing of selinux_state
` [PATCH v3 02/42] selinux: introduce current_selinux_state
` [PATCH v3 03/42] selinux: support multiple selinuxfs instances
` [PATCH v3 04/42] selinux: dynamically allocate selinux namespace
` [PATCH v3 05/42] netstate,selinux: create the selinux netlink socket per network namespace
` [PATCH v3 06/42] selinux: limit selinux netlink notifications to init namespace
` [PATCH v3 07/42] selinux: support per-task/cred selinux namespace
` [PATCH v3 08/42] selinux: introduce cred_selinux_state() and use it
` [PATCH v3 09/42] selinux: add a selinuxfs interface to unshare selinux namespace
` [PATCH v3 10/42] selinux: add limits for SELinux namespaces
` [PATCH v3 11/42] selinux: exempt creation of init SELinux namespace from limits
` [PATCH v3 12/42] selinux: refactor selinux_state_create()
` [PATCH v3 13/42] selinux: allow userspace to detect non-init SELinux namespace
` [PATCH v3 14/42] selinuxfs: restrict write operations to the same selinux namespace
` [PATCH v3 15/42] selinux: introduce a global SID table
` [PATCH v3 16/42] selinux: wrap security server interfaces to use the "
` [PATCH v3 17/42] selinux: introduce a Kconfig option for SELinux namespaces
` [PATCH v3 18/42] selinux: eliminate global SID table if !CONFIG_SECURITY_SELINUX_NS
` [PATCH v3 19/42] selinux: maintain a small cache in the global SID table
` [PATCH v3 20/42] selinux: update hook functions to use correct selinux namespace
` [PATCH v3 21/42] selinux: introduce cred_task_has_perm()
` [PATCH v3 22/42] selinux: introduce cred_has_extended_perms()
` [PATCH v3 23/42] selinux: introduce cred_self_has_perm()
` [PATCH v3 24/42] selinux: introduce cred_has_perm()
` [PATCH v3 25/42] selinux: introduce cred_ssid_has_perm() and cred_other_has_perm()
` [PATCH v3 26/42] selinux: introduce task_obj_perm()
` [PATCH v3 27/42] selinux: update bprm hooks for selinux namespaces
` [PATCH v3 28/42] selinux: add kerneldoc to new permission checking functions
` [PATCH v3 29/42] selinux: convert selinux_file_send_sigiotask() to namespace-aware helper
` [PATCH v3 30/42] selinux: rename cred_has_perm*() to cred_tsid_has_perm*()
` [PATCH v3 31/42] selinux: update cred_tsid_has_perm_noaudit() to return the combined avd
` [PATCH v3 32/42] selinux: convert additional checks to cred_ssid_has_perm()
` [PATCH v3 33/42] selinux: introduce selinux_state_has_perm()
` [PATCH v3 34/42] selinux: annotate selinuxfs permission checks
` [PATCH v3 35/42] selinux: annotate process transition "
` [PATCH v3 36/42] selinux: convert xfrm and netlabel "
` [PATCH v3 37/42] selinux: switch selinux_lsm_setattr() checks to current namespace
` [PATCH v3 38/42] selinux: make open_perms namespace-aware
` [PATCH v3 39/42] selinux: split cred_ssid_has_perm() into two cases
` [PATCH v3 40/42] selinux: disallow writes to /sys/fs/selinux/user in non-init namespaces
` [PATCH v3 41/42] selinux: convert nlmsg_sock_has_extended_perms() to namespace-aware
` [PATCH v3 42/42] selinux: init inode from nearest initialized namespace
[PATCH 6.1.y] selinux: avoid dereference of garbage after mount failure
2025-05-20 11:18 UTC (2+ messages)
[PATCH v3 01/14] selinux: avoid nontransitive comparison
2025-05-17 21:53 UTC (4+ messages)
` [PATCH v3 02/14] selinux: use u16 for security classes
Recent selinux-testsuite failures in tests/mmap:109 (execheap/execmem)
2025-05-16 19:54 UTC (4+ messages)
[PATCH 0/2] fs/exec: Explicitly unshare fs_struct on exec
2025-05-15 16:48 UTC (12+ messages)
` [PATCH 1/2] "
[PATCH] Fix variable type to be 'bool' instead of incorrect 'int'
2025-05-15 14:22 UTC (2+ messages)
[PATCH] libselinux: prioritize local literal fcontext definitions
2025-05-15 9:52 UTC (5+ messages)
[PATCH] Trivial fix comment
2025-05-15 9:27 UTC
[PATCH] A trivial simplification to shorten the code a bit
2025-05-15 9:26 UTC
[PATCH v5 0/7] fs: introduce file_getattr and file_setattr syscalls
2025-05-15 7:50 UTC (6+ messages)
` [PATCH v5 2/7] lsm: introduce new hooks for setting/getting inode fsxattr
[PATCH] userspace: Make git ignore ctags output file called 'tags'
2025-05-15 7:37 UTC (2+ messages)
page: next (older) | prev (newer) | latest
- recent:[subjects (threaded)|topics (new)|topics (active)]
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox