SPARC and UltraSPARC platform development
 help / color / mirror / Atom feed
[PATCH 00/22] Simplify special kernel page table handling
 2026-08-05 12:07 UTC  (45+ messages)
` [PATCH 01/22] mm: drop unused __mm_flags_set_mask_bits_word()
` [PATCH 02/22] mm: move mm_flags helpers to mm_types.h
` [PATCH 03/22] mm: introduce MMF_KERNEL flag and set it for init_mm
` [PATCH 04/22] mm: use mm_is_kernel() in generic page table code
` [PATCH 05/22] arm64: mm: use mm_is_kernel() for kernel mm checks
` [PATCH 06/22] loongarch: mm: use mm_is_kernel() in switch_mm_irqs_off()
` [PATCH 07/22] parisc: mm: use mm_is_kernel() for kernel mm checks
` [PATCH 08/22] powerpc: "
` [PATCH 09/22] s390: "
` [PATCH 10/22] sparc: "
` [PATCH 11/22] um: mm: use mm_is_kernel() in TLB sync
` [PATCH 12/22] x86/mm: use mm_is_kernel() for kernel mm checks
` [PATCH 13/22] mm: account page table pages when allocated
` [PATCH 14/22] mm: set page table page type "
` [PATCH 15/22] mm: only initialise pt_share_count for user pgtables
` [PATCH 16/22] efi: mark efi_mm as a kernel mm
` [PATCH 17/22] mm: pagewalk: drop redundant address check for kernel mm walks
` [PATCH 18/22] arm64: mm: drop explicit mm_is_efi() check in contpte
` [PATCH 19/22] x86/tboot: mark tboot_mm as a kernel mm
` [PATCH 20/22] arm64: mm: drop ctor/dtor calls for kernel page tables
` [PATCH 21/22] arm: mm: drop ctor call "
` [PATCH 22/22] riscv: mm: drop ctor/dtor calls "

[PATCH v4 0/3] Introduce arch_do_panic
 2026-08-05 10:11 UTC  (6+ messages)
` [PATCH v4 1/3] panic: "
` [PATCH v4 2/3] s390: Implement arch_do_panic()
` [PATCH v4 3/3] sparc: Implement arch_do_panic

[PATCH 0/3] alpha: fix floating-point exception state handling
 2026-08-05  9:33 UTC  (7+ messages)
` [PATCH 1/3] alpha: fix ieee_swcr_to_fpcr setting FPCR_DNOD unconditionally
` [PATCH 2/3] alpha: don't leak hardware-fabricated FP exception bits to user space
` [PATCH 3/3] alpha: determine tininess after rounding in the FP emulation

[PATCH v2 0/2] tty: vcc: Some small vcc bugfixes found by code scans
 2026-08-04  5:13 UTC  (5+ messages)
` [PATCH v2 1/2] tty: vcc: zero-initialize control packet in vcc_send_ctl()
` [PATCH v2 2/2] tty: vcc: hold port lock when clearing tty pointer in vcc_cleanup

[PATCH 0/2] tty: vcc: Some small vcc bugfixes found by code scans
 2026-08-03 14:09 UTC  (9+ messages)
` [PATCH 1/2] tty: vcc: zero-initialize control packet in vcc_send_ctl()
` [PATCH 2/2] tty: vcc: hold port lock when clearing tty pointer in vcc_cleanup

[PATCH] net/bpf_jit: SPARC: drop unneeded semicolon
 2026-08-01 19:44 UTC  (2+ messages)

[Bug 221820] New: sparc64 mmap() returns EINVAL for non-MAP_FIXED hint within VA_EXCLUDE_START...END
 2026-08-01 19:06 UTC 

[PATCH v3 0/3] Introduce arch_do_panic
 2026-07-30 14:23 UTC  (8+ messages)
` [PATCH v3 1/3] panic: "
` [PATCH v3 2/3] s390: Implement arch_do_panic
` [PATCH v3 3/3] sparc: "

[PATCH v2 0/3] Introduce arch_do_panic
 2026-07-29 12:06 UTC  (15+ messages)
` [PATCH v2 1/3] panic: "
` [PATCH v2 2/3] s390: Implement arch_do_panic
` [PATCH v2 3/3] sparc: "

[PATCH bpf-next] bpf, sparc: Add support for BPF_SDIV and BPF_SMOD in the sparc64 JIT
 2026-07-29  1:36 UTC  (3+ messages)

[PATCH 0/3] Introduce arch_do_panic
 2026-07-27  8:58 UTC  (4+ messages)
` [PATCH 1/3] panic: "
` [PATCH 2/3] s390: Implement arch_do_panic
` [PATCH 3/3] sparc: "

[patch 00/18] entry: Consolidate and rework syscall entry handling
 2026-07-21  8:17 UTC  (102+ messages)
` [patch 01/18] powerpc: Move stack randomization after syscall_enter_from_user_mode()
` [patch 02/18] randomize_kstack: Provide add_random_kstack_offset_irqsoff()
` [patch 03/18] entry: Provide [syscall_]enter_from_user_mode_randomize_stack()
` [patch 04/18] loongarch/syscall: Use syscall_enter_from_user_mode_randomize_stack()
` [patch 05/18] powerpc/syscall: "
` [patch 06/18] riscv/syscall: "
` [patch 07/18] s390/syscall: Use enter_from_user_mode_randomize_stack()
` [patch 08/18] x86/syscall: Use [syscall_]enter_from_user_mode_randomize_stack()
` [patch 09/18] entry: Remove syscall_enter_from_user_mode()
` [patch 10/18] entry: Use syscall number instead of rereading it
` [patch 11/18] seccomp, treewide: Rename and convert __secure_computing() to return boolean
` [patch 12/18] ptrace, treewide: Rename ptrace_report_syscall_entry() to ptrace_report_syscall_permit_entry()
` [patch 13/18] entry: Make trace_syscall_enter() return type bool
` [patch 14/18] entry: Make return type of syscall_trace_enter() bool
` [patch 15/18] x86/entry: Make syscall functions static
` [patch 16/18] x86/entry: Get rid of the sys_ni_syscall() indirection
` [patch 17/18] x86/entry: Simplify the syscall number logic
` [patch 18/18] entry, treewide: Make syscall_enter_from_user_mode[_work]() indicate syscall execution

[PATCH] ioport: Use kzalloc() instead of kmalloc()/memset() in _sparc_alloc_io()
 2026-07-14  9:13 UTC 

Dear sparclinux, project info
 2026-07-14  5:30 UTC 


This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox