From mboxrd@z Thu Jan 1 00:00:00 1970 Content-Type: multipart/mixed; boundary="===============8513525780482925993==" MIME-Version: 1.0 From: Harris, James R Subject: Re: [SPDK] RPC Naming Date: Thu, 09 May 2019 15:47:11 +0000 Message-ID: <08FE1D59-F385-4D2E-8048-DEF5FF9192A5@intel.com> List-ID: To: spdk@lists.01.org --===============8513525780482925993== Content-Type: text/plain; charset="utf-8" MIME-Version: 1.0 Content-Transfer-Encoding: quoted-printable My intention is that the old names could stick around for years if necessar= y. But we will want to update the Cinder driver at some point to use the n= ew names. -Jim =EF=BB=BFOn 5/9/19, 7:03 AM, "SPDK on behalf of Szwed, Maciej" wrote: Hi Jim, "We could keep the old names around as aliases for as long as needed." = - that might be very long. For example: Cinder driver uses RPC calls and ch= aning it in this driver may cause that some older user setups may stop work= ing. We have to be very careful about such changes - I'm sure you are aware= of that, but I just wanted point that in case somebody else may have simil= ar situation but not be fully aware. = Maciek = -----Original Message----- From: SPDK [mailto:spdk-bounces(a)lists.01.org] On Behalf Of Harris, Ja= mes R Sent: Wednesday, May 8, 2019 1:10 AM To: Storage Performance Development Kit Subject: [SPDK] RPC Naming = There has been quite a bit of chatter recently about the SPDK RPCs =E2= =80=93 lack of meaningful error codes in a lot of the RPCs, and at least on= e RPC returning data in an array with different =E2=80=9Ctypes=E2=80=9D. A= nother sore point is the naming of the RPCs themselves. = = 1. construct v. create (the vast majority use =E2=80=9Cconstruct=E2= =80=9D) 2. destruct v. delete v. destroy (the vast majority use =E2=80=9Cdel= ete=E2=80=9D) 3. most contain their associated component name in the RPC names, bu= t some of the oldest ones from iscsi do not 4. most do not follow a noun_verb(_object) naming convention 5. minor nits like =E2=80=9Cconstruct_nvme_bdev=E2=80=9D =E2=80=93 t= his really attaches an nvme controller, which then creates bdevs for each n= amespace (there could be many) = I=E2=80=99ve put out a patch series (https://review.gerrithub.io/c/spdk= /spdk/+/453036) with suggested names for all of our existing RPCs =E2=80=93= there are almost 150 of them now. All of the old names would still be val= id, but deprecated. We could keep the old names around as aliases for as l= ong as needed. = The patch series has an example of how the get_rpc_methods RPC would be= converted to rpc_get_methods, and converts the previously deprecated get/s= et/clear_trace_flag RPCs to use this new framework. Thanks to Ben Walker f= or his help on making some of the Python infrastructure for this simpler th= an I originally coded it. = If you have an interest in the SPDK RPC API, please take some time and = review this patch set. = Thanks, = -Jim = _______________________________________________ SPDK mailing list SPDK(a)lists.01.org https://lists.01.org/mailman/listinfo/spdk _______________________________________________ SPDK mailing list SPDK(a)lists.01.org https://lists.01.org/mailman/listinfo/spdk = --===============8513525780482925993==--