From mboxrd@z Thu Jan 1 00:00:00 1970 Content-Type: multipart/mixed; boundary="===============8245542035961492169==" MIME-Version: 1.0 From: Harris, James R Subject: [SPDK] RPC Naming Date: Tue, 07 May 2019 23:09:31 +0000 Message-ID: <76F2E352-3DBA-4EB3-8E8D-DA326D781959@intel.com> List-ID: To: spdk@lists.01.org --===============8245542035961492169== Content-Type: text/plain; charset="utf-8" MIME-Version: 1.0 Content-Transfer-Encoding: quoted-printable There has been quite a bit of chatter recently about the SPDK RPCs =E2=80= =93 lack of meaningful error codes in a lot of the RPCs, and at least one R= PC returning data in an array with different =E2=80=9Ctypes=E2=80=9D. Anot= her sore point is the naming of the RPCs themselves. 1. construct v. create (the vast majority use =E2=80=9Cconstruct=E2=80= =9D) 2. destruct v. delete v. destroy (the vast majority use =E2=80=9Cdelete= =E2=80=9D) 3. most contain their associated component name in the RPC names, but so= me of the oldest ones from iscsi do not 4. most do not follow a noun_verb(_object) naming convention 5. minor nits like =E2=80=9Cconstruct_nvme_bdev=E2=80=9D =E2=80=93 this = really attaches an nvme controller, which then creates bdevs for each names= pace (there could be many) I=E2=80=99ve put out a patch series (https://review.gerrithub.io/c/spdk/spd= k/+/453036) with suggested names for all of our existing RPCs =E2=80=93 the= re are almost 150 of them now. All of the old names would still be valid, = but deprecated. We could keep the old names around as aliases for as long = as needed. The patch series has an example of how the get_rpc_methods RPC would be con= verted to rpc_get_methods, and converts the previously deprecated get/set/c= lear_trace_flag RPCs to use this new framework. Thanks to Ben Walker for h= is help on making some of the Python infrastructure for this simpler than I= originally coded it. If you have an interest in the SPDK RPC API, please take some time and revi= ew this patch set. Thanks, -Jim --===============8245542035961492169==--