Linux kernel -stable discussions
 help / color / mirror / Atom feed
From: Greg KH <greg@kroah.com>
To: "Thomas Weißschuh" <thomas.weissschuh@linutronix.de>
Cc: stable@vger.kernel.org, Matthew Wilcox <willy@infradead.org>,
	Linus Torvalds <torvalds@linux-foundation.org>,
	Ben Hutchings <ben@decadent.org.uk>
Subject: Re: [PATCH 5.10.y 5.15.y 6.1.y 6.6.y 6.12.y 6.18.y 6.19.y] ARM: clean up the memset64() C wrapper
Date: Wed, 25 Feb 2026 07:14:09 -0800	[thread overview]
Message-ID: <2026022556-poise-retrial-2090@gregkh> (raw)
In-Reply-To: <20260225160327-91efd064-656c-409c-a1e1-aa8433a3ba6e@linutronix.de>

On Wed, Feb 25, 2026 at 04:08:23PM +0100, Thomas Weißschuh wrote:
> On Wed, Feb 25, 2026 at 06:36:13AM -0800, Greg KH wrote:
> > On Wed, Feb 25, 2026 at 12:35:09PM +0100, Thomas Weißschuh wrote:
> > > [ Upstream commit b52343d1cb47bb27ca32a3f4952cc2fd3cd165bf ]
> > > 
> > > The current logic to split the 64-bit argument into its 32-bit halves is
> > > byte-order specific and a bit clunky.  Use a union instead which is
> > > easier to read and works in all cases.
> > > 
> > > GCC still generates the same machine code.
> > > 
> > > While at it, rename the arguments of the __memset64() prototype to
> > > actually reflect their semantics.
> > > 
> > > Signed-off-by: Thomas Weißschuh <thomas.weissschuh@linutronix.de>
> > > Signed-off-by: Linus Torvalds <torvalds@linux-foundation.org>
> > > Reported-by: Ben Hutchings <ben@decadent.org.uk> # for -stable
> > > Link: https://lore.kernel.org/all/1a11526ae3d8664f705b541b8d6ea57b847b49a8.camel@decadent.org.uk/
> > > Suggested-by: https://lore.kernel.org/all/aZonkWMwpbFhzDJq@casper.infradead.org/ # for -stable
> > > Link: https://lore.kernel.org/all/aZonkWMwpbFhzDJq@casper.infradead.org/
> > > ---
> > > Hi stable team,
> > > 
> > > unfortunately the backports of commit 23ea2a4c7232 ("ARM: 9468/1: fix
> > > memset64() on big-endian") does not work on 5.10 and 5.15 as
> > > CONFIG_CPU_LITTLE_ENDIAN does not exist there, effectively breaking memset64()
> > > on little-endian. Please use this variant instead which always works.
> > > For consistency I prefer to have it backported to all versions.
> > > ---
> > >  arch/arm/include/asm/string.h | 14 +++++++++-----
> > >  1 file changed, 9 insertions(+), 5 deletions(-)
> > > 
> > > diff --git a/arch/arm/include/asm/string.h b/arch/arm/include/asm/string.h
> > > index b5ad23acb303..369781ec5511 100644
> > > --- a/arch/arm/include/asm/string.h
> > > +++ b/arch/arm/include/asm/string.h
> > > @@ -33,13 +33,17 @@ static inline void *memset32(uint32_t *p, uint32_t v, __kernel_size_t n)
> > >  }
> > >  
> > >  #define __HAVE_ARCH_MEMSET64
> > > -extern void *__memset64(uint64_t *, uint32_t low, __kernel_size_t, uint32_t hi);
> > > +extern void *__memset64(uint64_t *, uint32_t first, __kernel_size_t, uint32_t second);
> > >  static inline void *memset64(uint64_t *p, uint64_t v, __kernel_size_t n)
> > >  {
> > > -	if (IS_ENABLED(CONFIG_CPU_LITTLE_ENDIAN))
> > > -		return __memset64(p, v, n * 8, v >> 32);
> > > -	else
> > > -		return __memset64(p, v >> 32, n * 8, v);
> > > +	union {
> > > +		uint64_t val;
> > > +		struct {
> > > +			uint32_t first, second;
> > > +		};
> > > +	} word = { .val = v };
> > > +
> > > +	return __memset64(p, word.first, n * 8, word.second);
> > >  }
> > >  
> > >  #endif
> > > 
> > > ---
> > 
> > I don't understand, why is this patch needed at all?  What issue is it
> > fixing to require this?
> 
> memset64() was broken on ARM big-endian. It was fixed in commit 23ea2a4c7232
> ("ARM: 9468/1: fix memset64() on big-endian"). That fix was marked with a Fixes:
> tag and was backported to all stable kernels. However that fix relies on the
> kconfig symbol CONFIG_CPU_LITTLE_ENDIAN (as shown in the diff above).
> That kconfig symbol does not exist on 5.10 and 5.15. So now memset64() is
> broken on ARM little-endian on those branches.

So on ALL branches?  When did that config option get added?

> The proposed works always, without requiring kconfig options.
> The Fixes: tag target would differ between the stable branches,
> so I left it out.

A fixes: for commit 23ea2a4c7232 should be correct, right?

thanks,

greg k-h

  reply	other threads:[~2026-02-25 15:14 UTC|newest]

Thread overview: 6+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2026-02-25 11:35 [PATCH 5.10.y 5.15.y 6.1.y 6.6.y 6.12.y 6.18.y 6.19.y] ARM: clean up the memset64() C wrapper Thomas Weißschuh
2026-02-25 14:36 ` Greg KH
2026-02-25 15:08   ` Thomas Weißschuh
2026-02-25 15:14     ` Greg KH [this message]
2026-02-25 16:03       ` Thomas Weißschuh
2026-02-25 16:18         ` Greg KH

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=2026022556-poise-retrial-2090@gregkh \
    --to=greg@kroah.com \
    --cc=ben@decadent.org.uk \
    --cc=stable@vger.kernel.org \
    --cc=thomas.weissschuh@linutronix.de \
    --cc=torvalds@linux-foundation.org \
    --cc=willy@infradead.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox