From mboxrd@z Thu Jan 1 00:00:00 1970 From: Dave Liu Date: Wed, 19 Mar 2008 17:08:59 +0800 Subject: [U-Boot-Users] [PATCH v1 2/5] ATA: Add the libata support In-Reply-To: References: Message-ID: <1205917739.3654.81.camel@localhost.localdomain> List-Id: MIME-Version: 1.0 Content-Type: text/plain; charset="us-ascii" Content-Transfer-Encoding: 7bit To: u-boot@lists.denx.de On Wed, 2008-03-19 at 09:35 +0000, Tor Krill wrote: > After some further work with these pathces. (I currently work on a > SIL3114 driver using them) > > It seems like there is a "lot" of code duplication in libata.h and the > existant ata.h. Thus making it impossible to include both ones. Which i > would like to do. Yes, it is my one concern. My another concern is, the common dir originally have one cmd_sata.c. However, the cmd_sata.c is not generic. Wolfgang, How do we handle it? > Pasted below is the modifications i did to do to get it working. > > Could one perhaps merge the differences? Or is there other suggestions on > how to solve this? So, Wolfgang, Can we merge the new stuff from libata.h to ata.h? Thanks, Dave