From: Anatolij Gustschin <agust@denx.de>
To: u-boot@lists.denx.de
Subject: [U-Boot] [PATCH v6 10/26] pmic:battery: Support for Trats Battery at PMIC framework
Date: Sat, 10 Nov 2012 01:11:55 +0100 [thread overview]
Message-ID: <20121110011155.618a50c3@wker> (raw)
In-Reply-To: <1352446951-12558-11-git-send-email-l.majewski@samsung.com>
Hi Lukasz,
On Fri, 09 Nov 2012 08:42:15 +0100
Lukasz Majewski <l.majewski@samsung.com> wrote:
...
> +int power_bat_init(unsigned char bus)
> +{
> + struct pmic *p = pmic_alloc();
> + static const char name[] = "BAT_TRATS";
> +
> + debug("Board BAT init\n");
> +
> + p->interface = PMIC_NONE;
> + p->name = name;
> + p->bus = bus;
Please check the return value of pmic_alloc() before accessing.
Thanks,
Anatolij
next prev parent reply other threads:[~2012-11-10 0:11 UTC|newest]
Thread overview: 31+ messages / expand[flat|nested] mbox.gz Atom feed top
2012-11-09 7:42 [U-Boot] [PATCH v6 00/26] pmic: Redesign PMIC framework to support multiple instances of devices Lukasz Majewski
2012-11-09 7:42 ` [U-Boot] [PATCH v6 01/26] pmic:i2c: Handle PMIC I2C transmission comprising of two bytes Lukasz Majewski
2012-11-09 7:42 ` [U-Boot] [PATCH v6 02/26] pmic:i2c: Add I2C sensor byte order (big/little) to PMIC framework Lukasz Majewski
2012-11-09 7:42 ` [U-Boot] [PATCH v6 03/26] pmic:max8997: Switch the MAX8997 PMIC to be used with multibus I2C Lukasz Majewski
2012-11-09 7:42 ` [U-Boot] [PATCH v6 04/26] pmic: Extend PMIC framework to support multiple instances of PMIC devices Lukasz Majewski
2012-11-10 0:01 ` Anatolij Gustschin
2012-11-12 8:23 ` Lukasz Majewski
2012-11-09 7:42 ` [U-Boot] [PATCH v6 05/26] pmic: Introduce power_init_board() method at ./lib/board.c file Lukasz Majewski
2012-11-09 7:42 ` [U-Boot] [PATCH v6 06/26] pmic: Enable power_board_init() support at TRATS Lukasz Majewski
2012-11-09 7:42 ` [U-Boot] [PATCH v6 07/26] pmic:chrg: Common information about charger and battery (power_chrg.h) Lukasz Majewski
2012-11-09 7:42 ` [U-Boot] [PATCH v6 08/26] pmic: Move pmic related code to ./drivers/power directory Lukasz Majewski
2012-11-09 7:42 ` [U-Boot] [PATCH v6 09/26] pmic: Extend struct pmic to support battery and charger related operations Lukasz Majewski
2012-11-09 7:42 ` [U-Boot] [PATCH v6 10/26] pmic:battery: Support for Trats Battery at PMIC framework Lukasz Majewski
2012-11-10 0:11 ` Anatolij Gustschin [this message]
2012-11-09 7:42 ` [U-Boot] [PATCH v6 11/26] pmic:muic: Support for MUIC built into MAX8997 device Lukasz Majewski
2012-11-10 0:17 ` Anatolij Gustschin
2012-11-09 7:42 ` [U-Boot] [PATCH v6 12/26] pmic:fuel-gauge: Support for MAX17042 fuel-gauge Lukasz Majewski
2012-11-09 7:42 ` [U-Boot] [PATCH v6 13/26] pmic:max8997: Function for calculating LDO internal register value Lukasz Majewski
2012-11-09 7:42 ` [U-Boot] [PATCH v6 14/26] arm:trats:pmic: Default PMIC(MAX8997) initialization for Samsung's TRATS board Lukasz Majewski
2012-11-09 7:42 ` [U-Boot] [PATCH v6 15/26] arm:trats:pmic: Enable MUIC (MAX8997) at " Lukasz Majewski
2012-11-09 7:42 ` [U-Boot] [PATCH v6 16/26] arm:trats:pmic: Enable fuel-gauge (MAX17042) " Lukasz Majewski
2012-11-09 7:42 ` [U-Boot] [PATCH v6 17/26] arm:trats:pmic: Enable battery support " Lukasz Majewski
2012-11-09 7:42 ` [U-Boot] [PATCH v6 18/26] pmic:max8997: Support for MAX8997 internal charger control Lukasz Majewski
2012-11-09 7:42 ` [U-Boot] [PATCH v6 19/26] arm:trats:pmic: Power consumption reduction state for Samsung's TRATS board Lukasz Majewski
2012-11-09 7:42 ` [U-Boot] [PATCH v6 20/26] arm:trats:pmic: Support for charging battery at " Lukasz Majewski
2012-11-09 7:42 ` [U-Boot] [PATCH v6 21/26] pmic: Extend PMIC framework to support battery related commands Lukasz Majewski
2012-11-09 7:42 ` [U-Boot] [PATCH v6 22/26] power:pmic: Rename ./drivers/power/pmic_* to ./drivers/power/power_* files Lukasz Majewski
2012-11-09 7:42 ` [U-Boot] [PATCH v6 23/26] power:pmic: Rename CONFIG_PMIC* defines to CONFIG_POWER Lukasz Majewski
2012-11-09 7:42 ` [U-Boot] [PATCH v6 24/26] power:pmic: Rename CONFIG_DIALOG_PMIC defines to CONFIG_DIALOG_POWER Lukasz Majewski
2012-11-09 7:42 ` [U-Boot] [PATCH v6 25/26] arm:goni:pmic: Adjust GONI target platform board to new PMIC framework Lukasz Majewski
2012-11-09 7:42 ` [U-Boot] [PATCH v6 26/26] arm:universal_c210:pmic: Adjust C210 Universal " Lukasz Majewski
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20121110011155.618a50c3@wker \
--to=agust@denx.de \
--cc=u-boot@lists.denx.de \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox