From mboxrd@z Thu Jan 1 00:00:00 1970 From: Tom Rini Date: Mon, 5 Dec 2016 11:04:09 -0500 Subject: [U-Boot] [PATCH 4/6] mmc: move CONFIG_SDHCI to Kconfig, renaming to CONFIG_MMC_SDHCI In-Reply-To: <1480857794-27145-5-git-send-email-yamada.masahiro@socionext.com> References: <1480857794-27145-1-git-send-email-yamada.masahiro@socionext.com> <1480857794-27145-5-git-send-email-yamada.masahiro@socionext.com> Message-ID: <20161205160409.GN4248@bill-the-cat> List-Id: MIME-Version: 1.0 Content-Type: text/plain; charset="us-ascii" Content-Transfer-Encoding: 7bit To: u-boot@lists.denx.de On Sun, Dec 04, 2016 at 10:23:12PM +0900, Masahiro Yamada wrote: > Move CONFIG_SDHCI to Kconfig and rename it to CONFIG_MMC_SDHCI. > My motivation for the rename is, ultimately, to make all the MMC > options prefixed with MMC_ and SDHCI options with MMC_SDHCI_, > like Linux. > > This commit was created as follows: > > [1] Rename the config option with the following command: > find . -name .git -prune -o ! -path ./scripts/config_whitelist.txt \ > -type f -print | xargs sed -i -e 's/CONFIG_SDHCI/CONFIG_MMC_SDHCI/g' > > [2] create the entry for MMC_SDHCI in drivers/mmc/Kconfig > > [3] run "tools/moveconfig MMC_SDHCI" > > [4] add "depends on MMC_SDHCI" to existing SDHCI driver entries > > Signed-off-by: Masahiro Yamada Reviewed-by: Tom Rini -- Tom -------------- next part -------------- A non-text attachment was scrubbed... Name: signature.asc Type: application/pgp-signature Size: 819 bytes Desc: Digital signature URL: