From mboxrd@z Thu Jan 1 00:00:00 1970 From: Tom Rini Date: Fri, 24 Aug 2018 11:01:59 -0400 Subject: [U-Boot] [PATCH 2/8] arm: K3: Add support for AM654 SoC definition In-Reply-To: References: <20180821143055.29012-1-lokeshvutla@ti.com> <20180821143055.29012-3-lokeshvutla@ti.com> <20180824141100.GL26633@bill-the-cat> Message-ID: <20180824150159.GB26633@bill-the-cat> List-Id: MIME-Version: 1.0 Content-Type: text/plain; charset="us-ascii" Content-Transfer-Encoding: 7bit To: u-boot@lists.denx.de On Fri, Aug 24, 2018 at 08:28:17PM +0530, Lokesh Vutla wrote: > > > On Friday 24 August 2018 07:41 PM, Tom Rini wrote: > > On Tue, Aug 21, 2018 at 08:00:49PM +0530, Lokesh Vutla wrote: > > > >> The AM654 device is designed for industrial automation and PLC > >> controller class platforms among other applications. Introduce > >> base support for AM654 SoC. > > [snip] > >> +config NON_SECURE_MSRAM_SIZE > >> + hex "Size of the MCU OC-MSRAM" > >> + default 0x80000 > >> + help > >> + Describes the total size of the MCU MSRAM. This doesn't > >> + specify the total size of SPL as ROM can use some part > >> + of this RAM. Once ROM gives control to SPL then this > >> + complete size can be usable. > >> + > >> +config MAX_DOWNLODABLE_IMAGE_SIZE > >> + hex "Maximum size of the image" > >> + default 0x58000 > >> + help > >> + Describes the maximum size of the image that ROM can download > >> + from any boot media. > >> + > >> +config MCU_SCRATCHPAD_BASE > >> + hex "Base address of Scratchpad RAM" > >> + default 0x40280000 if SOC_K3_AM6 > >> + help > >> + Describes the base address of MCU Scratchpad RAM. > >> + > >> +config MCU_SCRATCHPAD_SIZE > >> + hex "Size of Scratchpad RAM" > >> + default 0x200 if SOC_K3_AM6 > >> + help > >> + Describes the size of MCU Scratchpad RAM. > > > > These are very generic names. And are these really things that can be > > configured and changed by the user? MAX_DOWNLODABLE_IMAGE_SIZE is > > You are right. These are not configurable by user, but changes from SoC > to SoC within K3 family. Will fix it in v2 by dropping the prompt string. > Well, the names are also fairly generic. Why not just #define SYS_K3_xxx ? -- Tom -------------- next part -------------- A non-text attachment was scrubbed... Name: signature.asc Type: application/pgp-signature Size: 819 bytes Desc: not available URL: