From mboxrd@z Thu Jan 1 00:00:00 1970 From: Michal =?UTF-8?B?U3VjaMOhbmVr?= Date: Tue, 2 Jul 2019 17:44:20 +0200 Subject: [U-Boot] [PATCH 6/8] usb: add usb_submit_int_msg_nonblock In-Reply-To: References: <5dfc00046742db978f1ae046d8855663ccf7c281.1561996556.git.msuchanek@suse.de> <28844f682ed31648b5f0d812aeff18b2458baa6c.1561996556.git.msuchanek@suse.de> <8a0869a4-9c7c-9a12-e7b1-2bbf1ec17c4e@denx.de> <20190702161411.0dd6a80b@kitsune.suse.cz> <20190702162507.2c772d7b@kitsune.suse.cz> <20190702165838.08091351@kitsune.suse.cz> <20190702173037.7b6e6b4c@kitsune.suse.cz> Message-ID: <20190702174420.37c2c655@kitsune.suse.cz> List-Id: MIME-Version: 1.0 Content-Type: text/plain; charset="utf-8" Content-Transfer-Encoding: 8bit To: u-boot@lists.denx.de On Tue, 2 Jul 2019 23:39:42 +0800 Bin Meng wrote: > On Tue, Jul 2, 2019 at 11:30 PM Michal Suchánek wrote: > > > > On Tue, 2 Jul 2019 23:11:01 +0800 > > Bin Meng wrote: > > > > > Hi Michal, > > > > > > On Tue, Jul 2, 2019 at 10:58 PM Michal Suchánek wrote: > > > > > > > > On Tue, 2 Jul 2019 22:29:42 +0800 > > > > Bin Meng wrote: > > > > > > > > > Hi Michal, > > > > > > > > > > On Tue, Jul 2, 2019 at 10:25 PM Michal Suchánek wrote: > > > > > > > > > > > > On Tue, 2 Jul 2019 22:16:02 +0800 > > > > > > Bin Meng wrote: > > > > > > > > > > > > > Hi Michal, > > > > > > > > > > > > > > On Tue, Jul 2, 2019 at 10:14 PM Michal Suchánek wrote: > > > > > > > > > > > > > > > > On Tue, 2 Jul 2019 13:59:49 +0200 > > > > > > > > Marek Vasut wrote: > > > > > > > > > > > > > > > > > On 7/1/19 5:56 PM, Michal Suchanek wrote: > > > > > > > > > > Signed-off-by: Michal Suchanek > > > > > > > > > > --- > > > > > > > > > > common/usb.c | 9 +++++++++ > > > > > > > > > > include/usb.h | 2 ++ > > > > > > > > > > 2 files changed, 11 insertions(+) > > > > > > > > > > > > > > > > > > > > diff --git a/common/usb.c b/common/usb.c > > > > > > > > > > index 3ae71c98aaf4..d8302d39a91a 100644 > > > > > > > > > > --- a/common/usb.c > > > > > > > > > > +++ b/common/usb.c > > > > > > > > > > @@ -200,6 +200,15 @@ int usb_submit_int_msg(struct usb_device *dev, unsigned long pipe, > > > > > > > > > > return submit_int_msg(dev, pipe, buffer, transfer_len, interval, false); > > > > > > > > > > } > > > > > > > > > > > > > > > > > > > > +/* > > > > > > > > > > + * submits an Interrupt Message without retry > > > > > > > > > > + */ > > > > > > > > > > +int usb_submit_int_msg_nonblock(struct usb_device *dev, unsigned long pipe, > > > > > > > > > > + void *buffer, int transfer_len, int interval) > > > > > > > > > > +{ > > > > > > > > > > + return submit_int_msg(dev, pipe, buffer, transfer_len, interval, true); > > > > > > > > > > +} > > > > > > > > > > > > > > > > > > Is this wrapper really necessary ? > > > > > > > > > > > > > > > > > > > > > > > > > Avoids changing other users of the code. Not that there are that many, > > > > > > > > anyway. > > > > > > > > > > > > > > Then I wonder why not change your codes to call submit_int_msg() instead? > > > > > > > > > > > > > Why do we have usb_submit_int_msg in the first place? > > > > > > > > > > I am happy to remove that. A patch is welcome. :) > > > > > > > > > > > > > So the answer is we have wrappers for USB messages, and while > > > > submit_int_msg is trivial others are not. To keep reasonable interface > > > > all messages should be wrapped. > > > > > > I don't see usb_submit_control_msg() or usb_submit_bulk_msg(), so I > > > think we should remove usb_submit_int_msg() and just leave > > > submit_int_msg() for drivers to call. > > > > There is no _submit_ in those. See include/usb.h > > > > OK, so we should just rename usb_submit_int_msg() to usb_int_msg() and > everything is consistent, no? > Yes, looks like the _submit in usb_submit_int_msg is superfluous. Thanks Michal