From mboxrd@z Thu Jan 1 00:00:00 1970 From: Tom Rini Date: Fri, 10 Jan 2020 16:50:41 -0500 Subject: [PATCH 1/3] dtimg/am57xx_evm_defconfig: Rename dtimg to adtimg In-Reply-To: <20191224165108.2836-2-erosca@de.adit-jv.com> References: <20191224165108.2836-1-erosca@de.adit-jv.com> <20191224165108.2836-2-erosca@de.adit-jv.com> Message-ID: <20200110215041.GP31026@bill-the-cat> List-Id: MIME-Version: 1.0 Content-Type: text/plain; charset="us-ascii" Content-Transfer-Encoding: 7bit To: u-boot@lists.denx.de On Tue, Dec 24, 2019 at 05:51:06PM +0100, Eugeniu Rosca wrote: > Rename the existing 'dtimg' command to 'adtimg', in order to: > - Suggest the Android origins and scope > - Be consistent with the upcoming 'abootimg' command (naming > suggested by Simon [*]) > > The change in _not_ backward compatible, but its benefits outweigh its > downsides, given that we don't expect active users of 'dtimg' today. > > Perform the rename in several steps: > 1. Rename *.c file and Kconfig symbol. This should allow > 'git log --follow' to properly track the history of 'adtimg.c' > 2. 's/dtimg/adtimg/g' in the internal namespace of 'adtimg.c' > > ELF comparison [**] before and after shows no functional change. > > [*] https://patchwork.ozlabs.org/patch/1182212/#2291600 > [**] diff -u <(objdump -d cmd/dtimg.o) <(objdump -d cmd/adtimg.o) > > Cc: Tom Rini > Signed-off-by: Eugeniu Rosca > Reviewed-by: Simon Glass > Reviewed-by: Sam Protsenko Applied to u-boot/master, thanks! -- Tom -------------- next part -------------- A non-text attachment was scrubbed... Name: signature.asc Type: application/pgp-signature Size: 833 bytes Desc: not available URL: