U-Boot Archive on lore.kernel.org
 help / color / mirror / Atom feed
From: Tom Rini <trini@konsulko.com>
To: u-boot@lists.denx.de
Subject: [PATCH 3/3] cmd: adtimg: Refactor usage style
Date: Fri, 10 Jan 2020 16:50:52 -0500	[thread overview]
Message-ID: <20200110215052.GR31026@bill-the-cat> (raw)
In-Reply-To: <20191224165108.2836-4-erosca@de.adit-jv.com>

On Tue, Dec 24, 2019 at 05:51:08PM +0100, Eugeniu Rosca wrote:

> Trying to extend 'adtimg' functionality [1], we've been severely hit
> by a major limitation in the command's usage scheme. Specifically, the
> command's user interface appears to be too centric to getting the
> DTB/DTBO entry [3] based on the index of the desired DT in the image,
> which makes it really difficult retrieving the DT entry based on
> alternative criteria (e.g. filtering by id/rev fields), the
> latter being demanded by real life customer use-cases [1].
> 
> This went to the point of receiving below feedback from Sam [2]:
> 
>  -- snip --
>  As for 'dtimg' command: after giving it some thought, I think not much
>  people using it yet. So in this particular case I don't have some
>  strong preference, and if you think the 'dtimg' interface is ugly, and
>  it overcomes "don't break interfaces" rule, maybe now is a good time
>  to rework it (before it gets widely used).
>  -- snip --
> 
> Given the above, rework the usage pattern from [4] to [5], in order to
> allow an intuitive enablement of "by id|rev" DT search [6].
> 
> [1] https://patchwork.ozlabs.org/cover/1202575/
>     ("cmd: dtimg: Enhance with --id and --rev options (take #1)")
> [2] https://patchwork.ozlabs.org/patch/1182207/#2317020
> [3] https://source.android.com/devices/architecture/dto/partitions
> [4] Old usage
> adtimg dump <addr>                    - Print image contents
> adtimg start <addr> <index> <varname> - Get DT address by index
> adtimg size <addr> <index> <varname>  - Get DT size by index
> 
> [5] New usage
> adtimg addr <addr>                      - Set image location to <addr>
> adtimg dump                             - Print out image contents
> adtimg get dt --index=<i> [avar [svar]] - Get DT address and size by index
> 
> [6] Soon-to-be-provided "by id|rev" add-on functionality
> adtimg get dt --id=<id> --rev=<rev> [avar [svar [ivar]]]
>  - Get DT address/size/index by id|rev fields
> 
> Signed-off-by: Eugeniu Rosca <erosca@de.adit-jv.com>
> Reviewed-by: Sam Protsenko <semen.protsenko@linaro.org>

Applied to u-boot/master, thanks!

-- 
Tom
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 833 bytes
Desc: not available
URL: <https://lists.denx.de/pipermail/u-boot/attachments/20200110/30d94b3b/attachment.sig>

  parent reply	other threads:[~2020-01-10 21:50 UTC|newest]

Thread overview: 17+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2019-12-24 16:51 [PATCH 0/3] cmd: dtimg: Rename to adtimg and refactor usage style Eugeniu Rosca
2019-12-24 16:51 ` [PATCH 1/3] dtimg/am57xx_evm_defconfig: Rename dtimg to adtimg Eugeniu Rosca
2020-01-07 16:49   ` Simon Glass
2020-01-07 17:13     ` Eugeniu Rosca
2020-01-10 21:50   ` Tom Rini
2019-12-24 16:51 ` [PATCH 2/3] cmd: adtimg: Rename internal symbols Eugeniu Rosca
2020-01-08 17:39   ` Simon Glass
2020-01-10 21:50   ` Tom Rini
2019-12-24 16:51 ` [PATCH 3/3] cmd: adtimg: Refactor usage style Eugeniu Rosca
2020-01-08 17:39   ` Simon Glass
2020-01-08 18:12     ` Eugeniu Rosca
2020-01-10 21:50   ` Tom Rini [this message]
2020-01-10 23:29     ` Eugeniu Rosca
2020-07-03 16:40       ` Patrick DELAUNAY
2020-07-06  6:46         ` Eugeniu Rosca
2020-07-08 17:26           ` Patrick DELAUNAY
2019-12-24 19:44 ` [PATCH 0/3] cmd: dtimg: Rename to adtimg and refactor " Sam Protsenko

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20200110215052.GR31026@bill-the-cat \
    --to=trini@konsulko.com \
    --cc=u-boot@lists.denx.de \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox