From mboxrd@z Thu Jan 1 00:00:00 1970 From: Albert ARIBAUD Date: Sat, 20 Sep 2014 09:47:16 +0200 Subject: [U-Boot] [PATCH 1/7] spl: pbl: Add new SPL image for pblimage tool In-Reply-To: <8785cda4654347988ff9668c88c45db7@BN1PR0301MB0689.namprd03.prod.outlook.com> References: <1411019239-12360-1-git-send-email-b18965@freescale.com> <1411019239-12360-2-git-send-email-b18965@freescale.com> <8785cda4654347988ff9668c88c45db7@BN1PR0301MB0689.namprd03.prod.outlook.com> Message-ID: List-Id: MIME-Version: 1.0 Content-Type: text/plain; charset="us-ascii" Content-Transfer-Encoding: 7bit To: u-boot@lists.denx.de Hi Huan, On Fri, 19 Sep 2014 05:07:05 +0000, Huan Wang wrote: > Hi, Albert, > > > On Thu, 18 Sep 2014 13:47:13 +0800, Alison Wang > > wrote: > > > > > For the pblimage tool, the SPL image is splitted into 64 byte chunks, > > > and PBL needs a command for each piece. In current pblimage structure, > > > the size of the SPL image should be a fixed value. Well, for LS102xA > > > and some other ARM platforms, the size of the SPL image is changeable. > > > So a new image spl/u-boot-spl-pbl-pad.bin is built, and the size of > > it > > > is a fixed value "CONFIG_SPL_MAX_SIZE". Use it instead of > > > spl/u-boot-spl.bin for LS102xA. > > > > > > CONFIG_SPL_PBL_PAD is used to enable this function. > > > > > > Signed-off-by: Alison Wang > > > --- > > > > There is already a CONFIG_SPL_PAD_TO (see ./README). Can you not use > > this? (BTW, thanks for fixing the way your mailer quotes. That's much more readable to me.) > [Alison Wang] I have already used CONFIG_SPL_PAD_TO to determine the offset to which u-boot-spl.pbl should be padded when generating u-boot-with-spl-pbl.bin. Well, I used CONFIG_SPL_MAX_SIZE to determine the size of u-boot-spl-pbl-pad.bin. u-boot-spl-pbl-pad.bin is generated by padding u-boot-spl.bin to CONFIG_SPL_MAX_SIZE. I'm still lost. Can you summarize the sequence of operations performed, starting from the u-boot SPL elf file, and on each step indicate which file is produced and which config option(s) from CONFIG_SPL_[PBL_]{PAD_TO,MAX_SIZE} is(are) involved and why? Also, in any case, if CONFIG_SPL_PBL_PAD is needed then it must be added to README with its description. > Best Regards, > Alison Wang Amicalement, -- Albert.