From: Tanmay Kathpalia <tanmay.kathpalia@altera.com>
To: Peng Fan <peng.fan@oss.nxp.com>
Cc: u-boot@lists.denx.de, peng.fan@nxp.com, jh80.chung@samsung.com,
trini@konsulko.com, marex@denx.de, tien.fong.chee@altera.com,
balsundar.ponnusamy@altera.com
Subject: Re: [PATCH 7/8] mmc: sdhci-cadence6: socfpga: Fix DT property naming convention
Date: Thu, 20 Nov 2025 20:12:11 +0530 [thread overview]
Message-ID: <e48238cb-9cf4-4e4c-9a47-63e80c77c822@altera.com> (raw)
In-Reply-To: <aRwQqNaCcn6f9-Cg@nxa18884-linux>
On 11/18/2025 11:52 AM, Peng Fan wrote:
> On Mon, Nov 10, 2025 at 09:37:36AM -0800, Tanmay Kathpalia wrote:
>> 1. Replace underscores with hyphens in device tree property names to
>> follow the standard DT naming convention. This affects all
>> "lpbk_ctrl" properties which are now correctly named "lpbk-ctrl".
>
> Are these properties in Linux Upstream tree?
>
No, the Linux upstream tree does not have the Cadence version 6 host
controller driver, so these properties are not present in Linux.
> I not see users in arch/arm/dts and dts/upstream for the properties.
>
Currently, there are no users for the Cadence version 6 host controller
IP. However, we have enabled it in our local repository for our
platform. Once these changes are merged, I plan to submit the enablement
patches.
> Regards
> Peng
next prev parent reply other threads:[~2025-11-20 14:42 UTC|newest]
Thread overview: 21+ messages / expand[flat|nested] mbox.gz Atom feed top
2025-11-10 17:37 [PATCH 0/8] mmc: sdhci-cadence: Improvements and fixes for Cadence SDHCI driver Tanmay Kathpalia
2025-11-10 17:37 ` [PATCH 1/8] mmc: sdhci-cadence: Add reset control support Tanmay Kathpalia
2025-11-18 5:09 ` Peng Fan
2025-11-20 14:59 ` Tanmay Kathpalia
2025-11-26 2:17 ` Peng Fan
2025-11-27 8:29 ` Tanmay Kathpalia
2025-11-27 9:48 ` Peng Fan
2025-11-27 9:52 ` Tanmay Kathpalia
2025-11-10 17:37 ` [PATCH 2/8] mmc: sdhci-cadence: Use max-frequency property from device tree Tanmay Kathpalia
2025-11-18 6:13 ` Peng Fan
2025-11-20 14:31 ` Tanmay Kathpalia
2025-11-10 17:37 ` [PATCH 3/8] mmc: sdhci-cadence: Set controller and PHY speed modes for SD and eMMC cards Tanmay Kathpalia
2025-11-10 17:37 ` [PATCH 4/8] mmc: sdhci: Add SDHCI_SPEC_400, _410, and _420 version defines Tanmay Kathpalia
2025-11-10 17:37 ` [PATCH 5/8] mmc: sdhci-cadence: Use hardware version field for Cadence SDHCI controller Tanmay Kathpalia
2025-11-10 17:37 ` [PATCH 6/8] mmc: sdhci-cadence: Enable software tuning for both SD and eMMC interfaces Tanmay Kathpalia
2025-11-10 17:37 ` [PATCH 7/8] mmc: sdhci-cadence6: socfpga: Fix DT property naming convention Tanmay Kathpalia
2025-11-18 6:22 ` Peng Fan
2025-11-20 14:42 ` Tanmay Kathpalia [this message]
2025-11-10 17:37 ` [PATCH 8/8] mmc: sdhci-cadence6: Add DLL master control and improve tuning reliability Tanmay Kathpalia
2025-11-18 6:24 ` Peng Fan
2025-11-20 14:50 ` Tanmay Kathpalia
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=e48238cb-9cf4-4e4c-9a47-63e80c77c822@altera.com \
--to=tanmay.kathpalia@altera.com \
--cc=balsundar.ponnusamy@altera.com \
--cc=jh80.chung@samsung.com \
--cc=marex@denx.de \
--cc=peng.fan@nxp.com \
--cc=peng.fan@oss.nxp.com \
--cc=tien.fong.chee@altera.com \
--cc=trini@konsulko.com \
--cc=u-boot@lists.denx.de \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox