U-Boot Archive on lore.kernel.org
 help / color / mirror / Atom feed
From: Teresa Remmet <T.Remmet@phytec.de>
To: Benjamin Hahn <B.Hahn@phytec.de>, "lukma@denx.de" <lukma@denx.de>
Cc: "sjg@chromium.org" <sjg@chromium.org>,
	"u-boot@lists.denx.de" <u-boot@lists.denx.de>,
	"trini@konsulko.com" <trini@konsulko.com>,
	"festevam@gmail.com" <festevam@gmail.com>,
	Cem Tenruh <C.Tenruh@phytec.de>,
	"martyn.welch@collabora.com" <martyn.welch@collabora.com>
Subject: Re: [PATCH v3] config: Add 'update_bootimg' command to update flash.bin on Phytec's imx8mm
Date: Thu, 8 Aug 2024 09:21:36 +0000	[thread overview]
Message-ID: <fbd60aeea9413d7fa9f82ef952530e316e6b9e97.camel@phytec.de> (raw)
In-Reply-To: <20240807130423.601a1e47@wsk>

Hello Lukasz,

Am Mittwoch, dem 07.08.2024 um 13:04 +0200 schrieb Lukasz Majewski:
> Hi Benjamin,
> 
> > Hi Lukasz,
> > 
> > On 06.08.24 10:11, Lukasz Majewski wrote:
> > > This command allows easy update on SD card or eMMC of the
> > > flash.bin
> > > generated (with binman) during u-boot build.
> > > 
> > > Signed-off-by: Lukasz Majewski <lukma@denx.de>
> > > ---
> > > Changes for v2:
> > > - Remove 'update_mmc_part' variable
> > > - Change path for hostname
> > > - Use full version of dhcp command (${loadaddr} added)
> > > 
> > > Changes for v3:
> > > - Remove +1 when calculating the size of binary to be written
> > > ---
> > >   include/configs/phycore_imx8mm.h | 10 ++++++++++
> > >   1 file changed, 10 insertions(+)
> > > 
> > > diff --git a/include/configs/phycore_imx8mm.h
> > > b/include/configs/phycore_imx8mm.h index ce6dc87c69..361e665676
> > > 100644 --- a/include/configs/phycore_imx8mm.h
> > > +++ b/include/configs/phycore_imx8mm.h
> > > @@ -29,6 +29,16 @@
> > >         "mmcdev=" __stringify(CONFIG_SYS_MMC_ENV_DEV) "\0" \
> > >         "mmcpart=1\0" \
> > >         "mmcroot=2\0" \
> > > +       "update_offset=0x42\0" \
> > > +       "update_filename=flash.bin\0" \
> > > +       "hostname=/srv/tftp/\0" \
> > > +       "update_bootimg="
> > >         \
> > > +               "mmc dev ${mmcdev} ; "          \
> > > +               "if dhcp ${loadaddr}
> > > ${hostname}/${update_filename} ; then " \  
> > 
> > The dhcp and tftp command should take the filepath from the tftp 
> > directory and get the tftp directory automatically not the absolute
> > path. So this will try to get the file from 
> > /path_to_tftp_folder/srv/tftp/flash.bin and will fail
> 
> And that is why you do have the ${hostname}/${update_filename}, so
> when
> you have several exported directories - you can specify which one
> without the need to modify the 'update_bootimg' command.

do I understand it correct that you just want to be able to define sub
dirs with a variable? This does make sense but you should not pre-
define them here.

And I think the variable name $hostname is kind of miss leading. Maybe
you can find some different name for it?

Regards,
Teresa

> 
> > because it
> > can't find it. So you can drop the ${hostname}.
> 
> I would prefer to keep the ${hostname}/${update_filename} part.
> 
> > Also drop the initialization of ${hostname} above since it is no
> > longer needed.
> > 
> > Should be like this:
> > 
> > dhcp ${loadaddr} ${update_filename}
> > 
> 
> IMHO the line shall be:
> 
> dhcp ${loadaddr} ${hostname}/${update_filename}
> 
> > > +               "setexpr fw_sz ${filesize} / 0x200 ; "  /*
> > > SD block size */ \
> > > +               "setexpr fw_sz ${fw_sz} ; "  
> > I think you can drop this line since it does not do anything.
> > 
> 
> Ok.
> 
> > Benjamin
> > >                                 \
> > > +               "mmc write ${loadaddr} ${update_offset} ${fw_sz}
> > > ;
> > > "       \
> > > +               "fi\0" \
> > >         "mmcautodetect=yes\0" \
> > >         "mmcargs=setenv bootargs console=${console} " \
> > >                 "root=/dev/mmcblk${mmcdev}p${mmcroot} rootwait
> > > rw\0" \  
> > 
> > 
> 
> 
> 
> 
> Best regards,
> 
> Lukasz Majewski
> 
> --
> 
> DENX Software Engineering GmbH,      Managing Director: Erika Unter
> HRB 165235 Munich, Office: Kirchenstr.5, D-82194 Groebenzell, Germany
> Phone: (+49)-8142-66989-59 Fax: (+49)-8142-66989-80 Email:
> lukma@denx.de

-- 
PHYTEC Messtechnik GmbH | Barcelona-Allee 1 | 55129 Mainz, Germany

Geschäftsführer: Dipl.-Ing. Michael Mitezki, Dipl.-Ing. Bodo Huber,
Dipl.-Ing. (FH) Markus Lickes | Handelsregister Mainz HRB 4656 |
Finanzamt Mainz | St.Nr. 266500608, DE 149059855

  reply	other threads:[~2024-08-08  9:21 UTC|newest]

Thread overview: 7+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2024-08-06  8:11 [PATCH v3] config: Add 'update_bootimg' command to update flash.bin on Phytec's imx8mm Lukasz Majewski
2024-08-06 12:57 ` Fabio Estevam
2024-08-07  9:58 ` Benjamin Hahn
2024-08-07 11:04   ` Lukasz Majewski
2024-08-08  9:21     ` Teresa Remmet [this message]
2024-08-08 10:25       ` Lukasz Majewski
2024-08-09  5:57         ` Teresa Remmet

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=fbd60aeea9413d7fa9f82ef952530e316e6b9e97.camel@phytec.de \
    --to=t.remmet@phytec.de \
    --cc=B.Hahn@phytec.de \
    --cc=C.Tenruh@phytec.de \
    --cc=festevam@gmail.com \
    --cc=lukma@denx.de \
    --cc=martyn.welch@collabora.com \
    --cc=sjg@chromium.org \
    --cc=trini@konsulko.com \
    --cc=u-boot@lists.denx.de \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox