From mboxrd@z Thu Jan 1 00:00:00 1970 From: David Hildenbrand Subject: Re: [PATCH v6 01/46] virtio: add low-level APIs for feature bits Date: Fri, 28 Nov 2014 13:10:57 +0100 Message-ID: <20141128131057.6046a382@thinkpad-w530> References: <1417118789-18231-1-git-send-email-mst@redhat.com> <1417118789-18231-2-git-send-email-mst@redhat.com> Mime-Version: 1.0 Content-Type: text/plain; charset="us-ascii" Content-Transfer-Encoding: 7bit Return-path: In-Reply-To: <1417118789-18231-2-git-send-email-mst@redhat.com> List-Unsubscribe: , List-Archive: List-Post: List-Help: List-Subscribe: , Sender: virtualization-bounces@lists.linux-foundation.org Errors-To: virtualization-bounces@lists.linux-foundation.org To: "Michael S. Tsirkin" Cc: thuth@linux.vnet.ibm.com, rusty@au1.ibm.com, linux-kernel@vger.kernel.org, virtualization@lists.linux-foundation.org, pbonzini@redhat.com, David Miller List-Id: virtualization@lists.linuxfoundation.org > Add low level APIs to test/set/clear feature bits. > For use by transports, to make it easier to > write code independent of feature bit array format. > > Signed-off-by: Michael S. Tsirkin > --- > include/linux/virtio_config.h | 53 ++++++++++++++++++++++++++++++++++++++++--- > 1 file changed, 50 insertions(+), 3 deletions(-) > As these functions really set feature bits, I would rather name them: virtio_has_feature ... virtio_set_feature ... virtio_clear_feature ... But in general, this looks good to me!