From mboxrd@z Thu Jan 1 00:00:00 1970 From: Baole Ni Subject: [PATCH 0214/1285] Replace numeric parameter like 0444 with macro Date: Tue, 2 Aug 2016 18:50:20 +0800 Message-ID: <20160802105020.28023-1-baolex.ni@intel.com> Mime-Version: 1.0 Content-Type: text/plain; charset="us-ascii" Content-Transfer-Encoding: 7bit Return-path: List-Unsubscribe: , List-Archive: List-Post: List-Help: List-Subscribe: , Sender: virtualization-bounces@lists.linux-foundation.org Errors-To: virtualization-bounces@lists.linux-foundation.org To: airlied@linux.ie, kraxel@redhat.com, kyungmin.park@samsung.com, kgene@kernel.org, k.kozlowski@samsung.com, dougthompson@xmission.com, bp@alien8.de Cc: linux-kernel@vger.kernel.org, dri-devel@lists.freedesktop.org, virtualization@lists.linux-foundation.org, baolex.ni@intel.com, alexander.deucher@amd.com, chuansheng.liu@intel.com, ville.syrjala@linux.intel.com List-Id: virtualization@lists.linuxfoundation.org I find that the developers often just specified the numeric value when calling a macro which is defined with a parameter for access permission. As we know, these numeric value for access permission have had the corresponding macro, and that using macro can improve the robustness and readability of the code, thus, I suggest replacing the numeric parameter with the macro. Signed-off-by: Chuansheng Liu Signed-off-by: Baole Ni --- drivers/gpu/drm/virtio/virtgpu_kms.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/gpu/drm/virtio/virtgpu_kms.c b/drivers/gpu/drm/virtio/virtgpu_kms.c index 4150873..1b7bd86 100644 --- a/drivers/gpu/drm/virtio/virtgpu_kms.c +++ b/drivers/gpu/drm/virtio/virtgpu_kms.c @@ -31,7 +31,7 @@ static int virtio_gpu_fbdev = 1; MODULE_PARM_DESC(fbdev, "Disable/Enable framebuffer device & console"); -module_param_named(fbdev, virtio_gpu_fbdev, int, 0400); +module_param_named(fbdev, virtio_gpu_fbdev, int, S_IRUSR); static void virtio_gpu_config_changed_work_func(struct work_struct *work) { -- 2.9.2