From mboxrd@z Thu Jan 1 00:00:00 1970 From: Baole Ni Subject: [PATCH 0753/1285] Replace numeric parameter like 0444 with macro Date: Tue, 2 Aug 2016 19:42:57 +0800 Message-ID: <20160802114257.32317-1-baolex.ni@intel.com> Mime-Version: 1.0 Content-Type: text/plain; charset="us-ascii" Content-Transfer-Encoding: 7bit Return-path: List-Unsubscribe: , List-Archive: List-Post: List-Help: List-Subscribe: , Sender: virtualization-bounces@lists.linux-foundation.org Errors-To: virtualization-bounces@lists.linux-foundation.org To: mst@redhat.com, f.fainelli@gmail.com, bkenward@solarflare.com, linux-driver@qlogic.com, computersforpeace@gmail.com, m.chehab@samsung.com, pawel@osciak.com, m.szyprowski@samsung.com, kyungmin.park@samsung.com, k.kozlowski@samsung.com Cc: pabeni@redhat.com, daniel@iogearbox.net, netdev@vger.kernel.org, linux-kernel@vger.kernel.org, virtualization@lists.linux-foundation.org, baolex.ni@intel.com, hannes@stressinduktion.org, chuansheng.liu@intel.com List-Id: virtualization@lists.linuxfoundation.org I find that the developers often just specified the numeric value when calling a macro which is defined with a parameter for access permission. As we know, these numeric value for access permission have had the corresponding macro, and that using macro can improve the robustness and readability of the code, thus, I suggest replacing the numeric parameter with the macro. Signed-off-by: Chuansheng Liu Signed-off-by: Baole Ni --- drivers/net/virtio_net.c | 6 +++--- 1 file changed, 3 insertions(+), 3 deletions(-) diff --git a/drivers/net/virtio_net.c b/drivers/net/virtio_net.c index e0638e5..39815e4 100644 --- a/drivers/net/virtio_net.c +++ b/drivers/net/virtio_net.c @@ -30,11 +30,11 @@ #include static int napi_weight = NAPI_POLL_WEIGHT; -module_param(napi_weight, int, 0444); +module_param(napi_weight, int, S_IRUSR | S_IRGRP | S_IROTH); static bool csum = true, gso = true; -module_param(csum, bool, 0444); -module_param(gso, bool, 0444); +module_param(csum, bool, S_IRUSR | S_IRGRP | S_IROTH); +module_param(gso, bool, S_IRUSR | S_IRGRP | S_IROTH); /* FIXME: MTU in config. */ #define GOOD_PACKET_LEN (ETH_HLEN + VLAN_HLEN + ETH_DATA_LEN) -- 2.9.2