Linux virtualization list
 help / color / mirror / Atom feed
From: Stefano Garzarella <sgarzare@redhat.com>
To: Jason Wang <jasowang@redhat.com>
Cc: Laurent Vivier <lvivier@redhat.com>,
	Max Gurtovoy <mgurtovoy@nvidia.com>,
	"Michael S. Tsirkin" <mst@redhat.com>,
	linux-kernel@vger.kernel.org,
	virtualization@lists.linux-foundation.org,
	Stefan Hajnoczi <stefanha@redhat.com>,
	Eli Cohen <elic@nvidia.com>
Subject: Re: [PATCH v2 12/17] vdpa_sim: add get_config callback in vdpasim_dev_attr
Date: Tue, 1 Dec 2020 11:52:50 +0100	[thread overview]
Message-ID: <20201201105250.a72yxsxmyalio6c3@steredhat> (raw)
In-Reply-To: <c2158059-6509-7702-f52a-e497ce899293@redhat.com>

On Tue, Dec 01, 2020 at 11:44:19AM +0800, Jason Wang wrote:
>
>On 2020/11/30 下午10:14, Stefano Garzarella wrote:
>>On Mon, Nov 30, 2020 at 11:25:31AM +0800, Jason Wang wrote:
>>>
>>>On 2020/11/26 下午10:49, Stefano Garzarella wrote:
>>>>The get_config callback can be used by the device to fill the
>>>>config structure.
>>>>The callback will be invoked in vdpasim_get_config() before copying
>>>>bytes into caller buffer.
>>>>
>>>>Move vDPA-net config updates from vdpasim_set_features() in the
>>>>new vdpasim_net_get_config() callback.
>>>>
>>>>Signed-off-by: Stefano Garzarella <sgarzare@redhat.com>
>>>>---
>>>> drivers/vdpa/vdpa_sim/vdpa_sim.c | 33 +++++++++++++++++++-------------
>>>> 1 file changed, 20 insertions(+), 13 deletions(-)
>>>>
>>>>diff --git a/drivers/vdpa/vdpa_sim/vdpa_sim.c 
>>>>b/drivers/vdpa/vdpa_sim/vdpa_sim.c
>>>>index c07ddf6af720..8b87ce0485b6 100644
>>>>--- a/drivers/vdpa/vdpa_sim/vdpa_sim.c
>>>>+++ b/drivers/vdpa/vdpa_sim/vdpa_sim.c
>>>>@@ -58,6 +58,8 @@ struct vdpasim_virtqueue {
>>>> #define VDPASIM_NET_FEATURES    (VDPASIM_FEATURES | \
>>>>                  (1ULL << VIRTIO_NET_F_MAC))
>>>>+struct vdpasim;
>>>>+
>>>> struct vdpasim_dev_attr {
>>>>     u64 supported_features;
>>>>     size_t config_size;
>>>>@@ -65,6 +67,7 @@ struct vdpasim_dev_attr {
>>>>     u32 id;
>>>>     work_func_t work_fn;
>>>>+    void (*get_config)(struct vdpasim *vdpasim, void *config);
>>>> };
>>>> /* State of each vdpasim device */
>>>>@@ -520,8 +523,6 @@ static u64 vdpasim_get_features(struct 
>>>>vdpa_device *vdpa)
>>>> static int vdpasim_set_features(struct vdpa_device *vdpa, u64 
>>>>features)
>>>> {
>>>>     struct vdpasim *vdpasim = vdpa_to_sim(vdpa);
>>>>-    struct virtio_net_config *config =
>>>>-        (struct virtio_net_config *)vdpasim->config;
>>>>     /* DMA mapping must be done by driver */
>>>>     if (!(features & (1ULL << VIRTIO_F_ACCESS_PLATFORM)))
>>>>@@ -529,15 +530,6 @@ static int vdpasim_set_features(struct 
>>>>vdpa_device *vdpa, u64 features)
>>>>     vdpasim->features = features & 
>>>>vdpasim->dev_attr.supported_features;
>>>>-    /* We generally only know whether guest is using the legacy 
>>>>interface
>>>>-     * here, so generally that's the earliest we can set config 
>>>>fields.
>>>>-     * Note: We actually require VIRTIO_F_ACCESS_PLATFORM above which
>>>>-     * implies VIRTIO_F_VERSION_1, but let's not try to be 
>>>>clever here.
>>>>-     */
>>>>-
>>>>-    config->mtu = cpu_to_vdpasim16(vdpasim, 1500);
>>>>-    config->status = cpu_to_vdpasim16(vdpasim, VIRTIO_NET_S_LINK_UP);
>>>>-    memcpy(config->mac, macaddr_buf, ETH_ALEN);
>>>>     return 0;
>>>> }
>>>>@@ -593,8 +585,12 @@ static void vdpasim_get_config(struct 
>>>>vdpa_device *vdpa, unsigned int offset,
>>>> {
>>>>     struct vdpasim *vdpasim = vdpa_to_sim(vdpa);
>>>>-    if (offset + len < vdpasim->dev_attr.config_size)
>>>>-        memcpy(buf, vdpasim->config + offset, len);
>>>>+    if (offset + len > vdpasim->dev_attr.config_size)
>>>>+        return;
>>>>+
>>>>+    vdpasim->dev_attr.get_config(vdpasim, vdpasim->config);
>>>>+
>>>>+    memcpy(buf, vdpasim->config + offset, len);
>>>> }
>>>
>>>
>>>I wonder how much value we can get from vdpasim->config consider 
>>>we've already had get_config() method.
>>>
>>>Is it possible to copy to the buffer directly here?
>>
>>I had thought of eliminating it too, but then I wanted to do something 
>>similar to what we do in QEMU (hw/virtio/virtio.c), leaving in the 
>>simulator core the buffer, the memory copy (handling offset and len), 
>>and the boundary checks.
>>
>>In this way each device should simply fill the entire configuration 
>>and we can avoid code duplication.
>>
>>Storing the configuration in the core may also be useful if some 
>>device needs to support config writes.
>
>
>I think in that way we need should provide config_write().

Yes, I'll add set_config() callback.

>
>
>>
>>Do you think it makes sense, or is it better to move everything in the 
>>device?
>
>
>I prefer to do that in the device but it's also fine keep what the 
>patch has done.

Okay, for now I'll keep it and add the set_config() callback, but I'm 
open to move it in the device.

Thanks,
Stefano

_______________________________________________
Virtualization mailing list
Virtualization@lists.linux-foundation.org
https://lists.linuxfoundation.org/mailman/listinfo/virtualization

  reply	other threads:[~2020-12-01 10:53 UTC|newest]

Thread overview: 40+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-11-26 14:49 [PATCH v2 00/17] vdpa: generalize vdpa simulator Stefano Garzarella
2020-11-26 14:49 ` [PATCH v2 01/17] vdpa: remove unnecessary 'default n' in Kconfig entries Stefano Garzarella
2020-11-30  3:01   ` Jason Wang
2020-11-26 14:49 ` [PATCH v2 02/17] vdpa_sim: remove unnecessary headers inclusion Stefano Garzarella
2020-11-30  3:04   ` Jason Wang
2020-11-30 11:10     ` Stefano Garzarella
2020-11-26 14:49 ` [PATCH v2 03/17] vdpa_sim: remove hard-coded virtq count Stefano Garzarella
2020-11-30  3:05   ` Jason Wang
2020-11-26 14:49 ` [PATCH v2 04/17] vdpa_sim: remove the limit of IOTLB entries Stefano Garzarella
2020-11-30  3:07   ` Jason Wang
2020-11-30 11:24     ` Stefano Garzarella
2020-11-26 14:49 ` [PATCH v2 05/17] vdpa_sim: rename vdpasim_config_ops variables Stefano Garzarella
2020-11-30  3:07   ` Jason Wang
2020-11-26 14:49 ` [PATCH v2 06/17] vdpa_sim: add struct vdpasim_dev_attr for device attributes Stefano Garzarella
2020-11-30  3:09   ` Jason Wang
2020-11-26 14:49 ` [PATCH v2 07/17] vdpa_sim: add device id field in vdpasim_dev_attr Stefano Garzarella
2020-11-30  3:10   ` Jason Wang
2020-11-26 14:49 ` [PATCH v2 08/17] vdpa_sim: add supported_features " Stefano Garzarella
2020-11-30  3:14   ` Jason Wang
2020-11-26 14:49 ` [PATCH v2 09/17] vdpa_sim: add work_fn " Stefano Garzarella
2020-11-30  3:16   ` Jason Wang
2020-11-26 14:49 ` [PATCH v2 10/17] vdpa_sim: store parsed MAC address in a buffer Stefano Garzarella
2020-11-30  3:20   ` Jason Wang
2020-11-26 14:49 ` [PATCH v2 11/17] vdpa_sim: make 'config' generic and usable for any device type Stefano Garzarella
2020-11-26 14:49 ` [PATCH v2 12/17] vdpa_sim: add get_config callback in vdpasim_dev_attr Stefano Garzarella
2020-11-30  3:25   ` Jason Wang
2020-11-30 14:14     ` Stefano Garzarella
2020-12-01  3:44       ` Jason Wang
2020-12-01 10:52         ` Stefano Garzarella [this message]
2020-11-26 14:49 ` [PATCH v2 13/17] vdpa_sim: set vringh notify callback Stefano Garzarella
2020-11-30  3:27   ` Jason Wang
2020-11-30 14:16     ` Stefano Garzarella
2020-11-26 14:49 ` [PATCH v2 14/17] vdpa_sim: use kvmalloc to allocate vdpasim->buffer Stefano Garzarella
2020-11-26 14:49 ` [PATCH v2 15/17] vdpa_sim: make vdpasim->buffer size configurable Stefano Garzarella
2020-11-26 14:49 ` [PATCH v2 16/17] vdpa_sim: split vdpasim_virtqueue's iov field in out_iov and in_iov Stefano Garzarella
2020-11-30  3:29   ` Jason Wang
2020-11-26 14:49 ` [PATCH v2 17/17] vdpa: split vdpasim to core and net modules Stefano Garzarella
2020-11-30  3:31   ` Jason Wang
2020-11-30 14:17     ` Stefano Garzarella
     [not found] ` <751e8938-8055-511c-c339-2b55dc902944@nvidia.com>
2020-11-26 15:24   ` [PATCH v2 00/17] vdpa: generalize vdpa simulator Stefano Garzarella

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20201201105250.a72yxsxmyalio6c3@steredhat \
    --to=sgarzare@redhat.com \
    --cc=elic@nvidia.com \
    --cc=jasowang@redhat.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=lvivier@redhat.com \
    --cc=mgurtovoy@nvidia.com \
    --cc=mst@redhat.com \
    --cc=stefanha@redhat.com \
    --cc=virtualization@lists.linux-foundation.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox