Yocto Project Documentation
 help / color / mirror / Atom feed
From: Quentin Schulz <quentin.schulz@cherry.de>
To: antonin.godard@bootlin.com, docs@lists.yoctoproject.org
Cc: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
Subject: Re: [docs] [PATCH 2/3] tools/check-glossaries: fix default doc path
Date: Fri, 3 Jul 2026 12:22:43 +0200	[thread overview]
Message-ID: <ade7e005-93df-433c-8b02-e520b0e9478b@cherry.de> (raw)
In-Reply-To: <20260702-pre-commit-v1-2-0ebd211b5d5e@bootlin.com>

Hi Antonin,

On 7/2/26 3:59 PM, Antonin Godard via lists.yoctoproject.org wrote:
> This default path pointing to the documentation was wrong, fix it.
> 
> Signed-off-by: Antonin Godard <antonin.godard@bootlin.com>
> ---
>   documentation/tools/check-glossaries | 2 +-
>   1 file changed, 1 insertion(+), 1 deletion(-)
> 
> diff --git a/documentation/tools/check-glossaries b/documentation/tools/check-glossaries
> index 9f1a47126..6bfddcfda 100755
> --- a/documentation/tools/check-glossaries
> +++ b/documentation/tools/check-glossaries
> @@ -14,7 +14,7 @@ def parse_arguments() -> argparse.Namespace:
>   
>       parser.add_argument("-d", "--docs-dir",
>                           type=Path,
> -                        default=Path(os.path.dirname(os.path.realpath(__file__))) / "documentation",
> +                        default=Path(os.path.dirname(os.path.realpath(__file__))) / "../",

Path(__file__).resolve().parent.parent

is much more readable IMO (and also, we avoid the mental gymnastic of 
seeing ../ and having to remove the last directory in the path.

Reviewed-by: Quentin Schulz <quentin.schulz@cherry.de>

Thanks!
Quentin


  reply	other threads:[~2026-07-03 10:23 UTC|newest]

Thread overview: 8+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2026-07-02 13:59 [PATCH 0/3] Add pre-commit support Antonin Godard
2026-07-02 13:59 ` [PATCH 1/3] tools/check-glossaries: return 1 in case of failure Antonin Godard
2026-07-03 10:17   ` [docs] " Quentin Schulz
2026-07-02 13:59 ` [PATCH 2/3] tools/check-glossaries: fix default doc path Antonin Godard
2026-07-03 10:22   ` Quentin Schulz [this message]
2026-07-03 11:34     ` [docs] " Antonin Godard
2026-07-02 13:59 ` [PATCH 3/3] Add a pre-commit hook to check the glossaries Antonin Godard
2026-07-03 10:53   ` [docs] " Quentin Schulz

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=ade7e005-93df-433c-8b02-e520b0e9478b@cherry.de \
    --to=quentin.schulz@cherry.de \
    --cc=antonin.godard@bootlin.com \
    --cc=docs@lists.yoctoproject.org \
    --cc=thomas.petazzoni@bootlin.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox