All of lore.kernel.org
 help / color / mirror / Atom feed
From: Bart Van Assche <bvanassche@acm.org>
To: Matthew Wilcox <willy@infradead.org>
Cc: "Martin K . Petersen" <martin.petersen@oracle.com>,
	linux-scsi@vger.kernel.org, Damien Le Moal <dlemoal@kernel.org>,
	Christoph Hellwig <hch@lst.de>
Subject: Re: [PATCH 1/4] scsi: Rename .slave_alloc() and .slave_destroy()
Date: Mon, 30 Sep 2024 14:10:06 -0700	[thread overview]
Message-ID: <0c044232-e36c-4c0b-a87d-4be25bd737cf@acm.org> (raw)
In-Reply-To: <ZvsQ310JHWHJAv7l@casper.infradead.org>

On 9/30/24 1:58 PM, Matthew Wilcox wrote:
> On Mon, Sep 30, 2024 at 01:18:47PM -0700, Bart Van Assche wrote:
>> There is agreement that the word "slave" should not be used in Linux
>> kernel source code. Hence this patch that renames .slave_alloc() into
>> .device_alloc() and .slave_destroy() into .device_destroy() in the SCSI
>> core, SCSI drivers, ATA drivers and also in the SCSI documentation.
>> Do not modify Documentation/scsi/ChangeLog.lpfc. No functionality has
>> been changed.
>>
>> This patch has been created as follows:
>> * Change the text "slave_alloc" into "device_alloc" in all source files
>>    except in the LPFC driver changelog.
>> * Change the text "slave_destroy" into "device_destroy" in all source
>>    files except in the LPFC driver changelog.
> 
> I still like my names better:
> 
> https://lore.kernel.org/linux-scsi/20200706193920.6897-1-willy@infradead.org/

The names used in this patch series are the names proposed by Christoph
Hellwig. Christoph, do you agree with the names proposed by Matthew?
 From his cover letter:

   scsi: Rename slave_alloc to sdev_prep
   scsi: Rename slave_destroy to sdev_destroy
   scsi: Rename slave_configure to sdev_configure

Thanks,

Bart.

  reply	other threads:[~2024-09-30 21:10 UTC|newest]

Thread overview: 16+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2024-09-30 20:18 [PATCH 0/4] Do not use "slave" in function names Bart Van Assche
2024-09-30 20:18 ` [PATCH 1/4] scsi: Rename .slave_alloc() and .slave_destroy() Bart Van Assche
2024-09-30 20:58   ` Matthew Wilcox
2024-09-30 21:10     ` Bart Van Assche [this message]
2024-10-01  0:10   ` Damien Le Moal
2024-10-02 20:23     ` Bart Van Assche
2024-10-02 22:26       ` Damien Le Moal
2024-10-01  3:26   ` Randy Dunlap
2024-10-01  4:43     ` Randy Dunlap
2024-10-01 20:15       ` Bart Van Assche
2024-09-30 20:18 ` [PATCH 2/4] scsi: Convert SCSI drivers to .device_configure() Bart Van Assche
2024-10-01  6:11   ` Leon Romanovsky
2024-10-02  9:02   ` Geoff Levand
2024-10-02 15:19   ` Khalid Aziz
2024-09-30 20:18 ` [PATCH 3/4] scsi: core: Remove .slave_configure() Bart Van Assche
2024-09-30 20:18 ` [PATCH 4/4] scsi: core: Update .slave_configure() references in the documentation Bart Van Assche

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=0c044232-e36c-4c0b-a87d-4be25bd737cf@acm.org \
    --to=bvanassche@acm.org \
    --cc=dlemoal@kernel.org \
    --cc=hch@lst.de \
    --cc=linux-scsi@vger.kernel.org \
    --cc=martin.petersen@oracle.com \
    --cc=willy@infradead.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.