From: Damien Le Moal <dlemoal@kernel.org>
To: Bart Van Assche <bvanassche@acm.org>,
"Martin K . Petersen" <martin.petersen@oracle.com>
Cc: linux-scsi@vger.kernel.org, Jonathan Corbet <corbet@lwn.net>,
Niklas Cassel <cassel@kernel.org>,
Takashi Sakamoto <o-takashi@sakamocchi.jp>,
Sathya Prakash <sathya.prakash@broadcom.com>,
Sreekanth Reddy <sreekanth.reddy@broadcom.com>,
Suganath Prabu Subramani <suganath-prabu.subramani@broadcom.com>,
Tariq Toukan <tariqt@nvidia.com>,
"David S. Miller" <davem@davemloft.net>,
Eric Dumazet <edumazet@google.com>,
Jakub Kicinski <kuba@kernel.org>, Paolo Abeni <pabeni@redhat.com>,
Steffen Maier <maier@linux.ibm.com>,
Benjamin Block <bblock@linux.ibm.com>,
Heiko Carstens <hca@linux.ibm.com>,
Vasily Gorbik <gor@linux.ibm.com>,
Alexander Gordeev <agordeev@linux.ibm.com>,
"James E.J. Bottomley" <James.Bottomley@HansenPartnership.com>,
Hannes Reinecke <hare@suse.com>,
Anil Gurumurthy <anil.gurumurthy@qlogic.com>,
Sudarsana Kalluru <sudarsana.kalluru@qlogic.com>,
Saurav Kashyap <skashyap@marvell.com>,
Javed Hasan <jhasan@marvell.com>,
GR-QLogic-Storage-Upstream@marvell.com,
Oliver Neukum <oliver@neukum.org>, Ali Akcaagac <aliakc@web.de>,
Jamie Lenehan <lenehan@twibble.org>,
Satish Kharat <satishkh@cisco.com>,
Sesidhar Baddela <sebaddel@cisco.com>,
Karan Tilak Kumar <kartilak@cisco.com>,
Yihang Li <liyihang9@huawei.com>,
Don Brace <don.brace@microchip.com>,
Tyrel Datwyler <tyreld@linux.ibm.com>,
Michael Ellerman <mpe@ellerman.id.au>,
Brian King <brking@us.ibm.com>,
James Smart <james.smart@broadcom.com>,
Dick Kennedy <dick.kennedy@broadcom.com>,
Kashyap Desai <kashyap.desai@broadcom.com>,
Sumit Saxena <sumit.saxena@broadcom.com>,
Shivasharan S <shivasharan.srikanteshwara@broadcom.com>,
Chandrakanth patil <chandrakanth.patil@broadcom.com>,
Nilesh Javali <njavali@marvell.com>,
Manish Rangankar <mrangankar@marvell.com>,
"K. Y. Srinivasan" <kys@microsoft.com>,
Haiyang Zhang <haiyangz@microsoft.com>,
Wei Liu <wei.liu@kernel.org>, Dexuan Cui <decui@microsoft.com>,
Matthew Wilcox <willy@infradead.org>,
"Michael S. Tsirkin" <mst@redhat.com>,
Jason Wang <jasowang@redhat.com>, Juergen Gross <jgross@suse.com>,
Stefano Stabellini <sstabellini@kernel.org>,
Greg Kroah-Hartman <gregkh@linuxfoundation.org>,
Alan Stern <stern@rowland.harvard.edu>,
Randy Dunlap <rdunlap@infradead.org>,
John Garry <john.g.garry@oracle.com>,
Soumya Negi <soumya.negi97@gmail.com>,
Johannes Thumshirn <johannes.thumshirn@wdc.com>,
Peter Wang <peter.wang@mediatek.com>,
Manivannan Sadhasivam <manivannan.sadhasivam@linaro.org>,
Avri Altman <avri.altman@wdc.com>,
Andrew Halaney <ahalaney@redhat.com>,
Bean Huo <beanhuo@micron.com>,
"Bao D. Nguyen" <quic_nguyenb@quicinc.com>
Subject: Re: [PATCH 1/4] scsi: Rename .slave_alloc() and .slave_destroy()
Date: Tue, 1 Oct 2024 09:10:57 +0900 [thread overview]
Message-ID: <5b3e96da-9fe9-4eb5-ad0e-0377622df5c2@kernel.org> (raw)
In-Reply-To: <20240930201937.2020129-2-bvanassche@acm.org>
On 10/1/24 05:18, Bart Van Assche wrote:
> There is agreement that the word "slave" should not be used in Linux
> kernel source code. Hence this patch that renames .slave_alloc() into
> .device_alloc() and .slave_destroy() into .device_destroy() in the SCSI
> core, SCSI drivers, ATA drivers and also in the SCSI documentation.
> Do not modify Documentation/scsi/ChangeLog.lpfc. No functionality has
> been changed.
>
> This patch has been created as follows:
> * Change the text "slave_alloc" into "device_alloc" in all source files
> except in the LPFC driver changelog.
Looks good, but like Matthew, I think sdev_xxx may be better names as they make
it clear that the operations take a struct scsi_device. But I will not hold this
series for that though.
The patch is really big too, so maybe move the documentation changes together
with patch 4 ?
Also, please send the cover letter to everyone. Having to look at all patch
titles to try to figure out what your patches do overall is not fun.
> * Change the text "slave_destroy" into "device_destroy" in all source
> files except in the LPFC driver changelog.
> * Rename lpfc_no_slave() into lpfc_no_device().
> * Manually adjust whitespace where necessary to restore vertical
> alignment (dc395x driver and include/linux/libata.h).
>
> Cc: Damien Le Moal <dlemoal@kernel.org>
> Signed-off-by: Bart Van Assche <bvanassche@acm.org>
[...]
> diff --git a/include/linux/libata.h b/include/linux/libata.h
> index 9b4a6ff03235..e04184b6d79b 100644
> --- a/include/linux/libata.h
> +++ b/include/linux/libata.h
> @@ -1201,10 +1201,10 @@ extern int ata_std_bios_param(struct scsi_device *sdev,
> struct block_device *bdev,
> sector_t capacity, int geom[]);
> extern void ata_scsi_unlock_native_capacity(struct scsi_device *sdev);
> -extern int ata_scsi_slave_alloc(struct scsi_device *sdev);
> +extern int ata_scsi_device_alloc(struct scsi_device *sdev);
While at it, drop the extern.
> int ata_scsi_device_configure(struct scsi_device *sdev,
> struct queue_limits *lim);
> -extern void ata_scsi_slave_destroy(struct scsi_device *sdev);
> +extern void ata_scsi_device_destroy(struct scsi_device *sdev);
Here too.
> extern int ata_scsi_change_queue_depth(struct scsi_device *sdev,
> int queue_depth);
> extern int ata_change_queue_depth(struct ata_port *ap, struct scsi_device *sdev,
> @@ -1460,8 +1460,8 @@ extern const struct attribute_group *ata_common_sdev_groups[];
> .this_id = ATA_SHT_THIS_ID, \
> .emulated = ATA_SHT_EMULATED, \
> .proc_name = drv_name, \
> - .slave_alloc = ata_scsi_slave_alloc, \
> - .slave_destroy = ata_scsi_slave_destroy, \
> + .device_alloc = ata_scsi_device_alloc, \
> + .device_destroy = ata_scsi_device_destroy, \
> .bios_param = ata_std_bios_param, \
> .unlock_native_capacity = ata_scsi_unlock_native_capacity,\
> .max_sectors = ATA_MAX_SECTORS_LBA48
--
Damien Le Moal
Western Digital Research
next prev parent reply other threads:[~2024-10-01 0:11 UTC|newest]
Thread overview: 16+ messages / expand[flat|nested] mbox.gz Atom feed top
2024-09-30 20:18 [PATCH 0/4] Do not use "slave" in function names Bart Van Assche
2024-09-30 20:18 ` [PATCH 1/4] scsi: Rename .slave_alloc() and .slave_destroy() Bart Van Assche
2024-09-30 20:58 ` Matthew Wilcox
2024-09-30 21:10 ` Bart Van Assche
2024-10-01 0:10 ` Damien Le Moal [this message]
2024-10-02 20:23 ` Bart Van Assche
2024-10-02 22:26 ` Damien Le Moal
2024-10-01 3:26 ` Randy Dunlap
2024-10-01 4:43 ` Randy Dunlap
2024-10-01 20:15 ` Bart Van Assche
2024-09-30 20:18 ` [PATCH 2/4] scsi: Convert SCSI drivers to .device_configure() Bart Van Assche
2024-10-01 6:11 ` Leon Romanovsky
2024-10-02 9:02 ` Geoff Levand
2024-10-02 15:19 ` Khalid Aziz
2024-09-30 20:18 ` [PATCH 3/4] scsi: core: Remove .slave_configure() Bart Van Assche
2024-09-30 20:18 ` [PATCH 4/4] scsi: core: Update .slave_configure() references in the documentation Bart Van Assche
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=5b3e96da-9fe9-4eb5-ad0e-0377622df5c2@kernel.org \
--to=dlemoal@kernel.org \
--cc=GR-QLogic-Storage-Upstream@marvell.com \
--cc=James.Bottomley@HansenPartnership.com \
--cc=agordeev@linux.ibm.com \
--cc=ahalaney@redhat.com \
--cc=aliakc@web.de \
--cc=anil.gurumurthy@qlogic.com \
--cc=avri.altman@wdc.com \
--cc=bblock@linux.ibm.com \
--cc=beanhuo@micron.com \
--cc=brking@us.ibm.com \
--cc=bvanassche@acm.org \
--cc=cassel@kernel.org \
--cc=chandrakanth.patil@broadcom.com \
--cc=corbet@lwn.net \
--cc=davem@davemloft.net \
--cc=decui@microsoft.com \
--cc=dick.kennedy@broadcom.com \
--cc=don.brace@microchip.com \
--cc=edumazet@google.com \
--cc=gor@linux.ibm.com \
--cc=gregkh@linuxfoundation.org \
--cc=haiyangz@microsoft.com \
--cc=hare@suse.com \
--cc=hca@linux.ibm.com \
--cc=james.smart@broadcom.com \
--cc=jasowang@redhat.com \
--cc=jgross@suse.com \
--cc=jhasan@marvell.com \
--cc=johannes.thumshirn@wdc.com \
--cc=john.g.garry@oracle.com \
--cc=kartilak@cisco.com \
--cc=kashyap.desai@broadcom.com \
--cc=kuba@kernel.org \
--cc=kys@microsoft.com \
--cc=lenehan@twibble.org \
--cc=linux-scsi@vger.kernel.org \
--cc=liyihang9@huawei.com \
--cc=maier@linux.ibm.com \
--cc=manivannan.sadhasivam@linaro.org \
--cc=martin.petersen@oracle.com \
--cc=mpe@ellerman.id.au \
--cc=mrangankar@marvell.com \
--cc=mst@redhat.com \
--cc=njavali@marvell.com \
--cc=o-takashi@sakamocchi.jp \
--cc=oliver@neukum.org \
--cc=pabeni@redhat.com \
--cc=peter.wang@mediatek.com \
--cc=quic_nguyenb@quicinc.com \
--cc=rdunlap@infradead.org \
--cc=sathya.prakash@broadcom.com \
--cc=satishkh@cisco.com \
--cc=sebaddel@cisco.com \
--cc=shivasharan.srikanteshwara@broadcom.com \
--cc=skashyap@marvell.com \
--cc=soumya.negi97@gmail.com \
--cc=sreekanth.reddy@broadcom.com \
--cc=sstabellini@kernel.org \
--cc=stern@rowland.harvard.edu \
--cc=sudarsana.kalluru@qlogic.com \
--cc=suganath-prabu.subramani@broadcom.com \
--cc=sumit.saxena@broadcom.com \
--cc=tariqt@nvidia.com \
--cc=tyreld@linux.ibm.com \
--cc=wei.liu@kernel.org \
--cc=willy@infradead.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.