From: Johannes Berg <johannes@sipsolutions.net>
To: ath9k-devel@lists.ath9k.org
Subject: [ath9k-devel] [PATCH 05/16] wireless: allow for private channel area
Date: Sun, 21 Dec 2008 11:34:35 +0100 [thread overview]
Message-ID: <1229855675.4953.6.camel@johannes> (raw)
In-Reply-To: <1229752522-1917-6-git-send-email-lrodriguez@atheros.com> (sfid-20081220_065605_625660_6912E235)
On Fri, 2008-12-19 at 21:55 -0800, Luis R. Rodriguez wrote:
> Wireless drivers tend to require calibration or noise floor
> checks. Some of these operations are channel specific. Instead
> of forcing each driver to keep a separate map for these values
> per channel allow for a private area on the ieee80211_channel to
> reduce code overhead and size.
>
> Signed-off-by: Luis R. Rodriguez <lrodriguez@atheros.com>
I don't like this much. This is prone to abuse, it'll only be right when
you have allocated channel arrays statically.
Can't you do something like I do in ar9170 and put the other information
into a table that is indexed by hw_key_idx? That even reduces the memory
usage :)
johannes
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 836 bytes
Desc: This is a digitally signed message part
Url : http://lists.ath9k.org/pipermail/ath9k-devel/attachments/20081221/33d0981c/attachment.pgp
WARNING: multiple messages have this Message-ID (diff)
From: Johannes Berg <johannes@sipsolutions.net>
To: "Luis R. Rodriguez" <lrodriguez@atheros.com>
Cc: linville@tuxdriver.com, linux-wireless@vger.kernel.org,
ath9k-devel@lists.ath9k.org, kalle.valo@nokia.com
Subject: Re: [PATCH 05/16] wireless: allow for private channel area
Date: Sun, 21 Dec 2008 11:34:35 +0100 [thread overview]
Message-ID: <1229855675.4953.6.camel@johannes> (raw)
In-Reply-To: <1229752522-1917-6-git-send-email-lrodriguez@atheros.com> (sfid-20081220_065605_625660_6912E235)
[-- Attachment #1: Type: text/plain, Size: 718 bytes --]
On Fri, 2008-12-19 at 21:55 -0800, Luis R. Rodriguez wrote:
> Wireless drivers tend to require calibration or noise floor
> checks. Some of these operations are channel specific. Instead
> of forcing each driver to keep a separate map for these values
> per channel allow for a private area on the ieee80211_channel to
> reduce code overhead and size.
>
> Signed-off-by: Luis R. Rodriguez <lrodriguez@atheros.com>
I don't like this much. This is prone to abuse, it'll only be right when
you have allocated channel arrays statically.
Can't you do something like I do in ar9170 and put the other information
into a table that is indexed by hw_key_idx? That even reduces the memory
usage :)
johannes
[-- Attachment #2: This is a digitally signed message part --]
[-- Type: application/pgp-signature, Size: 836 bytes --]
next prev parent reply other threads:[~2008-12-21 10:34 UTC|newest]
Thread overview: 30+ messages / expand[flat|nested] mbox.gz Atom feed top
2008-12-20 5:55 [PATCH 00/16] ath9k: first series for regulatory cleanup Luis R. Rodriguez
2008-12-20 5:55 ` [PATCH 01/16] mac80211: add HT conf helpers Luis R. Rodriguez
2008-12-20 5:55 ` [PATCH 02/16] ath9k: use hw->conf on ath_setcurmode() Luis R. Rodriguez
2008-12-20 5:55 ` [PATCH 03/16] ath9k: remove cache of rate preference when using 11g protection Luis R. Rodriguez
2008-12-20 5:55 ` [PATCH 04/16] ath9k: Rename ath_setcurmode() to ath_cache_conf_rate() Luis R. Rodriguez
2008-12-20 5:55 ` [PATCH 05/16] wireless: allow for private channel area Luis R. Rodriguez
2008-12-20 5:55 ` [PATCH 06/16] ath9k: start making use of channel->priv Luis R. Rodriguez
2008-12-20 5:55 ` [PATCH 07/16] ath9k: consolidate arguments on hw reset Luis R. Rodriguez
2008-12-20 5:55 ` [PATCH 08/16] ath9k: make request to get the noisefloor threshold band specific Luis R. Rodriguez
2008-12-20 5:55 ` [PATCH 09/16] ath9k: use ieee80211_conf on ath9k_hw_iscal_supported() Luis R. Rodriguez
2008-12-20 5:55 ` [PATCH 10/16] ath9k: make use of conf_is_ht40() in the rest of the driver Luis R. Rodriguez
2008-12-20 5:55 ` [PATCH 11/16] ath9k: Make ANI CCK and OFDM error triggers band specific Luis R. Rodriguez
2008-12-20 5:55 ` [PATCH 12/16] ath9k: remove mode specific default noise floor values Luis R. Rodriguez
2008-12-20 5:55 ` [PATCH 13/16] ath9k: remove ath9k_hw_chan2wmode() Luis R. Rodriguez
2008-12-20 5:55 ` [PATCH 14/16] ath9k: remove ath9k_hw_check_chan() Luis R. Rodriguez
2008-12-20 5:55 ` [PATCH 15/16] ath9k: remove superfluous check on changing channel Luis R. Rodriguez
2008-12-20 5:55 ` [PATCH 16/16] ath9k: fix sparse warnings Luis R. Rodriguez
2008-12-21 10:34 ` Johannes Berg [this message]
2008-12-21 10:34 ` [PATCH 05/16] wireless: allow for private channel area Johannes Berg
2008-12-21 18:58 ` [ath9k-devel] " Luis R. Rodriguez
2008-12-20 21:06 ` [ath9k-devel] [PATCH 01/16] mac80211: add HT conf helpers Tomas Winkler
2008-12-20 21:06 ` Tomas Winkler
2008-12-21 10:32 ` [ath9k-devel] " Johannes Berg
2008-12-21 10:32 ` Johannes Berg
2008-12-20 19:10 ` [ath9k-devel] [PATCH 00/16] ath9k: first series for regulatory cleanup Luis R. Rodriguez
2008-12-20 19:10 ` Luis R. Rodriguez
2008-12-21 2:45 ` [ath9k-devel] 11NAHT40PLUS Brian
2008-12-21 18:36 ` Luis R. Rodriguez
2008-12-22 15:57 ` [ath9k-devel] [PATCH 00/16] ath9k: first series for regulatory cleanup Luis R. Rodriguez
2008-12-22 15:57 ` Luis R. Rodriguez
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=1229855675.4953.6.camel@johannes \
--to=johannes@sipsolutions.net \
--cc=ath9k-devel@lists.ath9k.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.