From: mkl0301@gmail.com
To: htejun@gmail.com, cbouatmailru@gmail.com,
linux-arm-kernel@lists.infradead.org, jgarzik@pobox.com,
linux-ide@vger.kernel.org
Cc: Mac Lin <mkl0301@gmail.com>
Subject: [PATCH v4 0/3] add CNS3xxx AHCI support
Date: Sun, 9 Jan 2011 09:49:32 +0800 [thread overview]
Message-ID: <1294537775-21714-1-git-send-email-mkl0301@gmail.com> (raw)
From: Mac Lin <mkl0301@gmail.com>
v4:
- v2 basically, which make SoC-specific changes into separate files
- Rename module ahci_platform to ahci_platforms, into which link the ahci_platform and the SoC-specific changes
- No rename of ahci_platform.c
- Some cosmetic code changes since v2
v3: http://www.spinics.net/lists/arm-kernel/msg109924.html
- Make the SoC-specific changes into ahci_platform.c directly.
- Some cosmetic code changes
=> ahci_platform.c is less readable due to SoC-specific changes and macro
v2: http://www.spinics.net/lists/linux-ide/msg39766.html
- Renaming ahci_platform.c to ahci_pltfm.c for linking SoC specific changes into ahci_platform, while not changing the module name.
- Switch ahci_platform to module device table matching to add SoC specific support
- Add CNS3xxx SoC specific AHCI support to ahci_cns3xxx.c
v1: http://www.spinics.net/lists/arm-kernel/msg106236.html
- Add CNS3xxx SoC specific AHCI support to arch/arm/mach-cns3xxx
=> The changes depends on libahci and libata, i.e. both of them need to be built into kernel
This patchset is based on linux-2.6.37
Mac Lin (3):
ahci_platform: rename module ahci_platform to ahci_platforms
ahci_platform: switch to module device table matching
ahci_platforms: add support for CNS3xxx SoC devices
arch/arm/mach-cns3xxx/devices.c | 2 +-
drivers/ata/Kconfig | 11 ++++++++
drivers/ata/Makefile | 5 +++-
drivers/ata/ahci_cns3xxx.c | 51 +++++++++++++++++++++++++++++++++++++++
drivers/ata/ahci_platform.c | 17 ++++++++++++-
drivers/ata/ahci_platforms.h | 18 +++++++++++++
6 files changed, 101 insertions(+), 3 deletions(-)
create mode 100644 drivers/ata/ahci_cns3xxx.c
create mode 100644 drivers/ata/ahci_platforms.h
WARNING: multiple messages have this Message-ID (diff)
From: mkl0301@gmail.com (mkl0301 at gmail.com)
To: linux-arm-kernel@lists.infradead.org
Subject: [PATCH v4 0/3] add CNS3xxx AHCI support
Date: Sun, 9 Jan 2011 09:49:32 +0800 [thread overview]
Message-ID: <1294537775-21714-1-git-send-email-mkl0301@gmail.com> (raw)
From: Mac Lin <mkl0301@gmail.com>
v4:
- v2 basically, which make SoC-specific changes into separate files
- Rename module ahci_platform to ahci_platforms, into which link the ahci_platform and the SoC-specific changes
- No rename of ahci_platform.c
- Some cosmetic code changes since v2
v3: http://www.spinics.net/lists/arm-kernel/msg109924.html
- Make the SoC-specific changes into ahci_platform.c directly.
- Some cosmetic code changes
=> ahci_platform.c is less readable due to SoC-specific changes and macro
v2: http://www.spinics.net/lists/linux-ide/msg39766.html
- Renaming ahci_platform.c to ahci_pltfm.c for linking SoC specific changes into ahci_platform, while not changing the module name.
- Switch ahci_platform to module device table matching to add SoC specific support
- Add CNS3xxx SoC specific AHCI support to ahci_cns3xxx.c
v1: http://www.spinics.net/lists/arm-kernel/msg106236.html
- Add CNS3xxx SoC specific AHCI support to arch/arm/mach-cns3xxx
=> The changes depends on libahci and libata, i.e. both of them need to be built into kernel
This patchset is based on linux-2.6.37
Mac Lin (3):
ahci_platform: rename module ahci_platform to ahci_platforms
ahci_platform: switch to module device table matching
ahci_platforms: add support for CNS3xxx SoC devices
arch/arm/mach-cns3xxx/devices.c | 2 +-
drivers/ata/Kconfig | 11 ++++++++
drivers/ata/Makefile | 5 +++-
drivers/ata/ahci_cns3xxx.c | 51 +++++++++++++++++++++++++++++++++++++++
drivers/ata/ahci_platform.c | 17 ++++++++++++-
drivers/ata/ahci_platforms.h | 18 +++++++++++++
6 files changed, 101 insertions(+), 3 deletions(-)
create mode 100644 drivers/ata/ahci_cns3xxx.c
create mode 100644 drivers/ata/ahci_platforms.h
next reply other threads:[~2011-01-09 1:49 UTC|newest]
Thread overview: 14+ messages / expand[flat|nested] mbox.gz Atom feed top
2011-01-09 1:49 mkl0301 [this message]
2011-01-09 1:49 ` [PATCH v4 0/3] add CNS3xxx AHCI support mkl0301 at gmail.com
2011-01-09 1:49 ` [PATCH v4 1/3] ahci_platform: rename module ahci_platform to ahci_platforms mkl0301
2011-01-09 1:49 ` mkl0301 at gmail.com
2011-01-09 3:03 ` Anton Vorontsov
2011-01-09 3:03 ` Anton Vorontsov
2011-01-09 1:49 ` [PATCH v4 2/3] ahci_platform: switch to module device table matching mkl0301
2011-01-09 1:49 ` mkl0301 at gmail.com
2011-01-09 2:56 ` Anton Vorontsov
2011-01-09 2:56 ` Anton Vorontsov
2011-01-09 1:49 ` [PATCH v4 3/3] ahci_platforms: add support for CNS3xxx SoC devices mkl0301
2011-01-09 1:49 ` mkl0301 at gmail.com
2011-01-09 3:02 ` Anton Vorontsov
2011-01-09 3:02 ` Anton Vorontsov
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=1294537775-21714-1-git-send-email-mkl0301@gmail.com \
--to=mkl0301@gmail.com \
--cc=cbouatmailru@gmail.com \
--cc=htejun@gmail.com \
--cc=jgarzik@pobox.com \
--cc=linux-arm-kernel@lists.infradead.org \
--cc=linux-ide@vger.kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.