* [PATCH] rpmsg: rename virtqueue_add_buf_gfp to virtqueue_add_buf
@ 2011-12-13 7:14 Axel Lin
2011-12-13 7:20 ` Ohad Ben-Cohen
0 siblings, 1 reply; 3+ messages in thread
From: Axel Lin @ 2011-12-13 7:14 UTC (permalink / raw)
To: linux-kernel; +Cc: Rusty Russell, Ohad Ben-Cohen
Since commit 7bb7aef2 "virtio: rename virtqueue_add_buf_gfp to virtqueue_add_buf",
virtqueue_add_buf_gfp is renamed to virtqueue_add_buf now.
This patch fixes below build error:
CC [M] drivers/rpmsg/virtio_rpmsg_bus.o
drivers/rpmsg/virtio_rpmsg_bus.c: In function 'rpmsg_send_offchannel_raw':
drivers/rpmsg/virtio_rpmsg_bus.c:723: error: implicit declaration of function 'virtqueue_add_buf_gfp'
make[2]: *** [drivers/rpmsg/virtio_rpmsg_bus.o] Error 1
make[1]: *** [drivers/rpmsg] Error 2
make: *** [drivers] Error 2
Signed-off-by: Axel Lin <axel.lin@gmail.com>
---
I got the build error on linux-next 20111212.
So this patch is against linux-next.
Axel
drivers/rpmsg/virtio_rpmsg_bus.c | 8 ++++----
1 files changed, 4 insertions(+), 4 deletions(-)
diff --git a/drivers/rpmsg/virtio_rpmsg_bus.c b/drivers/rpmsg/virtio_rpmsg_bus.c
index 257683e..8980ac2 100644
--- a/drivers/rpmsg/virtio_rpmsg_bus.c
+++ b/drivers/rpmsg/virtio_rpmsg_bus.c
@@ -720,14 +720,14 @@ int rpmsg_send_offchannel_raw(struct rpmsg_channel *rpdev, u32 src, u32 dst,
mutex_lock(&vrp->tx_lock);
/* add message to the remote processor's virtqueue */
- err = virtqueue_add_buf_gfp(vrp->svq, &sg, 1, 0, msg, GFP_KERNEL);
+ err = virtqueue_add_buf(vrp->svq, &sg, 1, 0, msg, GFP_KERNEL);
if (err < 0) {
/*
* need to reclaim the buffer here, otherwise it's lost
* (memory won't leak, but rpmsg won't use it again for TX).
* this will wait for a buffer management overhaul.
*/
- dev_err(dev, "virtqueue_add_buf_gfp failed: %d\n", err);
+ dev_err(dev, "virtqueue_add_buf failed: %d\n", err);
goto out;
}
@@ -777,7 +777,7 @@ static void rpmsg_recv_done(struct virtqueue *rvq)
sg_init_one(&sg, msg, sizeof(*msg) + len);
/* add the buffer back to the remote processor's virtqueue */
- err = virtqueue_add_buf_gfp(vrp->rvq, &sg, 0, 1, msg, GFP_KERNEL);
+ err = virtqueue_add_buf(vrp->rvq, &sg, 0, 1, msg, GFP_KERNEL);
if (err < 0) {
dev_err(dev, "failed to add a virtqueue buffer: %d\n", err);
return;
@@ -907,7 +907,7 @@ static int rpmsg_probe(struct virtio_device *vdev)
sg_init_one(&sg, cpu_addr, RPMSG_BUF_SIZE);
- err = virtqueue_add_buf_gfp(vrp->rvq, &sg, 0, 1, cpu_addr,
+ err = virtqueue_add_buf(vrp->rvq, &sg, 0, 1, cpu_addr,
GFP_KERNEL);
WARN_ON(err < 0); /* sanity check; this can't really happen */
}
--
1.7.5.4
^ permalink raw reply related [flat|nested] 3+ messages in thread
* Re: [PATCH] rpmsg: rename virtqueue_add_buf_gfp to virtqueue_add_buf
2011-12-13 7:14 [PATCH] rpmsg: rename virtqueue_add_buf_gfp to virtqueue_add_buf Axel Lin
@ 2011-12-13 7:20 ` Ohad Ben-Cohen
2011-12-13 7:37 ` Stephen Rothwell
0 siblings, 1 reply; 3+ messages in thread
From: Ohad Ben-Cohen @ 2011-12-13 7:20 UTC (permalink / raw)
To: Axel Lin, Stephen Rothwell; +Cc: linux-kernel, Rusty Russell, linux-next
On Tue, Dec 13, 2011 at 9:14 AM, Axel Lin <axel.lin@gmail.com> wrote:
> Since commit 7bb7aef2 "virtio: rename virtqueue_add_buf_gfp to virtqueue_add_buf",
> virtqueue_add_buf_gfp is renamed to virtqueue_add_buf now.
>
> This patch fixes below build error:
> CC [M] drivers/rpmsg/virtio_rpmsg_bus.o
> drivers/rpmsg/virtio_rpmsg_bus.c: In function 'rpmsg_send_offchannel_raw':
> drivers/rpmsg/virtio_rpmsg_bus.c:723: error: implicit declaration of function 'virtqueue_add_buf_gfp'
> make[2]: *** [drivers/rpmsg/virtio_rpmsg_bus.o] Error 1
> make[1]: *** [drivers/rpmsg] Error 2
> make: *** [drivers] Error 2
>
> Signed-off-by: Axel Lin <axel.lin@gmail.com>
> ---
> I got the build error on linux-next 20111212.
> So this patch is against linux-next.
Thanks a lot for the heads up, Axel !
Stephen, can you please carry this patch in linux-next ?
Thanks!
Ohad.
^ permalink raw reply [flat|nested] 3+ messages in thread
* Re: [PATCH] rpmsg: rename virtqueue_add_buf_gfp to virtqueue_add_buf
2011-12-13 7:20 ` Ohad Ben-Cohen
@ 2011-12-13 7:37 ` Stephen Rothwell
0 siblings, 0 replies; 3+ messages in thread
From: Stephen Rothwell @ 2011-12-13 7:37 UTC (permalink / raw)
To: Ohad Ben-Cohen; +Cc: Axel Lin, linux-kernel, Rusty Russell, linux-next
[-- Attachment #1: Type: text/plain, Size: 1222 bytes --]
Hi,
On Tue, 13 Dec 2011 09:20:57 +0200 Ohad Ben-Cohen <ohad@wizery.com> wrote:
>
> On Tue, Dec 13, 2011 at 9:14 AM, Axel Lin <axel.lin@gmail.com> wrote:
> > Since commit 7bb7aef2 "virtio: rename virtqueue_add_buf_gfp to virtqueue_add_buf",
> > virtqueue_add_buf_gfp is renamed to virtqueue_add_buf now.
> >
> > This patch fixes below build error:
> > CC [M] drivers/rpmsg/virtio_rpmsg_bus.o
> > drivers/rpmsg/virtio_rpmsg_bus.c: In function 'rpmsg_send_offchannel_raw':
> > drivers/rpmsg/virtio_rpmsg_bus.c:723: error: implicit declaration of function 'virtqueue_add_buf_gfp'
> > make[2]: *** [drivers/rpmsg/virtio_rpmsg_bus.o] Error 1
> > make[1]: *** [drivers/rpmsg] Error 2
> > make: *** [drivers] Error 2
> >
> > Signed-off-by: Axel Lin <axel.lin@gmail.com>
> > ---
> > I got the build error on linux-next 20111212.
> > So this patch is against linux-next.
>
> Thanks a lot for the heads up, Axel !
>
> Stephen, can you please carry this patch in linux-next ?
I seem to have mislaid my copy :-(
If Axel could send to to me again, I will put it in as a merge fix tomorrow.
--
Cheers,
Stephen Rothwell sfr@canb.auug.org.au
http://www.canb.auug.org.au/~sfr/
[-- Attachment #2: Type: application/pgp-signature, Size: 836 bytes --]
^ permalink raw reply [flat|nested] 3+ messages in thread
end of thread, other threads:[~2011-12-13 7:37 UTC | newest]
Thread overview: 3+ messages (download: mbox.gz follow: Atom feed
-- links below jump to the message on this page --
2011-12-13 7:14 [PATCH] rpmsg: rename virtqueue_add_buf_gfp to virtqueue_add_buf Axel Lin
2011-12-13 7:20 ` Ohad Ben-Cohen
2011-12-13 7:37 ` Stephen Rothwell
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.