* [PATCH v11 5/8] KVM: PPC: ev_idle hcall support for e500 guests
@ 2012-06-22 20:04 ` Stuart Yoder
0 siblings, 0 replies; 8+ messages in thread
From: Stuart Yoder @ 2012-06-22 20:04 UTC (permalink / raw)
To: agraf, kvm-ppc, kvm
From: Liu Yu-B13201 <Yu.Liu@freescale.com>
Signed-off-by: Liu Yu <yu.liu@freescale.com>
[varun: 64-bit changes]
Signed-off-by: Varun Sethi <Varun.Sethi@freescale.com>
Signed-off-by: Stuart Yoder <stuart.yoder@freescale.com>
---
-v11:
-added comment about origin of idle instruction sequence
-update for 64-bit support found in testing
arch/powerpc/include/asm/epapr_hcalls.h | 11 +++++----
arch/powerpc/kernel/epapr_hcalls.S | 32 +++++++++++++++++++++++++++++++
arch/powerpc/kernel/epapr_paravirt.c | 11 +++++++++-
3 files changed, 48 insertions(+), 6 deletions(-)
diff --git a/arch/powerpc/include/asm/epapr_hcalls.h b/arch/powerpc/include/asm/epapr_hcalls.h
index c0c7adc..833ce2c 100644
--- a/arch/powerpc/include/asm/epapr_hcalls.h
+++ b/arch/powerpc/include/asm/epapr_hcalls.h
@@ -50,10 +50,6 @@
#ifndef _EPAPR_HCALLS_H
#define _EPAPR_HCALLS_H
-#include <linux/types.h>
-#include <linux/errno.h>
-#include <asm/byteorder.h>
-
#define EV_BYTE_CHANNEL_SEND 1
#define EV_BYTE_CHANNEL_RECEIVE 2
#define EV_BYTE_CHANNEL_POLL 3
@@ -109,6 +105,11 @@
#define EV_UNIMPLEMENTED 12 /* Unimplemented hypercall */
#define EV_BUFFER_OVERFLOW 13 /* Caller-supplied buffer too small */
+#ifndef __ASSEMBLY__
+#include <linux/types.h>
+#include <linux/errno.h>
+#include <asm/byteorder.h>
+
/*
* Hypercall register clobber list
*
@@ -506,5 +507,5 @@ static inline unsigned int ev_idle(void)
return r3;
}
-
+#endif /* !__ASSEMBLY__ */
#endif
diff --git a/arch/powerpc/kernel/epapr_hcalls.S b/arch/powerpc/kernel/epapr_hcalls.S
index 697b390..eb19377 100644
--- a/arch/powerpc/kernel/epapr_hcalls.S
+++ b/arch/powerpc/kernel/epapr_hcalls.S
@@ -8,13 +8,45 @@
*/
#include <linux/threads.h>
+#include <asm/epapr_hcalls.h>
#include <asm/reg.h>
#include <asm/page.h>
#include <asm/cputable.h>
#include <asm/thread_info.h>
#include <asm/ppc_asm.h>
+#include <asm/asm-compat.h>
#include <asm/asm-offsets.h>
+/* epapr_ev_idle() was derived from e500_idle() */
+_GLOBAL(epapr_ev_idle)
+#ifndef CONFIG_PPC64
+ rlwinm r3, r1, 0, 0, 31-THREAD_SHIFT /* current thread_info */
+#else
+ clrrdi r3, r1, THREAD_SHIFT
+#endif
+ PPC_LL r4, TI_LOCAL_FLAGS(r3) /* set napping bit */
+ ori r4, r4,_TLF_NAPPING /* so when we take an exception */
+ PPC_STL r4, TI_LOCAL_FLAGS(r3) /* it will return to our caller */
+
+ wrteei 1
+
+idle_loop:
+ LOAD_REG_IMMEDIATE(r11, EV_HCALL_TOKEN(EV_IDLE))
+
+.global epapr_ev_idle_start
+epapr_ev_idle_start:
+ li r3, -1
+ nop
+ nop
+ nop
+
+ /*
+ * Guard against spurious wakeups from a hypervisor --
+ * only interrupt will cause us to return to LR due to
+ * _TLF_NAPPING.
+ */
+ b idle_loop
+
/* Hypercall entry point. Will be patched with device tree instructions. */
.global epapr_hypercall_start
epapr_hypercall_start:
diff --git a/arch/powerpc/kernel/epapr_paravirt.c b/arch/powerpc/kernel/epapr_paravirt.c
index 028aeae..f3eab85 100644
--- a/arch/powerpc/kernel/epapr_paravirt.c
+++ b/arch/powerpc/kernel/epapr_paravirt.c
@@ -21,6 +21,10 @@
#include <asm/epapr_hcalls.h>
#include <asm/cacheflush.h>
#include <asm/code-patching.h>
+#include <asm/machdep.h>
+
+extern void epapr_ev_idle(void);
+extern u32 epapr_ev_idle_start[];
bool epapr_paravirt_enabled;
@@ -41,8 +45,13 @@ static int __init epapr_paravirt_init(void)
if (len % 4 || len > (4 * 4))
return -ENODEV;
- for (i = 0; i < (len / 4); i++)
+ for (i = 0; i < (len / 4); i++) {
patch_instruction(epapr_hypercall_start + i, insts[i]);
+ patch_instruction(epapr_ev_idle_start + i, insts[i]);
+ }
+
+ if (of_get_property(hyper_node, "has-idle", NULL))
+ ppc_md.power_save = epapr_ev_idle;
epapr_paravirt_enabled = true;
--
1.7.3.4
^ permalink raw reply related [flat|nested] 8+ messages in thread
* [PATCH v11 5/8] KVM: PPC: ev_idle hcall support for e500 guests
@ 2012-06-22 20:04 ` Stuart Yoder
0 siblings, 0 replies; 8+ messages in thread
From: Stuart Yoder @ 2012-06-22 20:04 UTC (permalink / raw)
To: agraf, kvm-ppc, kvm
From: Liu Yu-B13201 <Yu.Liu@freescale.com>
Signed-off-by: Liu Yu <yu.liu@freescale.com>
[varun: 64-bit changes]
Signed-off-by: Varun Sethi <Varun.Sethi@freescale.com>
Signed-off-by: Stuart Yoder <stuart.yoder@freescale.com>
---
-v11:
-added comment about origin of idle instruction sequence
-update for 64-bit support found in testing
arch/powerpc/include/asm/epapr_hcalls.h | 11 +++++----
arch/powerpc/kernel/epapr_hcalls.S | 32 +++++++++++++++++++++++++++++++
arch/powerpc/kernel/epapr_paravirt.c | 11 +++++++++-
3 files changed, 48 insertions(+), 6 deletions(-)
diff --git a/arch/powerpc/include/asm/epapr_hcalls.h b/arch/powerpc/include/asm/epapr_hcalls.h
index c0c7adc..833ce2c 100644
--- a/arch/powerpc/include/asm/epapr_hcalls.h
+++ b/arch/powerpc/include/asm/epapr_hcalls.h
@@ -50,10 +50,6 @@
#ifndef _EPAPR_HCALLS_H
#define _EPAPR_HCALLS_H
-#include <linux/types.h>
-#include <linux/errno.h>
-#include <asm/byteorder.h>
-
#define EV_BYTE_CHANNEL_SEND 1
#define EV_BYTE_CHANNEL_RECEIVE 2
#define EV_BYTE_CHANNEL_POLL 3
@@ -109,6 +105,11 @@
#define EV_UNIMPLEMENTED 12 /* Unimplemented hypercall */
#define EV_BUFFER_OVERFLOW 13 /* Caller-supplied buffer too small */
+#ifndef __ASSEMBLY__
+#include <linux/types.h>
+#include <linux/errno.h>
+#include <asm/byteorder.h>
+
/*
* Hypercall register clobber list
*
@@ -506,5 +507,5 @@ static inline unsigned int ev_idle(void)
return r3;
}
-
+#endif /* !__ASSEMBLY__ */
#endif
diff --git a/arch/powerpc/kernel/epapr_hcalls.S b/arch/powerpc/kernel/epapr_hcalls.S
index 697b390..eb19377 100644
--- a/arch/powerpc/kernel/epapr_hcalls.S
+++ b/arch/powerpc/kernel/epapr_hcalls.S
@@ -8,13 +8,45 @@
*/
#include <linux/threads.h>
+#include <asm/epapr_hcalls.h>
#include <asm/reg.h>
#include <asm/page.h>
#include <asm/cputable.h>
#include <asm/thread_info.h>
#include <asm/ppc_asm.h>
+#include <asm/asm-compat.h>
#include <asm/asm-offsets.h>
+/* epapr_ev_idle() was derived from e500_idle() */
+_GLOBAL(epapr_ev_idle)
+#ifndef CONFIG_PPC64
+ rlwinm r3, r1, 0, 0, 31-THREAD_SHIFT /* current thread_info */
+#else
+ clrrdi r3, r1, THREAD_SHIFT
+#endif
+ PPC_LL r4, TI_LOCAL_FLAGS(r3) /* set napping bit */
+ ori r4, r4,_TLF_NAPPING /* so when we take an exception */
+ PPC_STL r4, TI_LOCAL_FLAGS(r3) /* it will return to our caller */
+
+ wrteei 1
+
+idle_loop:
+ LOAD_REG_IMMEDIATE(r11, EV_HCALL_TOKEN(EV_IDLE))
+
+.global epapr_ev_idle_start
+epapr_ev_idle_start:
+ li r3, -1
+ nop
+ nop
+ nop
+
+ /*
+ * Guard against spurious wakeups from a hypervisor --
+ * only interrupt will cause us to return to LR due to
+ * _TLF_NAPPING.
+ */
+ b idle_loop
+
/* Hypercall entry point. Will be patched with device tree instructions. */
.global epapr_hypercall_start
epapr_hypercall_start:
diff --git a/arch/powerpc/kernel/epapr_paravirt.c b/arch/powerpc/kernel/epapr_paravirt.c
index 028aeae..f3eab85 100644
--- a/arch/powerpc/kernel/epapr_paravirt.c
+++ b/arch/powerpc/kernel/epapr_paravirt.c
@@ -21,6 +21,10 @@
#include <asm/epapr_hcalls.h>
#include <asm/cacheflush.h>
#include <asm/code-patching.h>
+#include <asm/machdep.h>
+
+extern void epapr_ev_idle(void);
+extern u32 epapr_ev_idle_start[];
bool epapr_paravirt_enabled;
@@ -41,8 +45,13 @@ static int __init epapr_paravirt_init(void)
if (len % 4 || len > (4 * 4))
return -ENODEV;
- for (i = 0; i < (len / 4); i++)
+ for (i = 0; i < (len / 4); i++) {
patch_instruction(epapr_hypercall_start + i, insts[i]);
+ patch_instruction(epapr_ev_idle_start + i, insts[i]);
+ }
+
+ if (of_get_property(hyper_node, "has-idle", NULL))
+ ppc_md.power_save = epapr_ev_idle;
epapr_paravirt_enabled = true;
--
1.7.3.4
^ permalink raw reply related [flat|nested] 8+ messages in thread
* Re: [PATCH v11 5/8] KVM: PPC: ev_idle hcall support for e500 guests
2012-06-22 20:04 ` Stuart Yoder
@ 2012-07-02 12:20 ` Alexander Graf
-1 siblings, 0 replies; 8+ messages in thread
From: Alexander Graf @ 2012-07-02 12:20 UTC (permalink / raw)
To: Stuart Yoder; +Cc: kvm-ppc, KVM list, Benjamin Herrenschmidt
On 22.06.2012, at 22:04, Stuart Yoder wrote:
> From: Liu Yu-B13201 <Yu.Liu@freescale.com>
>
> Signed-off-by: Liu Yu <yu.liu@freescale.com>
> [varun: 64-bit changes]
> Signed-off-by: Varun Sethi <Varun.Sethi@freescale.com>
> Signed-off-by: Stuart Yoder <stuart.yoder@freescale.com>
> ---
> -v11:
> -added comment about origin of idle instruction sequence
> -update for 64-bit support found in testing
>
> arch/powerpc/include/asm/epapr_hcalls.h | 11 +++++----
> arch/powerpc/kernel/epapr_hcalls.S | 32 +++++++++++++++++++++++++++++++
> arch/powerpc/kernel/epapr_paravirt.c | 11 +++++++++-
> 3 files changed, 48 insertions(+), 6 deletions(-)
>
> diff --git a/arch/powerpc/include/asm/epapr_hcalls.h b/arch/powerpc/include/asm/epapr_hcalls.h
> index c0c7adc..833ce2c 100644
> --- a/arch/powerpc/include/asm/epapr_hcalls.h
> +++ b/arch/powerpc/include/asm/epapr_hcalls.h
> @@ -50,10 +50,6 @@
> #ifndef _EPAPR_HCALLS_H
> #define _EPAPR_HCALLS_H
>
> -#include <linux/types.h>
> -#include <linux/errno.h>
> -#include <asm/byteorder.h>
> -
> #define EV_BYTE_CHANNEL_SEND 1
> #define EV_BYTE_CHANNEL_RECEIVE 2
> #define EV_BYTE_CHANNEL_POLL 3
> @@ -109,6 +105,11 @@
> #define EV_UNIMPLEMENTED 12 /* Unimplemented hypercall */
> #define EV_BUFFER_OVERFLOW 13 /* Caller-supplied buffer too small */
>
> +#ifndef __ASSEMBLY__
> +#include <linux/types.h>
> +#include <linux/errno.h>
> +#include <asm/byteorder.h>
> +
> /*
> * Hypercall register clobber list
> *
> @@ -506,5 +507,5 @@ static inline unsigned int ev_idle(void)
>
> return r3;
> }
> -
> +#endif /* !__ASSEMBLY__ */
> #endif
> diff --git a/arch/powerpc/kernel/epapr_hcalls.S b/arch/powerpc/kernel/epapr_hcalls.S
> index 697b390..eb19377 100644
> --- a/arch/powerpc/kernel/epapr_hcalls.S
> +++ b/arch/powerpc/kernel/epapr_hcalls.S
> @@ -8,13 +8,45 @@
> */
>
> #include <linux/threads.h>
> +#include <asm/epapr_hcalls.h>
> #include <asm/reg.h>
> #include <asm/page.h>
> #include <asm/cputable.h>
> #include <asm/thread_info.h>
> #include <asm/ppc_asm.h>
> +#include <asm/asm-compat.h>
> #include <asm/asm-offsets.h>
>
> +/* epapr_ev_idle() was derived from e500_idle() */
> +_GLOBAL(epapr_ev_idle)
> +#ifndef CONFIG_PPC64
> + rlwinm r3, r1, 0, 0, 31-THREAD_SHIFT /* current thread_info */
> +#else
> + clrrdi r3, r1, THREAD_SHIFT
> +#endif
Ben, would you be opposed to a macro that does this? Open-coding subtile details like this always makes me wary we could screw them up :)
Alex
^ permalink raw reply [flat|nested] 8+ messages in thread
* Re: [PATCH v11 5/8] KVM: PPC: ev_idle hcall support for e500 guests
@ 2012-07-02 12:20 ` Alexander Graf
0 siblings, 0 replies; 8+ messages in thread
From: Alexander Graf @ 2012-07-02 12:20 UTC (permalink / raw)
To: Stuart Yoder; +Cc: kvm-ppc, KVM list, Benjamin Herrenschmidt
On 22.06.2012, at 22:04, Stuart Yoder wrote:
> From: Liu Yu-B13201 <Yu.Liu@freescale.com>
>
> Signed-off-by: Liu Yu <yu.liu@freescale.com>
> [varun: 64-bit changes]
> Signed-off-by: Varun Sethi <Varun.Sethi@freescale.com>
> Signed-off-by: Stuart Yoder <stuart.yoder@freescale.com>
> ---
> -v11:
> -added comment about origin of idle instruction sequence
> -update for 64-bit support found in testing
>
> arch/powerpc/include/asm/epapr_hcalls.h | 11 +++++----
> arch/powerpc/kernel/epapr_hcalls.S | 32 +++++++++++++++++++++++++++++++
> arch/powerpc/kernel/epapr_paravirt.c | 11 +++++++++-
> 3 files changed, 48 insertions(+), 6 deletions(-)
>
> diff --git a/arch/powerpc/include/asm/epapr_hcalls.h b/arch/powerpc/include/asm/epapr_hcalls.h
> index c0c7adc..833ce2c 100644
> --- a/arch/powerpc/include/asm/epapr_hcalls.h
> +++ b/arch/powerpc/include/asm/epapr_hcalls.h
> @@ -50,10 +50,6 @@
> #ifndef _EPAPR_HCALLS_H
> #define _EPAPR_HCALLS_H
>
> -#include <linux/types.h>
> -#include <linux/errno.h>
> -#include <asm/byteorder.h>
> -
> #define EV_BYTE_CHANNEL_SEND 1
> #define EV_BYTE_CHANNEL_RECEIVE 2
> #define EV_BYTE_CHANNEL_POLL 3
> @@ -109,6 +105,11 @@
> #define EV_UNIMPLEMENTED 12 /* Unimplemented hypercall */
> #define EV_BUFFER_OVERFLOW 13 /* Caller-supplied buffer too small */
>
> +#ifndef __ASSEMBLY__
> +#include <linux/types.h>
> +#include <linux/errno.h>
> +#include <asm/byteorder.h>
> +
> /*
> * Hypercall register clobber list
> *
> @@ -506,5 +507,5 @@ static inline unsigned int ev_idle(void)
>
> return r3;
> }
> -
> +#endif /* !__ASSEMBLY__ */
> #endif
> diff --git a/arch/powerpc/kernel/epapr_hcalls.S b/arch/powerpc/kernel/epapr_hcalls.S
> index 697b390..eb19377 100644
> --- a/arch/powerpc/kernel/epapr_hcalls.S
> +++ b/arch/powerpc/kernel/epapr_hcalls.S
> @@ -8,13 +8,45 @@
> */
>
> #include <linux/threads.h>
> +#include <asm/epapr_hcalls.h>
> #include <asm/reg.h>
> #include <asm/page.h>
> #include <asm/cputable.h>
> #include <asm/thread_info.h>
> #include <asm/ppc_asm.h>
> +#include <asm/asm-compat.h>
> #include <asm/asm-offsets.h>
>
> +/* epapr_ev_idle() was derived from e500_idle() */
> +_GLOBAL(epapr_ev_idle)
> +#ifndef CONFIG_PPC64
> + rlwinm r3, r1, 0, 0, 31-THREAD_SHIFT /* current thread_info */
> +#else
> + clrrdi r3, r1, THREAD_SHIFT
> +#endif
Ben, would you be opposed to a macro that does this? Open-coding subtile details like this always makes me wary we could screw them up :)
Alex
^ permalink raw reply [flat|nested] 8+ messages in thread
* Re: [PATCH v11 5/8] KVM: PPC: ev_idle hcall support for e500 guests
2012-07-02 12:20 ` Alexander Graf
@ 2012-07-02 13:24 ` Benjamin Herrenschmidt
-1 siblings, 0 replies; 8+ messages in thread
From: Benjamin Herrenschmidt @ 2012-07-02 13:24 UTC (permalink / raw)
To: Alexander Graf; +Cc: Stuart Yoder, kvm-ppc, KVM list
On Mon, 2012-07-02 at 14:20 +0200, Alexander Graf wrote:
>
> Ben, would you be opposed to a macro that does this? Open-coding
> subtile details like this always makes me wary we could screw them
> up :)
That's definitely material for a macro (and fixup the gazillion places
where we do it by hand already :-)
Cheers,
Ben.
^ permalink raw reply [flat|nested] 8+ messages in thread
* Re: [PATCH v11 5/8] KVM: PPC: ev_idle hcall support for e500 guests
@ 2012-07-02 13:24 ` Benjamin Herrenschmidt
0 siblings, 0 replies; 8+ messages in thread
From: Benjamin Herrenschmidt @ 2012-07-02 13:24 UTC (permalink / raw)
To: Alexander Graf; +Cc: Stuart Yoder, kvm-ppc, KVM list
On Mon, 2012-07-02 at 14:20 +0200, Alexander Graf wrote:
>
> Ben, would you be opposed to a macro that does this? Open-coding
> subtile details like this always makes me wary we could screw them
> up :)
That's definitely material for a macro (and fixup the gazillion places
where we do it by hand already :-)
Cheers,
Ben.
^ permalink raw reply [flat|nested] 8+ messages in thread
* Re: [PATCH v11 5/8] KVM: PPC: ev_idle hcall support for e500 guests
2012-07-02 13:24 ` Benjamin Herrenschmidt
@ 2012-07-02 13:40 ` Alexander Graf
-1 siblings, 0 replies; 8+ messages in thread
From: Alexander Graf @ 2012-07-02 13:40 UTC (permalink / raw)
To: Benjamin Herrenschmidt; +Cc: Stuart Yoder, kvm-ppc, KVM list
On 02.07.2012, at 15:24, Benjamin Herrenschmidt wrote:
> On Mon, 2012-07-02 at 14:20 +0200, Alexander Graf wrote:
>>
>> Ben, would you be opposed to a macro that does this? Open-coding
>> subtile details like this always makes me wary we could screw them
>> up :)
>
> That's definitely material for a macro (and fixup the gazillion places
> where we do it by hand already :-)
Just like I thought.
Stuart, want to take this on you? It'd be mostly a simple search+replace of the pattern in question with a macro GET_THREAD_INFO(r3, r1) that does the same thing as the code we have today, but makes it easier to read.
Alex
^ permalink raw reply [flat|nested] 8+ messages in thread
* Re: [PATCH v11 5/8] KVM: PPC: ev_idle hcall support for e500 guests
@ 2012-07-02 13:40 ` Alexander Graf
0 siblings, 0 replies; 8+ messages in thread
From: Alexander Graf @ 2012-07-02 13:40 UTC (permalink / raw)
To: Benjamin Herrenschmidt; +Cc: Stuart Yoder, kvm-ppc, KVM list
On 02.07.2012, at 15:24, Benjamin Herrenschmidt wrote:
> On Mon, 2012-07-02 at 14:20 +0200, Alexander Graf wrote:
>>
>> Ben, would you be opposed to a macro that does this? Open-coding
>> subtile details like this always makes me wary we could screw them
>> up :)
>
> That's definitely material for a macro (and fixup the gazillion places
> where we do it by hand already :-)
Just like I thought.
Stuart, want to take this on you? It'd be mostly a simple search+replace of the pattern in question with a macro GET_THREAD_INFO(r3, r1) that does the same thing as the code we have today, but makes it easier to read.
Alex
^ permalink raw reply [flat|nested] 8+ messages in thread
end of thread, other threads:[~2012-07-02 13:40 UTC | newest]
Thread overview: 8+ messages (download: mbox.gz follow: Atom feed
-- links below jump to the message on this page --
2012-06-22 20:04 [PATCH v11 5/8] KVM: PPC: ev_idle hcall support for e500 guests Stuart Yoder
2012-06-22 20:04 ` Stuart Yoder
2012-07-02 12:20 ` Alexander Graf
2012-07-02 12:20 ` Alexander Graf
2012-07-02 13:24 ` Benjamin Herrenschmidt
2012-07-02 13:24 ` Benjamin Herrenschmidt
2012-07-02 13:40 ` Alexander Graf
2012-07-02 13:40 ` Alexander Graf
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.