All of lore.kernel.org
 help / color / mirror / Atom feed
From: Michael Ellerman <michael@ellerman.id.au>
To: Tom Musta <tommusta@gmail.com>
Cc: linux-kernel@vger.kernel.org,
	Stephane Eranian <eranian@google.com>,
	linuxppc-dev@ozlabs.org, Paul Mackerras <paulus@samba.org>,
	Arnaldo Carvalho de Melo <acme@ghostprotocols.net>,
	Sukadev Bhattiprolu <sukadev@linux.vnet.ibm.com>,
	Anshuman Khandual <khandual@linux.vnet.ibm.com>
Subject: Re: [PATCH 5/9][v5] powerpc: implement is_instr_load_store().
Date: Tue, 08 Oct 2013 14:28:55 +1100	[thread overview]
Message-ID: <1381202935.25887.4.camel@concordia> (raw)
In-Reply-To: <524DCAE6.5090601@gmail.com>

On Thu, 2013-10-03 at 14:52 -0500, Tom Musta wrote:
> On 10/3/2013 2:03 PM, Sukadev Bhattiprolu wrote:
> > Michael Ellerman [michael@ellerman.id.au] wrote:
> <snip>
> > |
> > |         if (lower == 6)
> > |             if (upper <= 1)
> > |                 return true;
> > |             return false;
> > v

> Note that this case covers the lvsl/lvsr instructions, which, despite their
> names are not actually loads.  So you could eliminate this check and do
> just a little bit better.

Yes you're right Tom, thanks for checking.

I saw "Load" in the name and that was good enough for me :)

cheers

WARNING: multiple messages have this Message-ID (diff)
From: Michael Ellerman <michael@ellerman.id.au>
To: Tom Musta <tommusta@gmail.com>
Cc: Sukadev Bhattiprolu <sukadev@linux.vnet.ibm.com>,
	linux-kernel@vger.kernel.org,
	Stephane Eranian <eranian@google.com>,
	linuxppc-dev@ozlabs.org, Paul Mackerras <paulus@samba.org>,
	Arnaldo Carvalho de Melo <acme@ghostprotocols.net>,
	Anshuman Khandual <khandual@linux.vnet.ibm.com>
Subject: Re: [PATCH 5/9][v5] powerpc: implement is_instr_load_store().
Date: Tue, 08 Oct 2013 14:28:55 +1100	[thread overview]
Message-ID: <1381202935.25887.4.camel@concordia> (raw)
In-Reply-To: <524DCAE6.5090601@gmail.com>

On Thu, 2013-10-03 at 14:52 -0500, Tom Musta wrote:
> On 10/3/2013 2:03 PM, Sukadev Bhattiprolu wrote:
> > Michael Ellerman [michael@ellerman.id.au] wrote:
> <snip>
> > |
> > |         if (lower == 6)
> > |             if (upper <= 1)
> > |                 return true;
> > |             return false;
> > v

> Note that this case covers the lvsl/lvsr instructions, which, despite their
> names are not actually loads.  So you could eliminate this check and do
> just a little bit better.

Yes you're right Tom, thanks for checking.

I saw "Load" in the name and that was good enough for me :)

cheers




  reply	other threads:[~2013-10-08  3:28 UTC|newest]

Thread overview: 51+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2013-10-02  0:15 Sukadev Bhattiprolu
2013-10-02  0:15 ` Sukadev Bhattiprolu
2013-10-02  0:15 ` [PATCH 1/9][v5] powerpc/perf: Rename Power8 macros to start with PME Sukadev Bhattiprolu
2013-10-02  0:15   ` Sukadev Bhattiprolu
2013-10-03  4:02   ` Michael Ellerman
2013-10-03  4:02     ` Michael Ellerman
2013-10-02  0:15 ` [PATCH 2/9][v5] powerpc/perf: Export Power8 generic events in sysfs Sukadev Bhattiprolu
2013-10-02  0:15   ` Sukadev Bhattiprolu
2013-10-03  4:04   ` Michael Ellerman
2013-10-03  4:04     ` Michael Ellerman
2013-10-03 17:57     ` Sukadev Bhattiprolu
2013-10-03 17:57       ` Sukadev Bhattiprolu
2013-10-08  3:58       ` Michael Ellerman
2013-10-08  3:58         ` Michael Ellerman
2013-10-02  0:15 ` [PATCH 3/9][v5] powerpc/perf: Add Power8 event PM_MRK_GRP_CMPL to sysfs Sukadev Bhattiprolu
2013-10-02  0:15   ` Sukadev Bhattiprolu
2013-10-02  0:15 ` [PATCH 4/9][v5] powerpc: Rename branch_opcode() to instr_opcode() Sukadev Bhattiprolu
2013-10-02  0:15   ` Sukadev Bhattiprolu
2013-10-02  0:15 ` [PATCH 5/9][v5] powerpc: implement is_instr_load_store() Sukadev Bhattiprolu
2013-10-02  0:15   ` Sukadev Bhattiprolu
2013-10-03  5:35   ` Michael Ellerman
2013-10-03  5:35     ` Michael Ellerman
2013-10-03 19:03     ` Sukadev Bhattiprolu
2013-10-03 19:03       ` Sukadev Bhattiprolu
2013-10-03 19:52       ` Tom Musta
2013-10-03 19:52         ` Tom Musta
2013-10-08  3:28         ` Michael Ellerman [this message]
2013-10-08  3:28           ` Michael Ellerman
2013-10-08  4:00       ` Michael Ellerman
2013-10-08  4:00         ` Michael Ellerman
2013-10-08 19:31     ` Sukadev Bhattiprolu
2013-10-08 19:31       ` Sukadev Bhattiprolu
2013-10-09  1:03       ` Michael Ellerman
2013-10-09  1:03         ` Michael Ellerman
2013-10-09  1:27         ` Michael Ellerman
2013-10-02  0:15 ` [PATCH 6/9][v5] powerpc/perf: Define big-endian version of perf_mem_data_src Sukadev Bhattiprolu
2013-10-02  0:15   ` Sukadev Bhattiprolu
2013-10-03  5:39   ` Michael Ellerman
2013-10-03  5:39     ` Michael Ellerman
2013-10-03  6:20     ` Sukadev Bhattiprolu
2013-10-03  6:20       ` Sukadev Bhattiprolu
2013-10-03 15:27     ` Sukadev Bhattiprolu
2013-10-03 15:27       ` Sukadev Bhattiprolu
2013-10-05  3:53     ` Sukadev Bhattiprolu
2013-10-05  3:53       ` Sukadev Bhattiprolu
2013-10-02  0:15 ` [PATCH 7/9][v5] powerpc/perf: Export Power8 memory hierarchy info to user space Sukadev Bhattiprolu
2013-10-02  0:15   ` Sukadev Bhattiprolu
2013-10-02  0:15 ` [PATCH 8/9][v5] powerpc/perf: Export Power7 " Sukadev Bhattiprolu
2013-10-02  0:15   ` Sukadev Bhattiprolu
2013-10-02  0:15 ` [PATCH 9/9][v5] powerpc/perf: Update perf-mem man page for Power Sukadev Bhattiprolu
2013-10-02  0:15   ` Sukadev Bhattiprolu

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=1381202935.25887.4.camel@concordia \
    --to=michael@ellerman.id.au \
    --cc=acme@ghostprotocols.net \
    --cc=eranian@google.com \
    --cc=khandual@linux.vnet.ibm.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linuxppc-dev@ozlabs.org \
    --cc=paulus@samba.org \
    --cc=sukadev@linux.vnet.ibm.com \
    --cc=tommusta@gmail.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.