All of lore.kernel.org
 help / color / mirror / Atom feed
From: Jerry-ch Chen <Jerry-ch.Chen@mediatek.com>
To: Tomasz Figa <tfiga@chromium.org>
Cc: "devicetree@vger.kernel.org" <devicetree@vger.kernel.org>,
	"Sean Cheng (鄭昇弘)" <Sean.Cheng@mediatek.com>,
	"laurent.pinchart+renesas@ideasonboard.com"
	<laurent.pinchart+renesas@ideasonboard.com>,
	"zwisler@chromium.org" <zwisler@chromium.org>,
	srv_heupstream <srv_heupstream@mediatek.com>,
	"Christie Yu (游雅惠)" <christie.yu@mediatek.com>,
	jerry-ch.chen@mediatek.com, HansVerkuil <hverkuil@xs4all.nl>,
	"Jungo Lin (林明俊)" <jungo.lin@mediatek.com>,
	"Sj Huang (黃信璋)" <sj.huang@mediatek.com>,
	"yuzhao@chromium.org" <yuzhao@chromium.org>,
	"hans.verkuil@cisco.com" <hans.verkuil@cisco.com>,
	"pihsun@chromium.org" <pihsun@chromium.org>,
	"Frederic Chen (陳俊元)" <Frederic.Chen@mediatek.com>,
	"matthias.bgg@gmail.com" <matthias.bgg@gmail.com>,
	"linux-mediatek@lists.infradead.org"
	<linux-mediatek@lists.infradead.org>,
	"mchehab@kernel.org" <mchehab@kernel.org>,
	"linux-arm-kernel@lists.infradead.org"
	<linux-arm-kernel@lists.infradead.org>,
	"linux-media@vger.kernel.org" <linux-media@vger.kernel.org>
Subject: Re: [RFC PATCH V4 0/4] media: platform: Add support for Face Detection (FD) on mt8183 SoC
Date: Tue, 30 Jun 2020 22:10:53 +0800	[thread overview]
Message-ID: <1593526253.29676.28.camel@mtksdccf07> (raw)
In-Reply-To: <20200521183825.GB249683@chromium.org>

Hi Tomasz,

On Thu, 2020-05-21 at 18:38 +0000, Tomasz Figa wrote:
> Hi Jerry,
> 
> On Wed, May 13, 2020 at 11:45:37PM +0200, Tomasz Figa wrote:
> > Hi Jerry,
> > 
> > On Fri, May 8, 2020 at 4:03 AM Jerry-ch Chen <Jerry-ch.Chen@mediatek.com> wrote:
> > >
> > > Hi Laurent, Tomasz, Matthias,
> > >
> > > gentle ping for this patch set,
> > > If no new comments, I would like to send a newer version.
> > >
> > 
> > Sorry, I still haven't had a chance to look at the series, so feel
> > free to send a new version and I will take a look at the new one.
> > 
> 
> Finally found some time to review the series. Again sorry for the delay
> and thanks for your patience.
> 
> Some general comments:
> 1) The metadata format FourCC should be added in a separate patch,
> together with documentation for it.
> 2) Control IDs, structs used by the userspace, etc. should be defined in
> a header under include/uapi/linux.
> 
> Please also check my replies to particular patches for further comments.
> 
> Best regards,
> Tomasz

Appreciate for your reply,

So far, I've locally created an uapi header:
include/uapi/linux/mtk_fd_40.h
which provides some values, control ids, and the definitions of
structures that would be needed by user of mtk_fd_40 driver.
In addition, I also provide a MACRO as example in comments that can
extract the struct member with bit length and offset
definitions(eliminate the bit-fields).

Also, I would like to rename struct fd_user_output with struct
mtk_fd_hw_result. I worry fd_user_output would be a confusing name.
I will add them in a separate patch in next version.

I am still working on the documentation, which might be
Documentation/media/uapi/v4l/pixfmt-meta-mtk-fd-40.rst.
Refering the other pixfmt-*.rst files, I will try to provide the
flat-table of the metadata with the structure of the mtk_fd_hw_result.

I am confusing that should I remain the name with -40 in the tail of rst
file?
Since I think the layout of metadata might be different in the future
mtk fd drivers. Maybe they create a new one or should they update the
rst file when they are upstreaming?

Other comments are almost fixed, I will inform you by this mail thread
as soon as I finish the documentation of fd metadata format.

Sorry for the late response,
Thanks and Best Regards,
Jerry
_______________________________________________
Linux-mediatek mailing list
Linux-mediatek@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/linux-mediatek

WARNING: multiple messages have this Message-ID (diff)
From: Jerry-ch Chen <Jerry-ch.Chen@mediatek.com>
To: Tomasz Figa <tfiga@chromium.org>
Cc: "devicetree@vger.kernel.org" <devicetree@vger.kernel.org>,
	"Sean Cheng (鄭昇弘)" <Sean.Cheng@mediatek.com>,
	"laurent.pinchart+renesas@ideasonboard.com"
	<laurent.pinchart+renesas@ideasonboard.com>,
	"zwisler@chromium.org" <zwisler@chromium.org>,
	srv_heupstream <srv_heupstream@mediatek.com>,
	"Christie Yu (游雅惠)" <christie.yu@mediatek.com>,
	jerry-ch.chen@mediatek.com, HansVerkuil <hverkuil@xs4all.nl>,
	"Jungo Lin (林明俊)" <jungo.lin@mediatek.com>,
	"Sj Huang (黃信璋)" <sj.huang@mediatek.com>,
	"yuzhao@chromium.org" <yuzhao@chromium.org>,
	"hans.verkuil@cisco.com" <hans.verkuil@cisco.com>,
	"pihsun@chromium.org" <pihsun@chromium.org>,
	"Frederic Chen (陳俊元)" <Frederic.Chen@mediatek.com>,
	"matthias.bgg@gmail.com" <matthias.bgg@gmail.com>,
	"linux-mediatek@lists.infradead.org"
	<linux-mediatek@lists.infradead.org>,
	"mchehab@kernel.org" <mchehab@kernel.org>,
	"linux-arm-kernel@lists.infradead.org"
	<linux-arm-kernel@lists.infradead.org>,
	"linux-media@vger.kernel.org" <linux-media@vger.kernel.org>
Subject: Re: [RFC PATCH V4 0/4] media: platform: Add support for Face Detection (FD) on mt8183 SoC
Date: Tue, 30 Jun 2020 22:10:53 +0800	[thread overview]
Message-ID: <1593526253.29676.28.camel@mtksdccf07> (raw)
In-Reply-To: <20200521183825.GB249683@chromium.org>

Hi Tomasz,

On Thu, 2020-05-21 at 18:38 +0000, Tomasz Figa wrote:
> Hi Jerry,
> 
> On Wed, May 13, 2020 at 11:45:37PM +0200, Tomasz Figa wrote:
> > Hi Jerry,
> > 
> > On Fri, May 8, 2020 at 4:03 AM Jerry-ch Chen <Jerry-ch.Chen@mediatek.com> wrote:
> > >
> > > Hi Laurent, Tomasz, Matthias,
> > >
> > > gentle ping for this patch set,
> > > If no new comments, I would like to send a newer version.
> > >
> > 
> > Sorry, I still haven't had a chance to look at the series, so feel
> > free to send a new version and I will take a look at the new one.
> > 
> 
> Finally found some time to review the series. Again sorry for the delay
> and thanks for your patience.
> 
> Some general comments:
> 1) The metadata format FourCC should be added in a separate patch,
> together with documentation for it.
> 2) Control IDs, structs used by the userspace, etc. should be defined in
> a header under include/uapi/linux.
> 
> Please also check my replies to particular patches for further comments.
> 
> Best regards,
> Tomasz

Appreciate for your reply,

So far, I've locally created an uapi header:
include/uapi/linux/mtk_fd_40.h
which provides some values, control ids, and the definitions of
structures that would be needed by user of mtk_fd_40 driver.
In addition, I also provide a MACRO as example in comments that can
extract the struct member with bit length and offset
definitions(eliminate the bit-fields).

Also, I would like to rename struct fd_user_output with struct
mtk_fd_hw_result. I worry fd_user_output would be a confusing name.
I will add them in a separate patch in next version.

I am still working on the documentation, which might be
Documentation/media/uapi/v4l/pixfmt-meta-mtk-fd-40.rst.
Refering the other pixfmt-*.rst files, I will try to provide the
flat-table of the metadata with the structure of the mtk_fd_hw_result.

I am confusing that should I remain the name with -40 in the tail of rst
file?
Since I think the layout of metadata might be different in the future
mtk fd drivers. Maybe they create a new one or should they update the
rst file when they are upstreaming?

Other comments are almost fixed, I will inform you by this mail thread
as soon as I finish the documentation of fd metadata format.

Sorry for the late response,
Thanks and Best Regards,
Jerry
_______________________________________________
linux-arm-kernel mailing list
linux-arm-kernel@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/linux-arm-kernel

WARNING: multiple messages have this Message-ID (diff)
From: Jerry-ch Chen <Jerry-ch.Chen@mediatek.com>
To: Tomasz Figa <tfiga@chromium.org>
Cc: "hans.verkuil@cisco.com" <hans.verkuil@cisco.com>,
	HansVerkuil <hverkuil@xs4all.nl>,
	"laurent.pinchart+renesas@ideasonboard.com"
	<laurent.pinchart+renesas@ideasonboard.com>,
	"matthias.bgg@gmail.com" <matthias.bgg@gmail.com>,
	"mchehab@kernel.org" <mchehab@kernel.org>,
	"pihsun@chromium.org" <pihsun@chromium.org>,
	"yuzhao@chromium.org" <yuzhao@chromium.org>,
	"zwisler@chromium.org" <zwisler@chromium.org>,
	"linux-mediatek@lists.infradead.org"
	<linux-mediatek@lists.infradead.org>,
	"linux-arm-kernel@lists.infradead.org"
	<linux-arm-kernel@lists.infradead.org>,
	"Sean Cheng (鄭昇弘)" <Sean.Cheng@mediatek.com>,
	"Sj Huang (黃信璋)" <sj.huang@mediatek.com>,
	"Christie Yu (游雅惠)" <christie.yu@mediatek.com>,
	"Frederic Chen (陳俊元)" <Frederic.Chen@mediatek.com>,
	"Jungo Lin (林明俊)" <jungo.lin@mediatek.com>,
	"linux-media@vger.kernel.org" <linux-media@vger.kernel.org>,
	srv_heupstream <srv_heupstream@mediatek.com>,
	"devicetree@vger.kernel.org" <devicetree@vger.kernel.org>,
	jerry-ch.chen@mediatek.com
Subject: Re: [RFC PATCH V4 0/4] media: platform: Add support for Face Detection (FD) on mt8183 SoC
Date: Tue, 30 Jun 2020 22:10:53 +0800	[thread overview]
Message-ID: <1593526253.29676.28.camel@mtksdccf07> (raw)
In-Reply-To: <20200521183825.GB249683@chromium.org>

Hi Tomasz,

On Thu, 2020-05-21 at 18:38 +0000, Tomasz Figa wrote:
> Hi Jerry,
> 
> On Wed, May 13, 2020 at 11:45:37PM +0200, Tomasz Figa wrote:
> > Hi Jerry,
> > 
> > On Fri, May 8, 2020 at 4:03 AM Jerry-ch Chen <Jerry-ch.Chen@mediatek.com> wrote:
> > >
> > > Hi Laurent, Tomasz, Matthias,
> > >
> > > gentle ping for this patch set,
> > > If no new comments, I would like to send a newer version.
> > >
> > 
> > Sorry, I still haven't had a chance to look at the series, so feel
> > free to send a new version and I will take a look at the new one.
> > 
> 
> Finally found some time to review the series. Again sorry for the delay
> and thanks for your patience.
> 
> Some general comments:
> 1) The metadata format FourCC should be added in a separate patch,
> together with documentation for it.
> 2) Control IDs, structs used by the userspace, etc. should be defined in
> a header under include/uapi/linux.
> 
> Please also check my replies to particular patches for further comments.
> 
> Best regards,
> Tomasz

Appreciate for your reply,

So far, I've locally created an uapi header:
include/uapi/linux/mtk_fd_40.h
which provides some values, control ids, and the definitions of
structures that would be needed by user of mtk_fd_40 driver.
In addition, I also provide a MACRO as example in comments that can
extract the struct member with bit length and offset
definitions(eliminate the bit-fields).

Also, I would like to rename struct fd_user_output with struct
mtk_fd_hw_result. I worry fd_user_output would be a confusing name.
I will add them in a separate patch in next version.

I am still working on the documentation, which might be
Documentation/media/uapi/v4l/pixfmt-meta-mtk-fd-40.rst.
Refering the other pixfmt-*.rst files, I will try to provide the
flat-table of the metadata with the structure of the mtk_fd_hw_result.

I am confusing that should I remain the name with -40 in the tail of rst
file?
Since I think the layout of metadata might be different in the future
mtk fd drivers. Maybe they create a new one or should they update the
rst file when they are upstreaming?

Other comments are almost fixed, I will inform you by this mail thread
as soon as I finish the documentation of fd metadata format.

Sorry for the late response,
Thanks and Best Regards,
Jerry

  reply	other threads:[~2020-06-30 14:21 UTC|newest]

Thread overview: 96+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2019-12-04 12:47 [RFC PATCH V4 0/4] media: platform: Add support for Face Detection (FD) on mt8183 SoC Jerry-ch Chen
2019-12-04 12:47 ` Jerry-ch Chen
2019-12-04 12:47 ` Jerry-ch Chen
2019-12-04 12:47 ` [RFC PATCH V4 1/4] media: v4l2-mem2mem: add v4l2_m2m_suspend, v4l2_m2m_resume Jerry-ch Chen
2019-12-04 12:47   ` Jerry-ch Chen
2019-12-04 12:47   ` Jerry-ch Chen
2020-05-21 17:11   ` Tomasz Figa
2020-05-21 17:11     ` Tomasz Figa
2020-05-21 17:11     ` Tomasz Figa
2020-05-22  6:01     ` Jerry-ch Chen
2020-05-22  6:01       ` Jerry-ch Chen
2020-05-22  6:01       ` Jerry-ch Chen
2020-06-10 10:28     ` Hans Verkuil
2020-06-10 10:28       ` Hans Verkuil
2020-06-10 10:28       ` Hans Verkuil
2020-06-10 10:32       ` Tomasz Figa
2020-06-10 10:32         ` Tomasz Figa
2020-06-10 10:32         ` Tomasz Figa
2020-06-10 18:52         ` Ezequiel Garcia
2020-06-10 18:52           ` Ezequiel Garcia
2020-06-10 18:52           ` Ezequiel Garcia
2020-06-10 19:03           ` Tomasz Figa
2020-06-10 19:03             ` Tomasz Figa
2020-06-10 19:03             ` Tomasz Figa
2020-06-10 19:14             ` Ezequiel Garcia
2020-06-10 19:14               ` Ezequiel Garcia
2020-06-10 19:14               ` Ezequiel Garcia
2020-06-10 19:26               ` Tomasz Figa
2020-06-10 19:26                 ` Tomasz Figa
2020-06-10 19:26                 ` Tomasz Figa
2020-06-14 22:43                 ` Ezequiel Garcia
2020-06-14 22:43                   ` Ezequiel Garcia
2020-06-14 22:43                   ` Ezequiel Garcia
2019-12-04 12:47 ` [RFC PATCH V4 2/4] dt-bindings: mt8183: Added FD dt-bindings Jerry-ch Chen
2019-12-04 12:47   ` Jerry-ch Chen
2019-12-04 12:47   ` Jerry-ch Chen
2019-12-04 18:58   ` Rob Herring
2019-12-04 18:58     ` Rob Herring
2019-12-04 18:58     ` Rob Herring
2020-05-06  8:41     ` Jerry-ch Chen
2020-05-06  8:41       ` Jerry-ch Chen
2020-05-06  8:41       ` Jerry-ch Chen
2019-12-04 12:47 ` [RFC PATCH V4 3/4] dts: arm64: mt8183: Add FD nodes Jerry-ch Chen
2019-12-04 12:47   ` Jerry-ch Chen
2019-12-04 12:47   ` Jerry-ch Chen
2019-12-04 12:47 ` [RFC PATCH V4 4/4] platform: mtk-isp: Add Mediatek FD driver Jerry-ch Chen
2019-12-04 12:47   ` Jerry-ch Chen
2019-12-04 12:47   ` Jerry-ch Chen
2020-05-21 18:28   ` Tomasz Figa
2020-05-21 18:28     ` Tomasz Figa
2020-05-21 18:28     ` Tomasz Figa
2020-05-22 14:10     ` Jerry-ch Chen
2020-05-22 14:10       ` Jerry-ch Chen
2020-05-22 14:10       ` Jerry-ch Chen
2020-05-25 12:24       ` Tomasz Figa
2020-05-25 12:24         ` Tomasz Figa
2020-05-25 12:24         ` Tomasz Figa
2020-05-29 12:26         ` Jerry-ch Chen
2020-05-29 12:26           ` Jerry-ch Chen
2020-05-29 12:26           ` Jerry-ch Chen
2020-05-29 12:59           ` Tomasz Figa
2020-05-29 12:59             ` Tomasz Figa
2020-05-29 12:59             ` Tomasz Figa
2020-06-01 10:37             ` Jerry-ch Chen
2020-06-01 10:37               ` Jerry-ch Chen
2020-06-01 10:37               ` Jerry-ch Chen
2020-05-08  2:02 ` [RFC PATCH V4 0/4] media: platform: Add support for Face Detection (FD) on mt8183 SoC Jerry-ch Chen
2020-05-08  2:02   ` Jerry-ch Chen
2020-05-08  2:02   ` Jerry-ch Chen
2020-05-13 21:45   ` Tomasz Figa
2020-05-13 21:45     ` Tomasz Figa
2020-05-13 21:45     ` Tomasz Figa
2020-05-21 18:38     ` Tomasz Figa
2020-05-21 18:38       ` Tomasz Figa
2020-05-21 18:38       ` Tomasz Figa
2020-06-30 14:10       ` Jerry-ch Chen [this message]
2020-06-30 14:10         ` Jerry-ch Chen
2020-06-30 14:10         ` Jerry-ch Chen
2020-06-30 17:19         ` Tomasz Figa
2020-06-30 17:19           ` Tomasz Figa
2020-06-30 17:19           ` Tomasz Figa
2020-11-11 11:51           ` Jerry-ch Chen
2020-11-11 11:51             ` Jerry-ch Chen
2020-11-11 11:51             ` Jerry-ch Chen
2020-11-12  4:26             ` Tomasz Figa
2020-11-12  4:26               ` Tomasz Figa
2020-11-12  4:26               ` Tomasz Figa
2020-11-12 12:05               ` Jerry-ch Chen
2020-11-12 12:05                 ` Jerry-ch Chen
2020-11-12 12:05                 ` Jerry-ch Chen
2020-12-28 17:02                 ` Jerry-ch Chen
2020-12-28 17:02                   ` Jerry-ch Chen
2020-12-28 17:02                   ` Jerry-ch Chen
2021-01-06  6:30                   ` Tomasz Figa
2021-01-06  6:30                     ` Tomasz Figa
2021-01-06  6:30                     ` Tomasz Figa

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=1593526253.29676.28.camel@mtksdccf07 \
    --to=jerry-ch.chen@mediatek.com \
    --cc=Frederic.Chen@mediatek.com \
    --cc=Sean.Cheng@mediatek.com \
    --cc=christie.yu@mediatek.com \
    --cc=devicetree@vger.kernel.org \
    --cc=hans.verkuil@cisco.com \
    --cc=hverkuil@xs4all.nl \
    --cc=jungo.lin@mediatek.com \
    --cc=laurent.pinchart+renesas@ideasonboard.com \
    --cc=linux-arm-kernel@lists.infradead.org \
    --cc=linux-media@vger.kernel.org \
    --cc=linux-mediatek@lists.infradead.org \
    --cc=matthias.bgg@gmail.com \
    --cc=mchehab@kernel.org \
    --cc=pihsun@chromium.org \
    --cc=sj.huang@mediatek.com \
    --cc=srv_heupstream@mediatek.com \
    --cc=tfiga@chromium.org \
    --cc=yuzhao@chromium.org \
    --cc=zwisler@chromium.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.