From: patchwork-bot+netdevbpf@kernel.org
To: Arun Ramadoss <arun.ramadoss@microchip.com>
Cc: linux-kernel@vger.kernel.org, netdev@vger.kernel.org,
woojung.huh@microchip.com, UNGLinuxDriver@microchip.com,
andrew@lunn.ch, vivien.didelot@gmail.com, f.fainelli@gmail.com,
olteanv@gmail.com, davem@davemloft.net, edumazet@google.com,
kuba@kernel.org, pabeni@redhat.com, linux@armlinux.org.uk
Subject: Re: [Patch net-next 00/13] net: dsa: microchip: common spi probe for the ksz series switches - part 2
Date: Fri, 24 Jun 2022 10:50:20 +0000 [thread overview]
Message-ID: <165606782011.15655.7360355084913161028.git-patchwork-notify@kernel.org> (raw)
In-Reply-To: <20220622090425.17709-1-arun.ramadoss@microchip.com>
Hello:
This series was applied to netdev/net-next.git (master)
by David S. Miller <davem@davemloft.net>:
On Wed, 22 Jun 2022 14:34:12 +0530 you wrote:
> This patch series aims to refactor the ksz_switch_register routine to have the
> common flow for the ksz series switch. And this is the follow up patch series.
>
> First, it tries moves the common implementation in the setup from individual
> files to ksz_setup. Then implements the common dsa_switch_ops structure instead
> of independent registration. And then moves the ksz_dev_ops to ksz_common.c,
> it allows the dynamic detection of which ksz_dev_ops to be used based on
> the switch detection function.
>
> [...]
Here is the summary with links:
- [net-next,01/13] net: dsa: microchip: rename shutdown to reset in ksz_dev_ops
https://git.kernel.org/netdev/net-next/c/673b196fdd34
- [net-next,02/13] net: dsa: microchip: add config_cpu_port to struct ksz_dev_ops
https://git.kernel.org/netdev/net-next/c/fb9324beb5d4
- [net-next,03/13] net: dsa: microchip: add the enable_stp_addr pointer in ksz_dev_ops
https://git.kernel.org/netdev/net-next/c/331d64f752bb
- [net-next,04/13] net: dsa: microchip: move setup function to ksz_common
https://git.kernel.org/netdev/net-next/c/d2822e686879
- [net-next,05/13] net: dsa: microchip: move broadcast rate limit to ksz_setup
https://git.kernel.org/netdev/net-next/c/1ca6437fafc9
- [net-next,06/13] net: dsa: microchip: move multicast enable to ksz_setup
https://git.kernel.org/netdev/net-next/c/0abab9f3ec6b
- [net-next,07/13] net: dsa: microchip: move start of switch to ksz_setup
https://git.kernel.org/netdev/net-next/c/ad08ac189758
- [net-next,08/13] net: dsa: microchip: common dsa_switch_ops for ksz switches
https://git.kernel.org/netdev/net-next/c/1958eee85f67
- [net-next,09/13] net: dsa: microchip: ksz9477: separate phylink mode from switch register
https://git.kernel.org/netdev/net-next/c/7a8988a17c48
- [net-next,10/13] net: dsa: microchip: common menuconfig for ksz series switch
https://git.kernel.org/netdev/net-next/c/07bca160469b
- [net-next,11/13] net: dsa: microchip: move ksz_dev_ops to ksz_common.c
https://git.kernel.org/netdev/net-next/c/6ec23aaaac43
- [net-next,12/13] net: dsa: microchip: remove the ksz8/ksz9477_switch_register
https://git.kernel.org/netdev/net-next/c/ff3f3a3090d2
- [net-next,13/13] net: dsa: microchip: common ksz_spi_probe for ksz switches
https://git.kernel.org/netdev/net-next/c/4658f2fe8fbc
You are awesome, thank you!
--
Deet-doot-dot, I am a bot.
https://korg.docs.kernel.org/patchwork/pwbot.html
next prev parent reply other threads:[~2022-06-24 10:50 UTC|newest]
Thread overview: 16+ messages / expand[flat|nested] mbox.gz Atom feed top
2022-06-22 9:04 [Patch net-next 00/13] net: dsa: microchip: common spi probe for the ksz series switches - part 2 Arun Ramadoss
2022-06-22 9:04 ` [Patch net-next 01/13] net: dsa: microchip: rename shutdown to reset in ksz_dev_ops Arun Ramadoss
2022-06-22 9:04 ` [Patch net-next 02/13] net: dsa: microchip: add config_cpu_port to struct ksz_dev_ops Arun Ramadoss
2022-06-22 9:04 ` [Patch net-next 03/13] net: dsa: microchip: add the enable_stp_addr pointer in ksz_dev_ops Arun Ramadoss
2022-06-22 9:04 ` [Patch net-next 04/13] net: dsa: microchip: move setup function to ksz_common Arun Ramadoss
2022-06-22 9:04 ` [Patch net-next 05/13] net: dsa: microchip: move broadcast rate limit to ksz_setup Arun Ramadoss
2022-06-22 9:04 ` [Patch net-next 06/13] net: dsa: microchip: move multicast enable " Arun Ramadoss
2022-06-22 9:04 ` [Patch net-next 07/13] net: dsa: microchip: move start of switch " Arun Ramadoss
2022-06-22 9:04 ` [Patch net-next 08/13] net: dsa: microchip: common dsa_switch_ops for ksz switches Arun Ramadoss
2022-06-22 9:04 ` [Patch net-next 09/13] net: dsa: microchip: ksz9477: separate phylink mode from switch register Arun Ramadoss
2022-06-22 9:04 ` [Patch net-next 10/13] net: dsa: microchip: common menuconfig for ksz series switch Arun Ramadoss
2022-06-22 9:04 ` [Patch net-next 11/13] net: dsa: microchip: move ksz_dev_ops to ksz_common.c Arun Ramadoss
2022-06-22 9:04 ` [Patch net-next 12/13] net: dsa: microchip: remove the ksz8/ksz9477_switch_register Arun Ramadoss
2022-06-22 9:04 ` [Patch net-next 13/13] net: dsa: microchip: common ksz_spi_probe for ksz switches Arun Ramadoss
2022-06-24 10:50 ` patchwork-bot+netdevbpf [this message]
2022-06-24 11:23 ` [Patch net-next 00/13] net: dsa: microchip: common spi probe for the ksz series switches - part 2 Vladimir Oltean
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=165606782011.15655.7360355084913161028.git-patchwork-notify@kernel.org \
--to=patchwork-bot+netdevbpf@kernel.org \
--cc=UNGLinuxDriver@microchip.com \
--cc=andrew@lunn.ch \
--cc=arun.ramadoss@microchip.com \
--cc=davem@davemloft.net \
--cc=edumazet@google.com \
--cc=f.fainelli@gmail.com \
--cc=kuba@kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux@armlinux.org.uk \
--cc=netdev@vger.kernel.org \
--cc=olteanv@gmail.com \
--cc=pabeni@redhat.com \
--cc=vivien.didelot@gmail.com \
--cc=woojung.huh@microchip.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.