From: Arun Ramadoss <arun.ramadoss@microchip.com>
To: <linux-kernel@vger.kernel.org>, <netdev@vger.kernel.org>
Cc: Woojung Huh <woojung.huh@microchip.com>,
<UNGLinuxDriver@microchip.com>, Andrew Lunn <andrew@lunn.ch>,
Vivien Didelot <vivien.didelot@gmail.com>,
Florian Fainelli <f.fainelli@gmail.com>,
Vladimir Oltean <olteanv@gmail.com>,
"David S. Miller" <davem@davemloft.net>,
Eric Dumazet <edumazet@google.com>,
Jakub Kicinski <kuba@kernel.org>, Paolo Abeni <pabeni@redhat.com>,
"Russell King" <linux@armlinux.org.uk>
Subject: [Patch net-next 00/13] net: dsa: microchip: common spi probe for the ksz series switches - part 2
Date: Wed, 22 Jun 2022 14:34:12 +0530 [thread overview]
Message-ID: <20220622090425.17709-1-arun.ramadoss@microchip.com> (raw)
This patch series aims to refactor the ksz_switch_register routine to have the
common flow for the ksz series switch. And this is the follow up patch series.
First, it tries moves the common implementation in the setup from individual
files to ksz_setup. Then implements the common dsa_switch_ops structure instead
of independent registration. And then moves the ksz_dev_ops to ksz_common.c,
it allows the dynamic detection of which ksz_dev_ops to be used based on
the switch detection function.
Finally, the patch updates the ksz_spi probe function to be same for all the
ksz_switches.
Arun Ramadoss (13):
net: dsa: microchip: rename shutdown to reset in ksz_dev_ops
net: dsa: microchip: add config_cpu_port to struct ksz_dev_ops
net: dsa: microchip: add the enable_stp_addr pointer in ksz_dev_ops
net: dsa: microchip: move setup function to ksz_common
net: dsa: microchip: move broadcast rate limit to ksz_setup
net: dsa: microchip: move multicast enable to ksz_setup
net: dsa: microchip: move start of switch to ksz_setup
net: dsa: microchip: common dsa_switch_ops for ksz switches
net: dsa: microchip: ksz9477: separate phylink mode from switch
register
net: dsa: microchip: common menuconfig for ksz series switch
net: dsa: microchip: move ksz_dev_ops to ksz_common.c
net: dsa: microchip: remove the ksz8/ksz9477_switch_register
net: dsa: microchip: common ksz_spi_probe for ksz switches
drivers/net/dsa/microchip/Kconfig | 42 +--
drivers/net/dsa/microchip/Makefile | 10 +-
drivers/net/dsa/microchip/ksz8.h | 48 +++
drivers/net/dsa/microchip/ksz8795.c | 195 +++--------
drivers/net/dsa/microchip/ksz8795_reg.h | 12 -
drivers/net/dsa/microchip/ksz8863_smi.c | 2 +-
drivers/net/dsa/microchip/ksz9477.c | 244 +++++--------
drivers/net/dsa/microchip/ksz9477.h | 60 ++++
drivers/net/dsa/microchip/ksz9477_i2c.c | 6 +-
drivers/net/dsa/microchip/ksz9477_reg.h | 12 -
drivers/net/dsa/microchip/ksz9477_spi.c | 150 --------
drivers/net/dsa/microchip/ksz_common.c | 326 +++++++++++++-----
drivers/net/dsa/microchip/ksz_common.h | 82 ++---
.../microchip/{ksz8795_spi.c => ksz_spi.c} | 89 +++--
14 files changed, 598 insertions(+), 680 deletions(-)
create mode 100644 drivers/net/dsa/microchip/ksz9477.h
delete mode 100644 drivers/net/dsa/microchip/ksz9477_spi.c
rename drivers/net/dsa/microchip/{ksz8795_spi.c => ksz_spi.c} (60%)
base-commit: 8720bd951b8e8515ffd995c7631790fdabaa9265
--
2.36.1
next reply other threads:[~2022-06-22 9:06 UTC|newest]
Thread overview: 16+ messages / expand[flat|nested] mbox.gz Atom feed top
2022-06-22 9:04 Arun Ramadoss [this message]
2022-06-22 9:04 ` [Patch net-next 01/13] net: dsa: microchip: rename shutdown to reset in ksz_dev_ops Arun Ramadoss
2022-06-22 9:04 ` [Patch net-next 02/13] net: dsa: microchip: add config_cpu_port to struct ksz_dev_ops Arun Ramadoss
2022-06-22 9:04 ` [Patch net-next 03/13] net: dsa: microchip: add the enable_stp_addr pointer in ksz_dev_ops Arun Ramadoss
2022-06-22 9:04 ` [Patch net-next 04/13] net: dsa: microchip: move setup function to ksz_common Arun Ramadoss
2022-06-22 9:04 ` [Patch net-next 05/13] net: dsa: microchip: move broadcast rate limit to ksz_setup Arun Ramadoss
2022-06-22 9:04 ` [Patch net-next 06/13] net: dsa: microchip: move multicast enable " Arun Ramadoss
2022-06-22 9:04 ` [Patch net-next 07/13] net: dsa: microchip: move start of switch " Arun Ramadoss
2022-06-22 9:04 ` [Patch net-next 08/13] net: dsa: microchip: common dsa_switch_ops for ksz switches Arun Ramadoss
2022-06-22 9:04 ` [Patch net-next 09/13] net: dsa: microchip: ksz9477: separate phylink mode from switch register Arun Ramadoss
2022-06-22 9:04 ` [Patch net-next 10/13] net: dsa: microchip: common menuconfig for ksz series switch Arun Ramadoss
2022-06-22 9:04 ` [Patch net-next 11/13] net: dsa: microchip: move ksz_dev_ops to ksz_common.c Arun Ramadoss
2022-06-22 9:04 ` [Patch net-next 12/13] net: dsa: microchip: remove the ksz8/ksz9477_switch_register Arun Ramadoss
2022-06-22 9:04 ` [Patch net-next 13/13] net: dsa: microchip: common ksz_spi_probe for ksz switches Arun Ramadoss
2022-06-24 10:50 ` [Patch net-next 00/13] net: dsa: microchip: common spi probe for the ksz series switches - part 2 patchwork-bot+netdevbpf
2022-06-24 11:23 ` Vladimir Oltean
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20220622090425.17709-1-arun.ramadoss@microchip.com \
--to=arun.ramadoss@microchip.com \
--cc=UNGLinuxDriver@microchip.com \
--cc=andrew@lunn.ch \
--cc=davem@davemloft.net \
--cc=edumazet@google.com \
--cc=f.fainelli@gmail.com \
--cc=kuba@kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux@armlinux.org.uk \
--cc=netdev@vger.kernel.org \
--cc=olteanv@gmail.com \
--cc=pabeni@redhat.com \
--cc=vivien.didelot@gmail.com \
--cc=woojung.huh@microchip.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.