From: patchwork-bot+netdevbpf@kernel.org
To: Simon Wunderlich <sw@simonwunderlich.de>
Cc: netdev@vger.kernel.org, davem@davemloft.net, edumazet@google.com,
kuba@kernel.org, pabeni@redhat.com, horms@kernel.org,
b.a.t.m.a.n@lists.open-mesh.org, sven@narfation.org,
sashiko-bot@kernel.org
Subject: Re: [PATCH net-next 01/15] batman-adv: dat: fix printing of unknown 4addr subtype
Date: Fri, 04 Sep 2026 22:51:00 +0000 [thread overview]
Message-ID: <178856226064.1003513.4882624192828119251.git-patchwork-notify@kernel.org> (raw)
In-Reply-To: <20260831135117.574836-2-sw@simonwunderlich.de>
Hello:
This series was applied to netdev/net-next.git (main)
by Sven Eckelmann <sven@narfation.org>:
On Mon, 31 Aug 2026 15:51:03 +0200 you wrote:
> From: Sven Eckelmann <sven@narfation.org>
>
> If an unknown subtype of an unicast 4addr packets was detected in
> batadv_dbg_arp(), it is printing the (known) packet_type instead of the
> subtype. This must be switched to the subtype to have any kind of use for
> the reader of the debug message.
>
> [...]
Here is the summary with links:
- [net-next,01/15] batman-adv: dat: fix printing of unknown 4addr subtype
https://git.kernel.org/netdev/net-next/c/c6c8f1d693ac
- [net-next,02/15] batman-adv: drop direction in _batadv_is_ap_isolated kernel-doc
https://git.kernel.org/netdev/net-next/c/b963ee1dc32c
- [net-next,03/15] batman-adv: bat_v: fix bonding candidate selection
https://git.kernel.org/netdev/net-next/c/77f653e6f722
- [net-next,04/15] batman-adv: clarify cut-off in batadv_v_neigh_is_sob kernel-doc
https://git.kernel.org/netdev/net-next/c/7356a9232d9c
- [net-next,05/15] batman-adv: use more descriptive var names for is_similar_or_better
https://git.kernel.org/netdev/net-next/c/776c26254d24
- [net-next,06/15] batman-adv: ensure u16 aligned mac address arrays on stack
https://git.kernel.org/netdev/net-next/c/a5f7058bee1e
- [net-next,07/15] batman-adv: ensure u16 aligned mac address in structs
https://git.kernel.org/netdev/net-next/c/d9304a90eca5
- [net-next,08/15] batman-adv: tt: remove only the entry which was looked up from the hash
https://git.kernel.org/netdev/net-next/c/bbfb0d2cf035
- [net-next,09/15] batman-adv: tt: extract code handling a roam on add
https://git.kernel.org/netdev/net-next/c/fd8d892c685a
- [net-next,10/15] batman-adv: tt: simplify NEW flag transition code
https://git.kernel.org/netdev/net-next/c/e103fbefa049
- [net-next,11/15] batman-adv: tt: drop unnecessary cleanup goto in helpers
https://git.kernel.org/netdev/net-next/c/52d8c713f464
- [net-next,12/15] batman-adv: tt: use protected flag modifications
https://git.kernel.org/netdev/net-next/c/976b159b3c12
- [net-next,13/15] batman-adv: tt: transition NEW local entries only under lock
https://git.kernel.org/netdev/net-next/c/f59c4c59df10
- [net-next,14/15] batman-adv: tt: don't uncount never committed clients on pending purge
https://git.kernel.org/netdev/net-next/c/01ae63ecd1c0
- [net-next,15/15] batman-adv: tt: decrement count for committed client on local_remove
https://git.kernel.org/netdev/net-next/c/799152bcf6cb
You are awesome, thank you!
--
Deet-doot-dot, I am a bot.
https://korg.docs.kernel.org/patchwork/pwbot.html
next prev parent reply other threads:[~2026-09-04 22:52 UTC|newest]
Thread overview: 33+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-08-31 13:51 [PATCH net-next 00/15] pull request for net-next: batman-adv 2026-08-31 Simon Wunderlich
2026-08-31 13:51 ` [PATCH net-next 01/15] batman-adv: dat: fix printing of unknown 4addr subtype Simon Wunderlich
2026-09-01 17:03 ` Sven Eckelmann
2026-09-04 22:51 ` patchwork-bot+netdevbpf [this message]
2026-08-31 13:51 ` [PATCH net-next 02/15] batman-adv: drop direction in _batadv_is_ap_isolated kernel-doc Simon Wunderlich
2026-08-31 13:51 ` [PATCH net-next 03/15] batman-adv: bat_v: fix bonding candidate selection Simon Wunderlich
[not found] ` <20260901135959.23F6C1F000E9@smtp.kernel.org>
2026-09-01 16:58 ` Sven Eckelmann
2026-09-01 17:10 ` Sven Eckelmann
2026-08-31 13:51 ` [PATCH net-next 04/15] batman-adv: clarify cut-off in batadv_v_neigh_is_sob kernel-doc Simon Wunderlich
2026-08-31 13:51 ` [PATCH net-next 05/15] batman-adv: use more descriptive var names for is_similar_or_better Simon Wunderlich
2026-09-01 17:20 ` Sven Eckelmann
2026-08-31 13:51 ` [PATCH net-next 06/15] batman-adv: ensure u16 aligned mac address arrays on stack Simon Wunderlich
[not found] ` <20260901140000.035F51F000E9@smtp.kernel.org>
2026-09-01 16:59 ` Sven Eckelmann
2026-08-31 13:51 ` [PATCH net-next 07/15] batman-adv: ensure u16 aligned mac address in structs Simon Wunderlich
2026-09-01 17:24 ` Sven Eckelmann
2026-08-31 13:51 ` [PATCH net-next 08/15] batman-adv: tt: remove only the entry which was looked up from the hash Simon Wunderlich
[not found] ` <20260901140001.59CD41F000E9@smtp.kernel.org>
2026-09-01 16:59 ` Sven Eckelmann
2026-09-01 18:11 ` Sven Eckelmann
2026-08-31 13:51 ` [PATCH net-next 09/15] batman-adv: tt: extract code handling a roam on add Simon Wunderlich
[not found] ` <20260901140002.533041F000E9@smtp.kernel.org>
2026-09-01 16:58 ` Sven Eckelmann
2026-09-01 18:14 ` Sven Eckelmann
2026-08-31 13:51 ` [PATCH net-next 10/15] batman-adv: tt: simplify NEW flag transition code Simon Wunderlich
2026-09-01 18:18 ` Sven Eckelmann
2026-08-31 13:51 ` [PATCH net-next 11/15] batman-adv: tt: drop unnecessary cleanup goto in helpers Simon Wunderlich
2026-08-31 13:51 ` [PATCH net-next 12/15] batman-adv: tt: use protected flag modifications Simon Wunderlich
[not found] ` <20260901140003.62B041F000E9@smtp.kernel.org>
2026-09-01 16:58 ` Sven Eckelmann
2026-09-01 19:21 ` Sven Eckelmann
2026-08-31 13:51 ` [PATCH net-next 13/15] batman-adv: tt: transition NEW local entries only under lock Simon Wunderlich
2026-09-01 19:31 ` Sven Eckelmann
2026-08-31 13:51 ` [PATCH net-next 14/15] batman-adv: tt: don't uncount never committed clients on pending purge Simon Wunderlich
2026-09-01 19:33 ` Sven Eckelmann
2026-08-31 13:51 ` [PATCH net-next 15/15] batman-adv: tt: decrement count for committed client on local_remove Simon Wunderlich
2026-09-01 19:36 ` Sven Eckelmann
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=178856226064.1003513.4882624192828119251.git-patchwork-notify@kernel.org \
--to=patchwork-bot+netdevbpf@kernel.org \
--cc=b.a.t.m.a.n@lists.open-mesh.org \
--cc=davem@davemloft.net \
--cc=edumazet@google.com \
--cc=horms@kernel.org \
--cc=kuba@kernel.org \
--cc=netdev@vger.kernel.org \
--cc=pabeni@redhat.com \
--cc=sashiko-bot@kernel.org \
--cc=sven@narfation.org \
--cc=sw@simonwunderlich.de \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.