All of lore.kernel.org
 help / color / mirror / Atom feed
From: "CK Hu (胡俊光)" <ck.hu@mediatek.com>
To: AngeloGioacchino Del Regno
	<angelogioacchino.delregno@collabora.com>,
	"chunkuang.hu@kernel.org" <chunkuang.hu@kernel.org>
Cc: "Lewis Liao (廖柏鈞)" <Lewis.Liao@mediatek.com>,
	"Jason-JH Lin (林睿祥)" <Jason-JH.Lin@mediatek.com>,
	"Ives Chenjh (陳俊弘)" <Ives.Chenjh@mediatek.com>,
	"simona@ffwll.ch" <simona@ffwll.ch>,
	"TommyYL Chen (陳彥良)" <TommyYL.Chen@mediatek.com>,
	"dri-devel@lists.freedesktop.org"
	<dri-devel@lists.freedesktop.org>,
	"airlied@gmail.com" <airlied@gmail.com>,
	"linux-kernel@vger.kernel.org" <linux-kernel@vger.kernel.org>,
	"linux-arm-kernel@lists.infradead.org"
	<linux-arm-kernel@lists.infradead.org>,
	"p.zabel@pengutronix.de" <p.zabel@pengutronix.de>,
	"matthias.bgg@gmail.com" <matthias.bgg@gmail.com>,
	"linux-mediatek@lists.infradead.org"
	<linux-mediatek@lists.infradead.org>,
	"kernel@collabora.com" <kernel@collabora.com>
Subject: Re: [PATCH v1 5/5] drm/mediatek: mtk_dpi: Rename output fmts array for MT8195 DP_INTF
Date: Tue, 22 Apr 2025 06:04:03 +0000	[thread overview]
Message-ID: <17edb4bdca86ea79f89208567cc6e17778821b50.camel@mediatek.com> (raw)
In-Reply-To: <20250409131306.108635-6-angelogioacchino.delregno@collabora.com>

On Wed, 2025-04-09 at 15:13 +0200, AngeloGioacchino Del Regno wrote:
> External email : Please do not click links or open attachments until you have verified the sender or the content.
> 
> 
> For the sake of increasing human readability and avoid possible
> confusion between DPI and DP_INTF output formats (as the two are
> ever so slightly different), rename the mt8195_output_fmts array
> to mt8195_dp_intf_output_fmts.
> 
> This commit brings no functional changes.

Reviewed-by: CK Hu <ck.hu@mediatek.com>

> 
> Signed-off-by: AngeloGioacchino Del Regno <angelogioacchino.delregno@collabora.com>
> ---
>  drivers/gpu/drm/mediatek/mtk_dpi.c | 6 +++---
>  1 file changed, 3 insertions(+), 3 deletions(-)
> 
> diff --git a/drivers/gpu/drm/mediatek/mtk_dpi.c b/drivers/gpu/drm/mediatek/mtk_dpi.c
> index 9de537a77493..0b7f91fb519f 100644
> --- a/drivers/gpu/drm/mediatek/mtk_dpi.c
> +++ b/drivers/gpu/drm/mediatek/mtk_dpi.c
> @@ -1106,7 +1106,7 @@ static const u32 mt8195_dpi_output_fmts[] = {
>         MEDIA_BUS_FMT_YUV10_1X30,
>  };
> 
> -static const u32 mt8195_output_fmts[] = {
> +static const u32 mt8195_dp_intf_output_fmts[] = {
>         MEDIA_BUS_FMT_RGB888_1X24,
>         MEDIA_BUS_FMT_RGB888_2X12_LE,
>         MEDIA_BUS_FMT_RGB888_2X12_BE,
> @@ -1248,8 +1248,8 @@ static const struct mtk_dpi_conf mt8195_dpintf_conf = {
>         .dpi_factor = dpi_factor_mt8195_dp_intf,
>         .num_dpi_factor = ARRAY_SIZE(dpi_factor_mt8195_dp_intf),
>         .max_clock_khz = 600000,
> -       .output_fmts = mt8195_output_fmts,
> -       .num_output_fmts = ARRAY_SIZE(mt8195_output_fmts),
> +       .output_fmts = mt8195_dp_intf_output_fmts,
> +       .num_output_fmts = ARRAY_SIZE(mt8195_dp_intf_output_fmts),
>         .pixels_per_iter = 4,
>         .dimension_mask = DPINTF_HPW_MASK,
>         .hvsize_mask = DPINTF_HSIZE_MASK,
> --
> 2.49.0
> 


WARNING: multiple messages have this Message-ID (diff)
From: "CK Hu (胡俊光)" <ck.hu@mediatek.com>
To: AngeloGioacchino Del Regno
	<angelogioacchino.delregno@collabora.com>,
	"chunkuang.hu@kernel.org" <chunkuang.hu@kernel.org>
Cc: "Lewis Liao (廖柏鈞)" <Lewis.Liao@mediatek.com>,
	"Jason-JH Lin (林睿祥)" <Jason-JH.Lin@mediatek.com>,
	"Ives Chenjh (陳俊弘)" <Ives.Chenjh@mediatek.com>,
	"simona@ffwll.ch" <simona@ffwll.ch>,
	"TommyYL Chen (陳彥良)" <TommyYL.Chen@mediatek.com>,
	"dri-devel@lists.freedesktop.org"
	<dri-devel@lists.freedesktop.org>,
	"airlied@gmail.com" <airlied@gmail.com>,
	"linux-kernel@vger.kernel.org" <linux-kernel@vger.kernel.org>,
	"linux-arm-kernel@lists.infradead.org"
	<linux-arm-kernel@lists.infradead.org>,
	"p.zabel@pengutronix.de" <p.zabel@pengutronix.de>,
	"matthias.bgg@gmail.com" <matthias.bgg@gmail.com>,
	"linux-mediatek@lists.infradead.org"
	<linux-mediatek@lists.infradead.org>,
	"kernel@collabora.com" <kernel@collabora.com>
Subject: Re: [PATCH v1 5/5] drm/mediatek: mtk_dpi: Rename output fmts array for MT8195 DP_INTF
Date: Tue, 22 Apr 2025 06:04:03 +0000	[thread overview]
Message-ID: <17edb4bdca86ea79f89208567cc6e17778821b50.camel@mediatek.com> (raw)
In-Reply-To: <20250409131306.108635-6-angelogioacchino.delregno@collabora.com>

[-- Attachment #1: Type: text/plain, Size: 1903 bytes --]

On Wed, 2025-04-09 at 15:13 +0200, AngeloGioacchino Del Regno wrote:
> External email : Please do not click links or open attachments until you have verified the sender or the content.
> 
> 
> For the sake of increasing human readability and avoid possible
> confusion between DPI and DP_INTF output formats (as the two are
> ever so slightly different), rename the mt8195_output_fmts array
> to mt8195_dp_intf_output_fmts.
> 
> This commit brings no functional changes.

Reviewed-by: CK Hu <ck.hu@mediatek.com>

> 
> Signed-off-by: AngeloGioacchino Del Regno <angelogioacchino.delregno@collabora.com>
> ---
>  drivers/gpu/drm/mediatek/mtk_dpi.c | 6 +++---
>  1 file changed, 3 insertions(+), 3 deletions(-)
> 
> diff --git a/drivers/gpu/drm/mediatek/mtk_dpi.c b/drivers/gpu/drm/mediatek/mtk_dpi.c
> index 9de537a77493..0b7f91fb519f 100644
> --- a/drivers/gpu/drm/mediatek/mtk_dpi.c
> +++ b/drivers/gpu/drm/mediatek/mtk_dpi.c
> @@ -1106,7 +1106,7 @@ static const u32 mt8195_dpi_output_fmts[] = {
>         MEDIA_BUS_FMT_YUV10_1X30,
>  };
> 
> -static const u32 mt8195_output_fmts[] = {
> +static const u32 mt8195_dp_intf_output_fmts[] = {
>         MEDIA_BUS_FMT_RGB888_1X24,
>         MEDIA_BUS_FMT_RGB888_2X12_LE,
>         MEDIA_BUS_FMT_RGB888_2X12_BE,
> @@ -1248,8 +1248,8 @@ static const struct mtk_dpi_conf mt8195_dpintf_conf = {
>         .dpi_factor = dpi_factor_mt8195_dp_intf,
>         .num_dpi_factor = ARRAY_SIZE(dpi_factor_mt8195_dp_intf),
>         .max_clock_khz = 600000,
> -       .output_fmts = mt8195_output_fmts,
> -       .num_output_fmts = ARRAY_SIZE(mt8195_output_fmts),
> +       .output_fmts = mt8195_dp_intf_output_fmts,
> +       .num_output_fmts = ARRAY_SIZE(mt8195_dp_intf_output_fmts),
>         .pixels_per_iter = 4,
>         .dimension_mask = DPINTF_HPW_MASK,
>         .hvsize_mask = DPINTF_HSIZE_MASK,
> --
> 2.49.0
> 


[-- Attachment #2: Type: text/html, Size: 4141 bytes --]

  reply	other threads:[~2025-04-22  6:06 UTC|newest]

Thread overview: 20+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2025-04-09 13:13 [PATCH v1 0/5] MediaTek DPI: Cleanups and add support for more formats AngeloGioacchino Del Regno
2025-04-09 13:13 ` [PATCH v1 1/5] drm/mediatek: mtk_dpi: Use switch in mtk_dpi_config_color_format() AngeloGioacchino Del Regno
2025-04-22  3:30   ` CK Hu (胡俊光)
2025-04-22  3:30     ` CK Hu (胡俊光)
2025-04-09 13:13 ` [PATCH v1 2/5] drm/mediatek: mtk_dpi: Add local helpers for bus format parameters AngeloGioacchino Del Regno
2025-04-22  4:00   ` CK Hu (胡俊光)
2025-04-22  4:00     ` CK Hu (胡俊光)
2025-04-09 13:13 ` [PATCH v1 3/5] drm/mediatek: mtk_dpi: Add support for additional output formats AngeloGioacchino Del Regno
2025-04-22  5:50   ` CK Hu (胡俊光)
2025-04-22  5:50     ` CK Hu (胡俊光)
2025-04-09 13:13 ` [PATCH v1 4/5] drm/mediatek: mtk_dpi: Allow additional output formats on MT8195/88 AngeloGioacchino Del Regno
2025-04-22  6:01   ` CK Hu (胡俊光)
2025-04-22  6:01     ` CK Hu (胡俊光)
2025-04-22 13:42     ` AngeloGioacchino Del Regno
2025-04-23  3:45       ` CK Hu (胡俊光)
2025-04-23  3:45         ` CK Hu (胡俊光)
2025-04-09 13:13 ` [PATCH v1 5/5] drm/mediatek: mtk_dpi: Rename output fmts array for MT8195 DP_INTF AngeloGioacchino Del Regno
2025-04-22  6:04   ` CK Hu (胡俊光) [this message]
2025-04-22  6:04     ` CK Hu (胡俊光)
2025-04-27  1:47 ` [PATCH v1 0/5] MediaTek DPI: Cleanups and add support for more formats Chun-Kuang Hu

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=17edb4bdca86ea79f89208567cc6e17778821b50.camel@mediatek.com \
    --to=ck.hu@mediatek.com \
    --cc=Ives.Chenjh@mediatek.com \
    --cc=Jason-JH.Lin@mediatek.com \
    --cc=Lewis.Liao@mediatek.com \
    --cc=TommyYL.Chen@mediatek.com \
    --cc=airlied@gmail.com \
    --cc=angelogioacchino.delregno@collabora.com \
    --cc=chunkuang.hu@kernel.org \
    --cc=dri-devel@lists.freedesktop.org \
    --cc=kernel@collabora.com \
    --cc=linux-arm-kernel@lists.infradead.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-mediatek@lists.infradead.org \
    --cc=matthias.bgg@gmail.com \
    --cc=p.zabel@pengutronix.de \
    --cc=simona@ffwll.ch \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.