* 2.5.71 cardbus problem + possible solution
@ 2003-06-16 13:25 mikpe
2003-06-16 14:32 ` Russell King
0 siblings, 1 reply; 7+ messages in thread
From: mikpe @ 2003-06-16 13:25 UTC (permalink / raw)
To: linux-kernel
2.5.71 changed the name of the Yenta module from yenta_socket
to yenta. In my case (Latitude with RH9 user-space), this
prevented cardmgr from starting properly.
Quick fix: add 'alias yenta_socket yenta' to /etc/modprobe.conf,
or s/yenta_socket/yenta/ in the appropriate config file (but
then you make multi-booting 2.4/2.5 more difficult).
/Mikael
^ permalink raw reply [flat|nested] 7+ messages in thread
* Re: 2.5.71 cardbus problem + possible solution
2003-06-16 13:25 2.5.71 cardbus problem + possible solution mikpe
@ 2003-06-16 14:32 ` Russell King
2003-06-16 14:38 ` mikpe
0 siblings, 1 reply; 7+ messages in thread
From: Russell King @ 2003-06-16 14:32 UTC (permalink / raw)
To: mikpe, Dominik Brodowski; +Cc: linux-kernel
On Mon, Jun 16, 2003 at 03:25:16PM +0200, mikpe@csd.uu.se wrote:
> 2.5.71 changed the name of the Yenta module from yenta_socket
> to yenta. In my case (Latitude with RH9 user-space), this
> prevented cardmgr from starting properly.
>
> Quick fix: add 'alias yenta_socket yenta' to /etc/modprobe.conf,
> or s/yenta_socket/yenta/ in the appropriate config file (but
> then you make multi-booting 2.4/2.5 more difficult).
What do people want to do about this? I have no particular desire to
answer all those emails asking about this, so unless Dominik objects,
I think we should just rename "yenta.c" to "yenta_socket.c" so we have
back-compatibility.
(This issue has appeared because yenta_socket.ko used to be created
by combining yenta.o with pci_socket.o. Since pci_socket.c no longer
exists, we create the module from yenta.c directly, so its now called
yenta.ko.)
--
Russell King (rmk@arm.linux.org.uk) The developer of ARM Linux
http://www.arm.linux.org.uk/personal/aboutme.html
^ permalink raw reply [flat|nested] 7+ messages in thread* Re: 2.5.71 cardbus problem + possible solution
2003-06-16 14:32 ` Russell King
@ 2003-06-16 14:38 ` mikpe
2003-06-16 14:53 ` Felipe Alfaro Solana
2003-06-16 14:54 ` Dominik Brodowski
0 siblings, 2 replies; 7+ messages in thread
From: mikpe @ 2003-06-16 14:38 UTC (permalink / raw)
To: Russell King; +Cc: Dominik Brodowski, linux-kernel
Russell King writes:
> On Mon, Jun 16, 2003 at 03:25:16PM +0200, mikpe@csd.uu.se wrote:
> > 2.5.71 changed the name of the Yenta module from yenta_socket
> > to yenta. In my case (Latitude with RH9 user-space), this
> > prevented cardmgr from starting properly.
> >
> > Quick fix: add 'alias yenta_socket yenta' to /etc/modprobe.conf,
> > or s/yenta_socket/yenta/ in the appropriate config file (but
> > then you make multi-booting 2.4/2.5 more difficult).
>
> What do people want to do about this? I have no particular desire to
> answer all those emails asking about this, so unless Dominik objects,
> I think we should just rename "yenta.c" to "yenta_socket.c" so we have
> back-compatibility.
>
> (This issue has appeared because yenta_socket.ko used to be created
> by combining yenta.o with pci_socket.o. Since pci_socket.c no longer
> exists, we create the module from yenta.c directly, so its now called
> yenta.ko.)
I'd prefer compatibility, if there are no technical reasons for
breaking it. Reverting to the old name in 2.5.72 sounds like a
good idea.
^ permalink raw reply [flat|nested] 7+ messages in thread
* Re: 2.5.71 cardbus problem + possible solution
2003-06-16 14:38 ` mikpe
@ 2003-06-16 14:53 ` Felipe Alfaro Solana
2003-06-16 14:58 ` Dominik Brodowski
2003-06-16 14:59 ` Russell King
2003-06-16 14:54 ` Dominik Brodowski
1 sibling, 2 replies; 7+ messages in thread
From: Felipe Alfaro Solana @ 2003-06-16 14:53 UTC (permalink / raw)
To: mikpe; +Cc: Russell King, Dominik Brodowski, LKML
On Mon, 2003-06-16 at 16:38, mikpe@csd.uu.se wrote:
> Russell King writes:
> > On Mon, Jun 16, 2003 at 03:25:16PM +0200, mikpe@csd.uu.se wrote:
> > > 2.5.71 changed the name of the Yenta module from yenta_socket
> > > to yenta. In my case (Latitude with RH9 user-space), this
> > > prevented cardmgr from starting properly.
> > >
> > > Quick fix: add 'alias yenta_socket yenta' to /etc/modprobe.conf,
> > > or s/yenta_socket/yenta/ in the appropriate config file (but
> > > then you make multi-booting 2.4/2.5 more difficult).
> >
> > What do people want to do about this? I have no particular desire to
> > answer all those emails asking about this, so unless Dominik objects,
> > I think we should just rename "yenta.c" to "yenta_socket.c" so we have
> > back-compatibility.
> >
> > (This issue has appeared because yenta_socket.ko used to be created
> > by combining yenta.o with pci_socket.o. Since pci_socket.c no longer
> > exists, we create the module from yenta.c directly, so its now called
> > yenta.ko.)
>
> I'd prefer compatibility, if there are no technical reasons for
> breaking it. Reverting to the old name in 2.5.72 sounds like a
> good idea.
I must agree with. I think backwards compatibility is important if we
want widespread adoption of 2.6 from the beginning. But there's a
question I had in mind for long time: is cardmgr really needed? Isn't
hotplug more than enough to handle CardBus devices?
^ permalink raw reply [flat|nested] 7+ messages in thread
* Re: 2.5.71 cardbus problem + possible solution
2003-06-16 14:53 ` Felipe Alfaro Solana
@ 2003-06-16 14:58 ` Dominik Brodowski
2003-06-16 14:59 ` Russell King
1 sibling, 0 replies; 7+ messages in thread
From: Dominik Brodowski @ 2003-06-16 14:58 UTC (permalink / raw)
To: Felipe Alfaro Solana; +Cc: mikpe, Russell King, LKML
On Mon, Jun 16, 2003 at 04:53:07PM +0200, Felipe Alfaro Solana wrote:
>
> I must agree with. I think backwards compatibility is important if we
> want widespread adoption of 2.6 from the beginning. But there's a
> question I had in mind for long time: is cardmgr really needed? Isn't
> hotplug more than enough to handle CardBus devices?
One aim of my work is to deprecate cardmgr for both CardBus (32-bit) and
PCMCIA (16-bit) devices. For CardBus, most pieces should be there already,
for PCMCIA the road is much longer.
Dominik
^ permalink raw reply [flat|nested] 7+ messages in thread
* Re: 2.5.71 cardbus problem + possible solution
2003-06-16 14:53 ` Felipe Alfaro Solana
2003-06-16 14:58 ` Dominik Brodowski
@ 2003-06-16 14:59 ` Russell King
1 sibling, 0 replies; 7+ messages in thread
From: Russell King @ 2003-06-16 14:59 UTC (permalink / raw)
To: Felipe Alfaro Solana; +Cc: mikpe, Dominik Brodowski, LKML
On Mon, Jun 16, 2003 at 04:53:07PM +0200, Felipe Alfaro Solana wrote:
> I must agree with. I think backwards compatibility is important if we
> want widespread adoption of 2.6 from the beginning. But there's a
> question I had in mind for long time: is cardmgr really needed? Isn't
> hotplug more than enough to handle CardBus devices?
We're slowly working towards the point where our reliance on cardmgr
getting less and less.
--
Russell King (rmk@arm.linux.org.uk) The developer of ARM Linux
http://www.arm.linux.org.uk/personal/aboutme.html
^ permalink raw reply [flat|nested] 7+ messages in thread
* Re: 2.5.71 cardbus problem + possible solution
2003-06-16 14:38 ` mikpe
2003-06-16 14:53 ` Felipe Alfaro Solana
@ 2003-06-16 14:54 ` Dominik Brodowski
1 sibling, 0 replies; 7+ messages in thread
From: Dominik Brodowski @ 2003-06-16 14:54 UTC (permalink / raw)
To: mikpe; +Cc: Russell King, linux-kernel
On Mon, Jun 16, 2003 at 04:38:52PM +0200, mikpe@csd.uu.se wrote:
> > What do people want to do about this? I have no particular desire to
> > answer all those emails asking about this, so unless Dominik objects,
> > I think we should just rename "yenta.c" to "yenta_socket.c" so we have
> > back-compatibility.
Agreed.
Dominik
^ permalink raw reply [flat|nested] 7+ messages in thread
end of thread, other threads:[~2003-06-16 14:47 UTC | newest]
Thread overview: 7+ messages (download: mbox.gz follow: Atom feed
-- links below jump to the message on this page --
2003-06-16 13:25 2.5.71 cardbus problem + possible solution mikpe
2003-06-16 14:32 ` Russell King
2003-06-16 14:38 ` mikpe
2003-06-16 14:53 ` Felipe Alfaro Solana
2003-06-16 14:58 ` Dominik Brodowski
2003-06-16 14:59 ` Russell King
2003-06-16 14:54 ` Dominik Brodowski
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.