From: Yasunori Goto <y-goto@jp.fujitsu.com>
To: Andrew Morton <akpm@osdl.org>
Cc: Linux Kernel ML <linux-kernel@vger.kernel.org>,
linux-mm <linux-mm@kvack.org>
Subject: [Patch:001/005] wait_table and zonelist initializing for memory hotadd (change name of wait_table_size())
Date: Tue, 11 Apr 2006 20:30:09 +0900 [thread overview]
Message-ID: <20060411202534.5645.Y-GOTO@jp.fujitsu.com> (raw)
In-Reply-To: <20060411202031.5643.Y-GOTO@jp.fujitsu.com>
This is just to rename from wait_table_size() to wait_table_hash_nr_entries().
Signed-off-by: Yasunori Goto <y-goto@jp.fujitsu.com>
include/linux/mmzone.h | 4 ++--
mm/page_alloc.c | 12 +++++++-----
2 files changed, 9 insertions(+), 7 deletions(-)
Index: pgdat10/mm/page_alloc.c
===================================================================
--- pgdat10.orig/mm/page_alloc.c 2006-04-10 18:30:42.000000000 +0900
+++ pgdat10/mm/page_alloc.c 2006-04-10 20:20:09.000000000 +0900
@@ -1786,7 +1786,7 @@ void __init build_all_zonelists(void)
*/
#define PAGES_PER_WAITQUEUE 256
-static inline unsigned long wait_table_size(unsigned long pages)
+static inline unsigned long wait_table_hash_nr_entries(unsigned long pages)
{
unsigned long size = 1;
@@ -2081,13 +2081,15 @@ void zone_wait_table_init(struct zone *z
* The per-page waitqueue mechanism uses hashed waitqueues
* per zone.
*/
- zone->wait_table_size = wait_table_size(zone_size_pages);
- zone->wait_table_bits = wait_table_bits(zone->wait_table_size);
+ zone->wait_table_hash_nr_entries =
+ wait_table_hash_nr_entries(zone_size_pages);
+ zone->wait_table_bits =
+ wait_table_bits(zone->wait_table_hash_nr_entries);
zone->wait_table = (wait_queue_head_t *)
- alloc_bootmem_node(pgdat, zone->wait_table_size
+ alloc_bootmem_node(pgdat, zone->wait_table_hash_nr_entries
* sizeof(wait_queue_head_t));
- for(i = 0; i < zone->wait_table_size; ++i)
+ for(i = 0; i < zone->wait_table_hash_nr_entries; ++i)
init_waitqueue_head(zone->wait_table + i);
}
Index: pgdat10/include/linux/mmzone.h
===================================================================
--- pgdat10.orig/include/linux/mmzone.h 2006-04-10 18:30:40.000000000 +0900
+++ pgdat10/include/linux/mmzone.h 2006-04-10 20:19:33.000000000 +0900
@@ -196,7 +196,7 @@ struct zone {
/*
* wait_table -- the array holding the hash table
- * wait_table_size -- the size of the hash table array
+ * wait_table_hash_nr_entries -- the size of the hash table array
* wait_table_bits -- wait_table_size == (1 << wait_table_bits)
*
* The purpose of all these is to keep track of the people
@@ -219,7 +219,7 @@ struct zone {
* free_area_init_core() performs the initialization of them.
*/
wait_queue_head_t * wait_table;
- unsigned long wait_table_size;
+ unsigned long wait_table_hash_nr_entries;
unsigned long wait_table_bits;
/*
--
Yasunori Goto
WARNING: multiple messages have this Message-ID (diff)
From: Yasunori Goto <y-goto@jp.fujitsu.com>
To: Andrew Morton <akpm@osdl.org>
Cc: Linux Kernel ML <linux-kernel@vger.kernel.org>,
linux-mm <linux-mm@kvack.org>
Subject: [Patch:001/005] wait_table and zonelist initializing for memory hotadd (change name of wait_table_size())
Date: Tue, 11 Apr 2006 20:30:09 +0900 [thread overview]
Message-ID: <20060411202534.5645.Y-GOTO@jp.fujitsu.com> (raw)
In-Reply-To: <20060411202031.5643.Y-GOTO@jp.fujitsu.com>
This is just to rename from wait_table_size() to wait_table_hash_nr_entries().
Signed-off-by: Yasunori Goto <y-goto@jp.fujitsu.com>
include/linux/mmzone.h | 4 ++--
mm/page_alloc.c | 12 +++++++-----
2 files changed, 9 insertions(+), 7 deletions(-)
Index: pgdat10/mm/page_alloc.c
===================================================================
--- pgdat10.orig/mm/page_alloc.c 2006-04-10 18:30:42.000000000 +0900
+++ pgdat10/mm/page_alloc.c 2006-04-10 20:20:09.000000000 +0900
@@ -1786,7 +1786,7 @@ void __init build_all_zonelists(void)
*/
#define PAGES_PER_WAITQUEUE 256
-static inline unsigned long wait_table_size(unsigned long pages)
+static inline unsigned long wait_table_hash_nr_entries(unsigned long pages)
{
unsigned long size = 1;
@@ -2081,13 +2081,15 @@ void zone_wait_table_init(struct zone *z
* The per-page waitqueue mechanism uses hashed waitqueues
* per zone.
*/
- zone->wait_table_size = wait_table_size(zone_size_pages);
- zone->wait_table_bits = wait_table_bits(zone->wait_table_size);
+ zone->wait_table_hash_nr_entries =
+ wait_table_hash_nr_entries(zone_size_pages);
+ zone->wait_table_bits =
+ wait_table_bits(zone->wait_table_hash_nr_entries);
zone->wait_table = (wait_queue_head_t *)
- alloc_bootmem_node(pgdat, zone->wait_table_size
+ alloc_bootmem_node(pgdat, zone->wait_table_hash_nr_entries
* sizeof(wait_queue_head_t));
- for(i = 0; i < zone->wait_table_size; ++i)
+ for(i = 0; i < zone->wait_table_hash_nr_entries; ++i)
init_waitqueue_head(zone->wait_table + i);
}
Index: pgdat10/include/linux/mmzone.h
===================================================================
--- pgdat10.orig/include/linux/mmzone.h 2006-04-10 18:30:40.000000000 +0900
+++ pgdat10/include/linux/mmzone.h 2006-04-10 20:19:33.000000000 +0900
@@ -196,7 +196,7 @@ struct zone {
/*
* wait_table -- the array holding the hash table
- * wait_table_size -- the size of the hash table array
+ * wait_table_hash_nr_entries -- the size of the hash table array
* wait_table_bits -- wait_table_size == (1 << wait_table_bits)
*
* The purpose of all these is to keep track of the people
@@ -219,7 +219,7 @@ struct zone {
* free_area_init_core() performs the initialization of them.
*/
wait_queue_head_t * wait_table;
- unsigned long wait_table_size;
+ unsigned long wait_table_hash_nr_entries;
unsigned long wait_table_bits;
/*
--
Yasunori Goto
--
To unsubscribe, send a message with 'unsubscribe linux-mm' in
the body to majordomo@kvack.org. For more info on Linux MM,
see: http://www.linux-mm.org/ .
Don't email: <a href=mailto:"dont@kvack.org"> email@kvack.org </a>
next prev parent reply other threads:[~2006-04-11 11:30 UTC|newest]
Thread overview: 12+ messages / expand[flat|nested] mbox.gz Atom feed top
2006-04-11 11:25 [Patch:000/005] wait_table and zonelist initializing for memory hotadd Yasunori Goto
2006-04-11 11:25 ` Yasunori Goto
2006-04-11 11:30 ` Yasunori Goto [this message]
2006-04-11 11:30 ` [Patch:001/005] wait_table and zonelist initializing for memory hotadd (change name of wait_table_size()) Yasunori Goto
2006-04-11 11:30 ` [Patch:002/005] wait_table and zonelist initializing for memory hotadd (change to meminit for build_zonelist) Yasunori Goto
2006-04-11 11:30 ` Yasunori Goto
2006-04-11 11:30 ` [Patch:003/005] wait_table and zonelist initializing for memory hotadd(add return code for init_current_empty_zone) Yasunori Goto
2006-04-11 11:30 ` Yasunori Goto
2006-04-11 11:30 ` [Patch:004/005] wait_table and zonelist initializing for memory hotadd (wait_table initialization) Yasunori Goto
2006-04-11 11:30 ` Yasunori Goto
2006-04-11 11:30 ` [Patch:005/005] wait_table and zonelist initializing for memory hotadd (update zonelists) Yasunori Goto
2006-04-11 11:30 ` Yasunori Goto
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20060411202534.5645.Y-GOTO@jp.fujitsu.com \
--to=y-goto@jp.fujitsu.com \
--cc=akpm@osdl.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-mm@kvack.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.