From: Sam Ravnborg <sam@ravnborg.org>
To: Olof Johansson <olof@lixom.net>
Cc: Jonas Bonn <jonas@southpole.se>, linux-kernel@vger.kernel.org
Subject: Re: pci_device_id definition cleanups
Date: Sat, 16 Feb 2008 13:24:07 +0100 [thread overview]
Message-ID: <20080216122407.GA11753@uranus.ravnborg.org> (raw)
In-Reply-To: <20080216052737.GA18277@lixom.net>
On Fri, Feb 15, 2008 at 11:27:38PM -0600, Olof Johansson wrote:
> On Sat, Feb 16, 2008 at 03:23:36AM +0100, Sam Ravnborg wrote:
> > On Sat, Feb 16, 2008 at 12:21:40AM +0100, Jonas Bonn wrote:
> > > I've done some work on cleaning up the definitions of pci_device_id to
> > > make them "static const" (where possible) and to make sure they go into
> > > __devinitconst. There are about 350 changes of the type shown in the
> > > diff at the end of this mail.
> > >
> > > ???All these changes are in my public GIT tree at:
> > >
> > > git://www.southpole.se/~jonas/git/linux.git
> > >
> > > (Based on 2.6.25-rc2)
> > >
> > > In addition to these pci_device_id changes, there are a few changesets
> > > that move "const" data from __devinitdata to __devinitconst.
> > >
> > > The tree above builds with both allmodconfig and allyesconfig.
> >
> > Hi Jonas.
> >
> > Can I ask you to try the same with ARCH=powerpc
> > (or alpha or ia64).
> > Becasue it is for these architectures we see issues with
> > defining data const.
>
> I pulled his tree and tried building on powerpc w/ gcc 4.3, it passed.
Thanks for testing!
>
> I'm not too excited about the extremely long open-coded variable
> definitions everywhere now though. Wouldn't it be better to just do a
> macro for it?
>
> Something like:
>
> #define PCI_DEVICE_TABLE(_var) static const struct pci_device_id _var[] __devinitconst
Fully agreed - but this is Greg's area I guess. Try submitting him a patch.
Sam
prev parent reply other threads:[~2008-02-16 12:24 UTC|newest]
Thread overview: 7+ messages / expand[flat|nested] mbox.gz Atom feed top
2008-02-15 23:21 pci_device_id definition cleanups Jonas Bonn
2008-02-16 0:05 ` Greg KH
2008-02-16 0:55 ` Jeff Garzik
2008-02-16 0:57 ` Greg KH
2008-02-16 2:23 ` Sam Ravnborg
2008-02-16 5:27 ` Olof Johansson
2008-02-16 12:24 ` Sam Ravnborg [this message]
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20080216122407.GA11753@uranus.ravnborg.org \
--to=sam@ravnborg.org \
--cc=jonas@southpole.se \
--cc=linux-kernel@vger.kernel.org \
--cc=olof@lixom.net \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.