* [U-Boot-Users] [PATCH 1/1] ppc4xx: Rename CONFIG_XILINX_ML300 to CONFIG_XILINX_405
@ 2008-06-24 7:54 monstr at seznam.cz
2008-06-24 8:26 ` Stefan Roese
2008-07-06 20:39 ` Wolfgang Denk
0 siblings, 2 replies; 5+ messages in thread
From: monstr at seznam.cz @ 2008-06-24 7:54 UTC (permalink / raw)
To: u-boot
From: Michal Simek <monstr@monstr.eu>
This change helps with better handling with others
Xilinx based platform.
Signed-off-by: Michal Simek <monstr@monstr.eu>
---
common/cmd_bdinfo.c | 8 ++++----
cpu/ppc4xx/speed.c | 2 +-
include/configs/ml300.h | 1 +
lib_ppc/board.c | 2 +-
4 files changed, 7 insertions(+), 6 deletions(-)
diff --git a/common/cmd_bdinfo.c b/common/cmd_bdinfo.c
index 5bb39d8..caa467d 100644
--- a/common/cmd_bdinfo.c
+++ b/common/cmd_bdinfo.c
@@ -60,18 +60,18 @@ int do_bdinfo ( cmd_tbl_t *cmdtp, int flag, int argc, char *argv[])
#endif
print_num ("bootflags", bd->bi_bootflags );
#if defined(CONFIG_405GP) || defined(CONFIG_405CR) || \
- defined(CONFIG_405EP) || defined(CONFIG_XILINX_ML300) || \
+ defined(CONFIG_405EP) || defined(CONFIG_XILINX_405) || \
defined(CONFIG_440EP) || defined(CONFIG_440GR) || \
defined(CONFIG_440EPX) || defined(CONFIG_440GRX) || \
defined(CONFIG_440SP) || defined(CONFIG_440SPE)
print_str ("procfreq", strmhz(buf, bd->bi_procfreq));
print_str ("plb_busfreq", strmhz(buf, bd->bi_plb_busfreq));
-#if defined(CONFIG_405GP) || defined(CONFIG_405EP) || defined(CONFIG_XILINX_ML300) || \
+#if defined(CONFIG_405GP) || defined(CONFIG_405EP) || defined(CONFIG_XILINX_405) || \
defined(CONFIG_440EP) || defined(CONFIG_440GR) || defined(CONFIG_440SPE) || \
defined(CONFIG_440EPX) || defined(CONFIG_440GRX)
print_str ("pci_busfreq", strmhz(buf, bd->bi_pci_busfreq));
#endif
-#else /* ! CONFIG_405GP, CONFIG_405CR, CONFIG_405EP, CONFIG_XILINX_ML300, CONFIG_440EP CONFIG_440GR */
+#else /* ! CONFIG_405GP, CONFIG_405CR, CONFIG_405EP, CONFIG_XILINX_405, CONFIG_440EP CONFIG_440GR */
#if defined(CONFIG_CPM2)
print_str ("vco", strmhz(buf, bd->bi_vco));
print_str ("sccfreq", strmhz(buf, bd->bi_sccfreq));
@@ -82,7 +82,7 @@ int do_bdinfo ( cmd_tbl_t *cmdtp, int flag, int argc, char *argv[])
print_str ("cpmfreq", strmhz(buf, bd->bi_cpmfreq));
#endif
print_str ("busfreq", strmhz(buf, bd->bi_busfreq));
-#endif /* CONFIG_405GP, CONFIG_405CR, CONFIG_405EP, CONFIG_XILINX_ML300, CONFIG_440EP CONFIG_440GR */
+#endif /* CONFIG_405GP, CONFIG_405CR, CONFIG_405EP, CONFIG_XILINX_405, CONFIG_440EP CONFIG_440GR */
#if defined(CONFIG_MPC8220)
print_str ("inpfreq", strmhz(buf, bd->bi_inpfreq));
print_str ("flbfreq", strmhz(buf, bd->bi_flbfreq));
diff --git a/cpu/ppc4xx/speed.c b/cpu/ppc4xx/speed.c
index ef47ffc..34bd721 100644
--- a/cpu/ppc4xx/speed.c
+++ b/cpu/ppc4xx/speed.c
@@ -754,7 +754,7 @@ ulong get_OPB_freq (void)
return sys_info.freqOPB;
}
-#elif defined(CONFIG_XILINX_ML300)
+#elif defined(CONFIG_XILINX_405)
extern void get_sys_info (sys_info_t * sysInfo);
extern ulong get_PCI_freq (void);
diff --git a/include/configs/ml300.h b/include/configs/ml300.h
index 1945918..319923a 100644
--- a/include/configs/ml300.h
+++ b/include/configs/ml300.h
@@ -54,6 +54,7 @@
#define CONFIG_405 1 /* This is a PPC405 CPU */
#define CONFIG_4xx 1 /* ...member of PPC4xx family */
+#define CONFIG_XILINX_405 1
#define CONFIG_XILINX_ML300 1 /* ...on a Xilinx ML300 board */
#define CONFIG_SYSTEMACE 1
diff --git a/lib_ppc/board.c b/lib_ppc/board.c
index c42e088..947e38d 100644
--- a/lib_ppc/board.c
+++ b/lib_ppc/board.c
@@ -627,7 +627,7 @@ void board_init_f (ulong bootflag)
defined(CONFIG_440EPX) || defined(CONFIG_440GRX)
bd->bi_pci_busfreq = get_PCI_freq ();
bd->bi_opbfreq = get_OPB_freq ();
-#elif defined(CONFIG_XILINX_ML300)
+#elif defined(CONFIG_XILINX_405)
bd->bi_pci_busfreq = get_PCI_freq ();
#endif
#endif
--
1.5.4.GIT
^ permalink raw reply related [flat|nested] 5+ messages in thread* [U-Boot-Users] [PATCH 1/1] ppc4xx: Rename CONFIG_XILINX_ML300 to CONFIG_XILINX_405
2008-06-24 7:54 [U-Boot-Users] [PATCH 1/1] ppc4xx: Rename CONFIG_XILINX_ML300 to CONFIG_XILINX_405 monstr at seznam.cz
@ 2008-06-24 8:26 ` Stefan Roese
2008-06-24 8:53 ` Michal Simek
2008-07-06 20:40 ` Wolfgang Denk
2008-07-06 20:39 ` Wolfgang Denk
1 sibling, 2 replies; 5+ messages in thread
From: Stefan Roese @ 2008-06-24 8:26 UTC (permalink / raw)
To: u-boot
On Tuesday 24 June 2008, monstr at seznam.cz wrote:
> From: Michal Simek <monstr@monstr.eu>
>
> This change helps with better handling with others
> Xilinx based platform.
>
> Signed-off-by: Michal Simek <monstr@monstr.eu>
Acked-by: Stefan Roese <sr@denx.de>
Wolfgang, please apply this directly, since it doesn't "fit" into one
of the custodian repositories.
Thanks.
Best regards,
Stefan
=====================================================================
DENX Software Engineering GmbH, MD: Wolfgang Denk & Detlev Zundel
HRB 165235 Munich, Office: Kirchenstr.5, D-82194 Groebenzell, Germany
Phone: +49-8142-66989-0 Fax: +49-8142-66989-80 Email: office at denx.de
=====================================================================
^ permalink raw reply [flat|nested] 5+ messages in thread
* [U-Boot-Users] [PATCH 1/1] ppc4xx: Rename CONFIG_XILINX_ML300 to CONFIG_XILINX_405
2008-06-24 8:26 ` Stefan Roese
@ 2008-06-24 8:53 ` Michal Simek
2008-07-06 20:40 ` Wolfgang Denk
1 sibling, 0 replies; 5+ messages in thread
From: Michal Simek @ 2008-06-24 8:53 UTC (permalink / raw)
To: u-boot
Thanks Stefan,
M
> From: Michal Simek <monstr@monstr.eu>
>
> This change helps with better handling with others
> Xilinx based platform.
>
> Signed-off-by: Michal Simek <monstr@monstr.eu>
Acked-by: Stefan Roese <sr@denx.de>
Wolfgang, please apply this directly, since it doesn't "fit" into one
of the custodian repositories.
Thanks.
Best regards,
Stefan
=====================================================================
DENX Software Engineering GmbH, MD: Wolfgang Denk & Detlev Zundel
HRB 165235 Munich, Office: Kirchenstr.5, D-82194 Groebenzell, Germany
Phone: +49-8142-66989-0 Fax: +49-8142-66989-80 Email: office at denx.de
=====================================================================
^ permalink raw reply [flat|nested] 5+ messages in thread
* [U-Boot-Users] [PATCH 1/1] ppc4xx: Rename CONFIG_XILINX_ML300 to CONFIG_XILINX_405
2008-06-24 8:26 ` Stefan Roese
2008-06-24 8:53 ` Michal Simek
@ 2008-07-06 20:40 ` Wolfgang Denk
1 sibling, 0 replies; 5+ messages in thread
From: Wolfgang Denk @ 2008-07-06 20:40 UTC (permalink / raw)
To: u-boot
In message <200806241026.45274.sr@denx.de> you wrote:
>
> Acked-by: Stefan Roese <sr@denx.de>
>
> Wolfgang, please apply this directly, since it doesn't "fit" into one
> of the custodian repositories.
Done, but pulling this into the ppc4xx repo would have been fine with
me.
Best regards,
Wolfgang Denk
--
DENX Software Engineering GmbH, MD: Wolfgang Denk & Detlev Zundel
HRB 165235 Munich, Office: Kirchenstr.5, D-82194 Groebenzell, Germany
Phone: (+49)-8142-66989-10 Fax: (+49)-8142-66989-80 Email: wd at denx.de
When a woman marries again it is because she detested her first hus-
band. When a man marries again, it is because he adored his first
wife. -- Oscar Wilde
^ permalink raw reply [flat|nested] 5+ messages in thread
* [U-Boot-Users] [PATCH 1/1] ppc4xx: Rename CONFIG_XILINX_ML300 to CONFIG_XILINX_405
2008-06-24 7:54 [U-Boot-Users] [PATCH 1/1] ppc4xx: Rename CONFIG_XILINX_ML300 to CONFIG_XILINX_405 monstr at seznam.cz
2008-06-24 8:26 ` Stefan Roese
@ 2008-07-06 20:39 ` Wolfgang Denk
1 sibling, 0 replies; 5+ messages in thread
From: Wolfgang Denk @ 2008-07-06 20:39 UTC (permalink / raw)
To: u-boot
In message <1214294049-4257-1-git-send-email-monstr@seznam.cz> you wrote:
> From: Michal Simek <monstr@monstr.eu>
>
> This change helps with better handling with others
> Xilinx based platform.
>
> Signed-off-by: Michal Simek <monstr@monstr.eu>
> ---
> common/cmd_bdinfo.c | 8 ++++----
> cpu/ppc4xx/speed.c | 2 +-
> include/configs/ml300.h | 1 +
> lib_ppc/board.c | 2 +-
> 4 files changed, 7 insertions(+), 6 deletions(-)
Applied, thanks.
Best regards,
Wolfgang Denk
--
DENX Software Engineering GmbH, MD: Wolfgang Denk & Detlev Zundel
HRB 165235 Munich, Office: Kirchenstr.5, D-82194 Groebenzell, Germany
Phone: (+49)-8142-66989-10 Fax: (+49)-8142-66989-80 Email: wd at denx.de
"A fractal is by definition a set for which the Hausdorff Besicovitch
dimension strictly exceeds the topological dimension."
- Mandelbrot, _The Fractal Geometry of Nature_
^ permalink raw reply [flat|nested] 5+ messages in thread
end of thread, other threads:[~2008-07-06 20:40 UTC | newest]
Thread overview: 5+ messages (download: mbox.gz follow: Atom feed
-- links below jump to the message on this page --
2008-06-24 7:54 [U-Boot-Users] [PATCH 1/1] ppc4xx: Rename CONFIG_XILINX_ML300 to CONFIG_XILINX_405 monstr at seznam.cz
2008-06-24 8:26 ` Stefan Roese
2008-06-24 8:53 ` Michal Simek
2008-07-06 20:40 ` Wolfgang Denk
2008-07-06 20:39 ` Wolfgang Denk
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.