* [PATCH 1/3] ARM: Samsung S5P: Move the common Samsung S5P series GPIO level type @ 2010-08-30 11:47 ` Kyungmin Park 0 siblings, 0 replies; 10+ messages in thread From: Kyungmin Park @ 2010-08-30 11:47 UTC (permalink / raw) To: linux-arm-kernel From: Kyungmin Park <kyungmin.park@samsung.com> Samsung S5P series has common level type. It's different from S3C series. Signed-off-by: Kyungmin Park <kyungmin.park@samsung.com> --- arch/arm/plat-samsung/include/plat/gpio-core.h | 6 ++++++ 1 files changed, 6 insertions(+), 0 deletions(-) diff --git a/arch/arm/plat-samsung/include/plat/gpio-core.h b/arch/arm/plat-samsung/include/plat/gpio-core.h index e358c7d..c8681e0 100644 --- a/arch/arm/plat-samsung/include/plat/gpio-core.h +++ b/arch/arm/plat-samsung/include/plat/gpio-core.h @@ -14,6 +14,12 @@ #define GPIOCON_OFF (0x00) #define GPIODAT_OFF (0x04) +#define S5P_GPIO_LEVEL_LOW (0x00) +#define S5P_GPIO_LEVEL_HIGH (0x01) +#define S5P_GPIO_EDGE_FALLING (0x02) +#define S5P_GPIO_EDGE_RISING (0x03) +#define S5P_GPIO_EDGE_BOTH (0x04) + #define con_4bit_shift(__off) ((__off) * 4) /* Define the core gpiolib support functions that the s3c platforms may -- 1.5.3.3 ^ permalink raw reply related [flat|nested] 10+ messages in thread
* [PATCH 1/3] ARM: Samsung S5P: Move the common Samsung S5P series GPIO level type @ 2010-08-30 11:47 ` Kyungmin Park 0 siblings, 0 replies; 10+ messages in thread From: Kyungmin Park @ 2010-08-30 11:47 UTC (permalink / raw) To: linux-arm-kernel, linux-kernel Cc: jy0922.shim, m.szyprowski, ben-linux, kgene.kim From: Kyungmin Park <kyungmin.park@samsung.com> Samsung S5P series has common level type. It's different from S3C series. Signed-off-by: Kyungmin Park <kyungmin.park@samsung.com> --- arch/arm/plat-samsung/include/plat/gpio-core.h | 6 ++++++ 1 files changed, 6 insertions(+), 0 deletions(-) diff --git a/arch/arm/plat-samsung/include/plat/gpio-core.h b/arch/arm/plat-samsung/include/plat/gpio-core.h index e358c7d..c8681e0 100644 --- a/arch/arm/plat-samsung/include/plat/gpio-core.h +++ b/arch/arm/plat-samsung/include/plat/gpio-core.h @@ -14,6 +14,12 @@ #define GPIOCON_OFF (0x00) #define GPIODAT_OFF (0x04) +#define S5P_GPIO_LEVEL_LOW (0x00) +#define S5P_GPIO_LEVEL_HIGH (0x01) +#define S5P_GPIO_EDGE_FALLING (0x02) +#define S5P_GPIO_EDGE_RISING (0x03) +#define S5P_GPIO_EDGE_BOTH (0x04) + #define con_4bit_shift(__off) ((__off) * 4) /* Define the core gpiolib support functions that the s3c platforms may -- 1.5.3.3 ^ permalink raw reply related [flat|nested] 10+ messages in thread
* [PATCH 1/3] ARM: Samsung S5P: Move the common Samsung S5P series GPIO level type 2010-08-30 11:47 ` Kyungmin Park @ 2010-08-30 11:59 ` Sergei Shtylyov -1 siblings, 0 replies; 10+ messages in thread From: Sergei Shtylyov @ 2010-08-30 11:59 UTC (permalink / raw) To: linux-arm-kernel Hello. Kyungmin Park wrote: > From: Kyungmin Park <kyungmin.park@samsung.com> > Samsung S5P series has common level type. It's different from S3C series. > Signed-off-by: Kyungmin Park <kyungmin.park@samsung.com> [...] > diff --git a/arch/arm/plat-samsung/include/plat/gpio-core.h b/arch/arm/plat-samsung/include/plat/gpio-core.h > index e358c7d..c8681e0 100644 > --- a/arch/arm/plat-samsung/include/plat/gpio-core.h > +++ b/arch/arm/plat-samsung/include/plat/gpio-core.h > @@ -14,6 +14,12 @@ > #define GPIOCON_OFF (0x00) > #define GPIODAT_OFF (0x04) > > +#define S5P_GPIO_LEVEL_LOW (0x00) > +#define S5P_GPIO_LEVEL_HIGH (0x01) > +#define S5P_GPIO_EDGE_FALLING (0x02) > +#define S5P_GPIO_EDGE_RISING (0x03) > +#define S5P_GPIO_EDGE_BOTH (0x04) The parens are useless here. WBR, Sergei ^ permalink raw reply [flat|nested] 10+ messages in thread
* Re: [PATCH 1/3] ARM: Samsung S5P: Move the common Samsung S5P series GPIO level type @ 2010-08-30 11:59 ` Sergei Shtylyov 0 siblings, 0 replies; 10+ messages in thread From: Sergei Shtylyov @ 2010-08-30 11:59 UTC (permalink / raw) To: Kyungmin Park Cc: linux-arm-kernel, linux-kernel, kgene.kim, jy0922.shim, ben-linux, m.szyprowski Hello. Kyungmin Park wrote: > From: Kyungmin Park <kyungmin.park@samsung.com> > Samsung S5P series has common level type. It's different from S3C series. > Signed-off-by: Kyungmin Park <kyungmin.park@samsung.com> [...] > diff --git a/arch/arm/plat-samsung/include/plat/gpio-core.h b/arch/arm/plat-samsung/include/plat/gpio-core.h > index e358c7d..c8681e0 100644 > --- a/arch/arm/plat-samsung/include/plat/gpio-core.h > +++ b/arch/arm/plat-samsung/include/plat/gpio-core.h > @@ -14,6 +14,12 @@ > #define GPIOCON_OFF (0x00) > #define GPIODAT_OFF (0x04) > > +#define S5P_GPIO_LEVEL_LOW (0x00) > +#define S5P_GPIO_LEVEL_HIGH (0x01) > +#define S5P_GPIO_EDGE_FALLING (0x02) > +#define S5P_GPIO_EDGE_RISING (0x03) > +#define S5P_GPIO_EDGE_BOTH (0x04) The parens are useless here. WBR, Sergei ^ permalink raw reply [flat|nested] 10+ messages in thread
* [PATCH 1/3] ARM: Samsung S5P: Move the common Samsung S5P series GPIO level type 2010-08-30 11:47 ` Kyungmin Park @ 2010-08-30 12:01 ` Kukjin Kim -1 siblings, 0 replies; 10+ messages in thread From: Kukjin Kim @ 2010-08-30 12:01 UTC (permalink / raw) To: linux-arm-kernel Kyungmin Park wrote: > > From: Kyungmin Park <kyungmin.park@samsung.com> > > Samsung S5P series has common level type. It's different from S3C series. > > Signed-off-by: Kyungmin Park <kyungmin.park@samsung.com> > --- > arch/arm/plat-samsung/include/plat/gpio-core.h | 6 ++++++ > 1 files changed, 6 insertions(+), 0 deletions(-) > > diff --git a/arch/arm/plat-samsung/include/plat/gpio-core.h b/arch/arm/plat- > samsung/include/plat/gpio-core.h > index e358c7d..c8681e0 100644 > --- a/arch/arm/plat-samsung/include/plat/gpio-core.h > +++ b/arch/arm/plat-samsung/include/plat/gpio-core.h > @@ -14,6 +14,12 @@ > #define GPIOCON_OFF (0x00) > #define GPIODAT_OFF (0x04) > > +#define S5P_GPIO_LEVEL_LOW (0x00) > +#define S5P_GPIO_LEVEL_HIGH (0x01) > +#define S5P_GPIO_EDGE_FALLING (0x02) > +#define S5P_GPIO_EDGE_RISING (0x03) > +#define S5P_GPIO_EDGE_BOTH (0x04) Why should we change the name of definition from S5P_EXTINT_XXX? If we use that, we don't need to change other files. > + > #define con_4bit_shift(__off) ((__off) * 4) > > /* Define the core gpiolib support functions that the s3c platforms may > -- Thanks. Best regards, Kgene. -- Kukjin Kim <kgene.kim@samsung.com>, Senior Engineer, SW Solution Development Team, Samsung Electronics Co., Ltd. ^ permalink raw reply [flat|nested] 10+ messages in thread
* RE: [PATCH 1/3] ARM: Samsung S5P: Move the common Samsung S5P series GPIO level type @ 2010-08-30 12:01 ` Kukjin Kim 0 siblings, 0 replies; 10+ messages in thread From: Kukjin Kim @ 2010-08-30 12:01 UTC (permalink / raw) To: 'Kyungmin Park', linux-arm-kernel, linux-kernel Cc: jy0922.shim, m.szyprowski, ben-linux Kyungmin Park wrote: > > From: Kyungmin Park <kyungmin.park@samsung.com> > > Samsung S5P series has common level type. It's different from S3C series. > > Signed-off-by: Kyungmin Park <kyungmin.park@samsung.com> > --- > arch/arm/plat-samsung/include/plat/gpio-core.h | 6 ++++++ > 1 files changed, 6 insertions(+), 0 deletions(-) > > diff --git a/arch/arm/plat-samsung/include/plat/gpio-core.h b/arch/arm/plat- > samsung/include/plat/gpio-core.h > index e358c7d..c8681e0 100644 > --- a/arch/arm/plat-samsung/include/plat/gpio-core.h > +++ b/arch/arm/plat-samsung/include/plat/gpio-core.h > @@ -14,6 +14,12 @@ > #define GPIOCON_OFF (0x00) > #define GPIODAT_OFF (0x04) > > +#define S5P_GPIO_LEVEL_LOW (0x00) > +#define S5P_GPIO_LEVEL_HIGH (0x01) > +#define S5P_GPIO_EDGE_FALLING (0x02) > +#define S5P_GPIO_EDGE_RISING (0x03) > +#define S5P_GPIO_EDGE_BOTH (0x04) Why should we change the name of definition from S5P_EXTINT_XXX? If we use that, we don't need to change other files. > + > #define con_4bit_shift(__off) ((__off) * 4) > > /* Define the core gpiolib support functions that the s3c platforms may > -- Thanks. Best regards, Kgene. -- Kukjin Kim <kgene.kim@samsung.com>, Senior Engineer, SW Solution Development Team, Samsung Electronics Co., Ltd. ^ permalink raw reply [flat|nested] 10+ messages in thread
* [PATCH 1/3] ARM: Samsung S5P: Move the common Samsung S5P series GPIO level type 2010-08-30 12:01 ` Kukjin Kim @ 2010-08-30 13:35 ` Kyungmin Park -1 siblings, 0 replies; 10+ messages in thread From: Kyungmin Park @ 2010-08-30 13:35 UTC (permalink / raw) To: linux-arm-kernel On Mon, Aug 30, 2010 at 9:01 PM, Kukjin Kim <kgene.kim@samsung.com> wrote: > Kyungmin Park wrote: >> >> From: Kyungmin Park <kyungmin.park@samsung.com> >> >> Samsung S5P series has common level type. It's different from S3C series. >> >> Signed-off-by: Kyungmin Park <kyungmin.park@samsung.com> >> --- >> ?arch/arm/plat-samsung/include/plat/gpio-core.h | ? ?6 ++++++ >> ?1 files changed, 6 insertions(+), 0 deletions(-) >> >> diff --git a/arch/arm/plat-samsung/include/plat/gpio-core.h > b/arch/arm/plat- >> samsung/include/plat/gpio-core.h >> index e358c7d..c8681e0 100644 >> --- a/arch/arm/plat-samsung/include/plat/gpio-core.h >> +++ b/arch/arm/plat-samsung/include/plat/gpio-core.h >> @@ -14,6 +14,12 @@ >> ?#define GPIOCON_OFF ?(0x00) >> ?#define GPIODAT_OFF ?(0x04) >> >> +#define S5P_GPIO_LEVEL_LOW ? ? ? ? ? (0x00) >> +#define S5P_GPIO_LEVEL_HIGH ? ? ? ? ?(0x01) >> +#define S5P_GPIO_EDGE_FALLING ? ? ? ? ? ? ? ?(0x02) >> +#define S5P_GPIO_EDGE_RISING ? ? ? ? (0x03) >> +#define S5P_GPIO_EDGE_BOTH ? ? ? ? ? (0x04) > > Why should we change the name of definition from S5P_EXTINT_XXX? > If we use that, we don't need to change other files. External interrupt is one of GPIOs. and it's used for GPIO interrupt. Do you want to use the EXTINT at generic gpio function? Also change the name format as IRQ_TYPE_* style. Thank you, Kyungmin Park > >> + >> ?#define con_4bit_shift(__off) ((__off) * 4) >> >> ?/* Define the core gpiolib support functions that the s3c platforms may >> -- > > Thanks. > > Best regards, > Kgene. > -- > Kukjin Kim <kgene.kim@samsung.com>, Senior Engineer, > SW Solution Development Team, Samsung Electronics Co., Ltd. > > ^ permalink raw reply [flat|nested] 10+ messages in thread
* Re: [PATCH 1/3] ARM: Samsung S5P: Move the common Samsung S5P series GPIO level type @ 2010-08-30 13:35 ` Kyungmin Park 0 siblings, 0 replies; 10+ messages in thread From: Kyungmin Park @ 2010-08-30 13:35 UTC (permalink / raw) To: Kukjin Kim Cc: linux-arm-kernel, linux-kernel, jy0922.shim, m.szyprowski, ben-linux On Mon, Aug 30, 2010 at 9:01 PM, Kukjin Kim <kgene.kim@samsung.com> wrote: > Kyungmin Park wrote: >> >> From: Kyungmin Park <kyungmin.park@samsung.com> >> >> Samsung S5P series has common level type. It's different from S3C series. >> >> Signed-off-by: Kyungmin Park <kyungmin.park@samsung.com> >> --- >> arch/arm/plat-samsung/include/plat/gpio-core.h | 6 ++++++ >> 1 files changed, 6 insertions(+), 0 deletions(-) >> >> diff --git a/arch/arm/plat-samsung/include/plat/gpio-core.h > b/arch/arm/plat- >> samsung/include/plat/gpio-core.h >> index e358c7d..c8681e0 100644 >> --- a/arch/arm/plat-samsung/include/plat/gpio-core.h >> +++ b/arch/arm/plat-samsung/include/plat/gpio-core.h >> @@ -14,6 +14,12 @@ >> #define GPIOCON_OFF (0x00) >> #define GPIODAT_OFF (0x04) >> >> +#define S5P_GPIO_LEVEL_LOW (0x00) >> +#define S5P_GPIO_LEVEL_HIGH (0x01) >> +#define S5P_GPIO_EDGE_FALLING (0x02) >> +#define S5P_GPIO_EDGE_RISING (0x03) >> +#define S5P_GPIO_EDGE_BOTH (0x04) > > Why should we change the name of definition from S5P_EXTINT_XXX? > If we use that, we don't need to change other files. External interrupt is one of GPIOs. and it's used for GPIO interrupt. Do you want to use the EXTINT at generic gpio function? Also change the name format as IRQ_TYPE_* style. Thank you, Kyungmin Park > >> + >> #define con_4bit_shift(__off) ((__off) * 4) >> >> /* Define the core gpiolib support functions that the s3c platforms may >> -- > > Thanks. > > Best regards, > Kgene. > -- > Kukjin Kim <kgene.kim@samsung.com>, Senior Engineer, > SW Solution Development Team, Samsung Electronics Co., Ltd. > > ^ permalink raw reply [flat|nested] 10+ messages in thread
* [PATCH 1/3] ARM: Samsung S5P: Move the common Samsung S5P series GPIO level type 2010-08-30 13:35 ` Kyungmin Park @ 2010-09-01 0:36 ` Kukjin Kim -1 siblings, 0 replies; 10+ messages in thread From: Kukjin Kim @ 2010-09-01 0:36 UTC (permalink / raw) To: linux-arm-kernel Kyungmin Park wrote: > > On Mon, Aug 30, 2010 at 9:01 PM, Kukjin Kim <kgene.kim@samsung.com> wrote: > > Kyungmin Park wrote: > >> > >> From: Kyungmin Park <kyungmin.park@samsung.com> > >> > >> Samsung S5P series has common level type. It's different from S3C series. > >> > >> Signed-off-by: Kyungmin Park <kyungmin.park@samsung.com> > >> --- > >> ?arch/arm/plat-samsung/include/plat/gpio-core.h | ? ?6 ++++++ > >> ?1 files changed, 6 insertions(+), 0 deletions(-) > >> > >> diff --git a/arch/arm/plat-samsung/include/plat/gpio-core.h > > b/arch/arm/plat- > >> samsung/include/plat/gpio-core.h > >> index e358c7d..c8681e0 100644 > >> --- a/arch/arm/plat-samsung/include/plat/gpio-core.h > >> +++ b/arch/arm/plat-samsung/include/plat/gpio-core.h > >> @@ -14,6 +14,12 @@ > >> ?#define GPIOCON_OFF ?(0x00) > >> ?#define GPIODAT_OFF ?(0x04) > >> > >> +#define S5P_GPIO_LEVEL_LOW ? ? ? ? ? (0x00) > >> +#define S5P_GPIO_LEVEL_HIGH ? ? ? ? ?(0x01) > >> +#define S5P_GPIO_EDGE_FALLING ? ? ? ? ? ? ? ?(0x02) > >> +#define S5P_GPIO_EDGE_RISING ? ? ? ? (0x03) > >> +#define S5P_GPIO_EDGE_BOTH ? ? ? ? ? (0x04) > > > > Why should we change the name of definition from S5P_EXTINT_XXX? > > If we use that, we don't need to change other files. > > External interrupt is one of GPIOs. and it's used for GPIO interrupt. > Do you want to use the EXTINT at generic gpio function? > Right, it is one of the GPIO pin's usage. But it doesn't mean that should be used like/with generic GPIO... Even though the value of their polarity is same. Anyway,...let's think about that again. > Also change the name format as IRQ_TYPE_* style. > (snip) Thanks. Best regards, Kgene. -- Kukjin Kim <kgene.kim@samsung.com>, Senior Engineer, SW Solution Development Team, Samsung Electronics Co., Ltd. ^ permalink raw reply [flat|nested] 10+ messages in thread
* RE: [PATCH 1/3] ARM: Samsung S5P: Move the common Samsung S5P series GPIO level type @ 2010-09-01 0:36 ` Kukjin Kim 0 siblings, 0 replies; 10+ messages in thread From: Kukjin Kim @ 2010-09-01 0:36 UTC (permalink / raw) To: 'Kyungmin Park' Cc: linux-arm-kernel, linux-kernel, jy0922.shim, m.szyprowski, ben-linux Kyungmin Park wrote: > > On Mon, Aug 30, 2010 at 9:01 PM, Kukjin Kim <kgene.kim@samsung.com> wrote: > > Kyungmin Park wrote: > >> > >> From: Kyungmin Park <kyungmin.park@samsung.com> > >> > >> Samsung S5P series has common level type. It's different from S3C series. > >> > >> Signed-off-by: Kyungmin Park <kyungmin.park@samsung.com> > >> --- > >> arch/arm/plat-samsung/include/plat/gpio-core.h | 6 ++++++ > >> 1 files changed, 6 insertions(+), 0 deletions(-) > >> > >> diff --git a/arch/arm/plat-samsung/include/plat/gpio-core.h > > b/arch/arm/plat- > >> samsung/include/plat/gpio-core.h > >> index e358c7d..c8681e0 100644 > >> --- a/arch/arm/plat-samsung/include/plat/gpio-core.h > >> +++ b/arch/arm/plat-samsung/include/plat/gpio-core.h > >> @@ -14,6 +14,12 @@ > >> #define GPIOCON_OFF (0x00) > >> #define GPIODAT_OFF (0x04) > >> > >> +#define S5P_GPIO_LEVEL_LOW (0x00) > >> +#define S5P_GPIO_LEVEL_HIGH (0x01) > >> +#define S5P_GPIO_EDGE_FALLING (0x02) > >> +#define S5P_GPIO_EDGE_RISING (0x03) > >> +#define S5P_GPIO_EDGE_BOTH (0x04) > > > > Why should we change the name of definition from S5P_EXTINT_XXX? > > If we use that, we don't need to change other files. > > External interrupt is one of GPIOs. and it's used for GPIO interrupt. > Do you want to use the EXTINT at generic gpio function? > Right, it is one of the GPIO pin's usage. But it doesn't mean that should be used like/with generic GPIO... Even though the value of their polarity is same. Anyway,...let's think about that again. > Also change the name format as IRQ_TYPE_* style. > (snip) Thanks. Best regards, Kgene. -- Kukjin Kim <kgene.kim@samsung.com>, Senior Engineer, SW Solution Development Team, Samsung Electronics Co., Ltd. ^ permalink raw reply [flat|nested] 10+ messages in thread
end of thread, other threads:[~2010-09-01 0:36 UTC | newest] Thread overview: 10+ messages (download: mbox.gz follow: Atom feed -- links below jump to the message on this page -- 2010-08-30 11:47 [PATCH 1/3] ARM: Samsung S5P: Move the common Samsung S5P series GPIO level type Kyungmin Park 2010-08-30 11:47 ` Kyungmin Park 2010-08-30 11:59 ` Sergei Shtylyov 2010-08-30 11:59 ` Sergei Shtylyov 2010-08-30 12:01 ` Kukjin Kim 2010-08-30 12:01 ` Kukjin Kim 2010-08-30 13:35 ` Kyungmin Park 2010-08-30 13:35 ` Kyungmin Park 2010-09-01 0:36 ` Kukjin Kim 2010-09-01 0:36 ` Kukjin Kim
This is an external index of several public inboxes, see mirroring instructions on how to clone and mirror all data and code used by this external index.