All of lore.kernel.org
 help / color / mirror / Atom feed
From: Jesse Barnes <jbarnes@virtuousgeek.org>
To: Daniel Vetter <daniel@ffwll.ch>
Cc: intel-gfx@lists.freedesktop.org
Subject: Re: [PATCH 1/3] drm/i915: make DP configuration vars less confusing in ironlake_crtc_mode_se
Date: Wed, 11 Apr 2012 08:56:51 -0700	[thread overview]
Message-ID: <20120411085651.1d33be43@jbarnes-desktop> (raw)
In-Reply-To: <20120411095355.GB4296@phenom.ffwll.local>


[-- Attachment #1.1: Type: text/plain, Size: 1251 bytes --]

On Wed, 11 Apr 2012 11:53:55 +0200
Daniel Vetter <daniel@ffwll.ch> wrote:

> On Tue, Apr 10, 2012 at 10:22:09PM +0100, Chris Wilson wrote:
> > On Tue, 10 Apr 2012 11:58:03 -0700, Jesse Barnes <jbarnes@virtuousgeek.org> wrote:
> > > Both PCH and CPU eDP are DP, so set the is_dp flag to true.  Add
> > > is_cpu_edp and is_pch_edp bools to make checking for each less verbose
> > > (rather than has_edp_encoder && !intel_encoder_is_pch_edp() sprinkled
> > > everywhere).  And rename the "has_edp_encoder" variable to just
> > > "edp_encoder".
> > > 
> > > With the above variables cleaned up, the rest of the code becomes a bit
> > > more readable and clear.
> > > 
> > > Signed-off-by: Jesse Barnes <jbarnes@virtuousgeek.org>
> > 
> > Ok, that took quite a bit of reading to be sure that the changes were
> > consistent. Unfortunately it also looks to be in its simplest form.
> > 
> > Reviewed-by: Chris Wilson <chris@chris-wilson.co.uk>
> Queued for -next, thanks for the patch. I don't know what to do with the
> other two patches, are they supposed to be for -fixes?

I don't think they're urgent enough for -fixes.  They're still just
fixing issues on my IVB SDV.

-- 
Jesse Barnes, Intel Open Source Technology Center

[-- Attachment #1.2: signature.asc --]
[-- Type: application/pgp-signature, Size: 836 bytes --]

[-- Attachment #2: Type: text/plain, Size: 159 bytes --]

_______________________________________________
Intel-gfx mailing list
Intel-gfx@lists.freedesktop.org
http://lists.freedesktop.org/mailman/listinfo/intel-gfx

      reply	other threads:[~2012-04-11 15:56 UTC|newest]

Thread overview: 11+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2012-04-10 18:58 [PATCH 1/3] drm/i915: make DP configuration vars less confusing in ironlake_crtc_mode_se Jesse Barnes
2012-04-10 18:58 ` [PATCH 2/3] drm/i915: check PPS regs for sanity when using eDP Jesse Barnes
2012-04-10 18:59   ` Jesse Barnes
2012-04-10 21:26   ` Chris Wilson
2012-04-11 16:04     ` Daniel Vetter
2012-04-10 18:58 ` [PATCH 3/3] drm/i915: allow PCH PWM override on IVB Jesse Barnes
2012-04-10 21:50   ` Daniel Vetter
2012-04-10 22:00     ` Jesse Barnes
2012-04-10 21:22 ` [PATCH 1/3] drm/i915: make DP configuration vars less confusing in ironlake_crtc_mode_se Chris Wilson
2012-04-11  9:53   ` Daniel Vetter
2012-04-11 15:56     ` Jesse Barnes [this message]

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20120411085651.1d33be43@jbarnes-desktop \
    --to=jbarnes@virtuousgeek.org \
    --cc=daniel@ffwll.ch \
    --cc=intel-gfx@lists.freedesktop.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.