From: Andrea Arcangeli <aarcange@redhat.com>
To: Benjamin Herrenschmidt <benh@kernel.crashing.org>
Cc: "linux-kernel@vger.kernel.org" <linux-kernel@vger.kernel.org>,
"linux-mm@kvack.org" <linux-mm@kvack.org>,
Bhushan Bharat-R65777 <R65777@freescale.com>,
"linuxppc-dev@lists.ozlabs.org" <linuxppc-dev@lists.ozlabs.org>,
David Miller <davem@davemloft.net>
Subject: Re: [PATCH] powerpc: Fix assmption of end_of_DRAM() returns end address
Date: Wed, 6 Jun 2012 15:14:42 +0200 [thread overview]
Message-ID: <20120606131442.GN21339@redhat.com> (raw)
In-Reply-To: <1338960617.7150.163.camel@pasglop>
Hi,
On Wed, Jun 06, 2012 at 03:30:17PM +1000, Benjamin Herrenschmidt wrote:
> On Wed, 2012-06-06 at 00:46 +0000, Bhushan Bharat-R65777 wrote:
>
> > > >> memblock_end_of_DRAM() returns end_address + 1, not end address.
> > > >> While some code assumes that it returns end address.
> > > >
> > > > Shouldn't we instead fix it the other way around ? IE, make
> > > > memblock_end_of_DRAM() does what the name implies, which is to
> > return
> > > > the last byte of DRAM, and fix the -other- callers not to make bad
> > > > assumptions ?
> > >
> > > That was my impression too when I saw this patch.
> >
> > Initially I also intended to do so. I initiated a email on linux-mm@
> > subject "memblock_end_of_DRAM() return end address + 1" and the only
> > response I received from Andrea was:
> >
> > "
> > It's normal that "end" means "first byte offset out of the range". End
> > = not ok.
> > end = start+size.
> > This is true for vm_end too. So it's better to keep it that way.
> > My suggestion is to just fix point 1 below and audit the rest :)
> > "
>
> Oh well, I don't care enough to fight this battle in my current state so
I wish you to get well soon Ben!
> unless Dave has more stamina than I have today, I'm ok with the patch.
Well it doesn't really matter in the end what is decided as long as
something is decided :). I was asked through a forward so I only
expressed my preference...
WARNING: multiple messages have this Message-ID (diff)
From: Andrea Arcangeli <aarcange@redhat.com>
To: Benjamin Herrenschmidt <benh@kernel.crashing.org>
Cc: Bhushan Bharat-R65777 <R65777@freescale.com>,
David Miller <davem@davemloft.net>,
"linuxppc-dev@lists.ozlabs.org" <linuxppc-dev@lists.ozlabs.org>,
"linux-kernel@vger.kernel.org" <linux-kernel@vger.kernel.org>,
"galak@kernel.crashing.org" <galak@kernel.crashing.org>,
"linux-mm@kvack.org" <linux-mm@kvack.org>
Subject: Re: [PATCH] powerpc: Fix assmption of end_of_DRAM() returns end address
Date: Wed, 6 Jun 2012 15:14:42 +0200 [thread overview]
Message-ID: <20120606131442.GN21339@redhat.com> (raw)
In-Reply-To: <1338960617.7150.163.camel@pasglop>
Hi,
On Wed, Jun 06, 2012 at 03:30:17PM +1000, Benjamin Herrenschmidt wrote:
> On Wed, 2012-06-06 at 00:46 +0000, Bhushan Bharat-R65777 wrote:
>
> > > >> memblock_end_of_DRAM() returns end_address + 1, not end address.
> > > >> While some code assumes that it returns end address.
> > > >
> > > > Shouldn't we instead fix it the other way around ? IE, make
> > > > memblock_end_of_DRAM() does what the name implies, which is to
> > return
> > > > the last byte of DRAM, and fix the -other- callers not to make bad
> > > > assumptions ?
> > >
> > > That was my impression too when I saw this patch.
> >
> > Initially I also intended to do so. I initiated a email on linux-mm@
> > subject "memblock_end_of_DRAM() return end address + 1" and the only
> > response I received from Andrea was:
> >
> > "
> > It's normal that "end" means "first byte offset out of the range". End
> > = not ok.
> > end = start+size.
> > This is true for vm_end too. So it's better to keep it that way.
> > My suggestion is to just fix point 1 below and audit the rest :)
> > "
>
> Oh well, I don't care enough to fight this battle in my current state so
I wish you to get well soon Ben!
> unless Dave has more stamina than I have today, I'm ok with the patch.
Well it doesn't really matter in the end what is decided as long as
something is decided :). I was asked through a forward so I only
expressed my preference...
--
To unsubscribe, send a message with 'unsubscribe linux-mm' in
the body to majordomo@kvack.org. For more info on Linux MM,
see: http://www.linux-mm.org/ .
Fight unfair telecom internet charges in Canada: sign http://stopthemeter.ca/
Don't email: <a href=mailto:"dont@kvack.org"> email@kvack.org </a>
WARNING: multiple messages have this Message-ID (diff)
From: Andrea Arcangeli <aarcange@redhat.com>
To: Benjamin Herrenschmidt <benh@kernel.crashing.org>
Cc: Bhushan Bharat-R65777 <R65777@freescale.com>,
David Miller <davem@davemloft.net>,
"linuxppc-dev@lists.ozlabs.org" <linuxppc-dev@lists.ozlabs.org>,
"linux-kernel@vger.kernel.org" <linux-kernel@vger.kernel.org>,
"galak@kernel.crashing.org" <galak@kernel.crashing.org>,
"linux-mm@kvack.org" <linux-mm@kvack.org>
Subject: Re: [PATCH] powerpc: Fix assmption of end_of_DRAM() returns end address
Date: Wed, 6 Jun 2012 15:14:42 +0200 [thread overview]
Message-ID: <20120606131442.GN21339@redhat.com> (raw)
In-Reply-To: <1338960617.7150.163.camel@pasglop>
Hi,
On Wed, Jun 06, 2012 at 03:30:17PM +1000, Benjamin Herrenschmidt wrote:
> On Wed, 2012-06-06 at 00:46 +0000, Bhushan Bharat-R65777 wrote:
>
> > > >> memblock_end_of_DRAM() returns end_address + 1, not end address.
> > > >> While some code assumes that it returns end address.
> > > >
> > > > Shouldn't we instead fix it the other way around ? IE, make
> > > > memblock_end_of_DRAM() does what the name implies, which is to
> > return
> > > > the last byte of DRAM, and fix the -other- callers not to make bad
> > > > assumptions ?
> > >
> > > That was my impression too when I saw this patch.
> >
> > Initially I also intended to do so. I initiated a email on linux-mm@
> > subject "memblock_end_of_DRAM() return end address + 1" and the only
> > response I received from Andrea was:
> >
> > "
> > It's normal that "end" means "first byte offset out of the range". End
> > = not ok.
> > end = start+size.
> > This is true for vm_end too. So it's better to keep it that way.
> > My suggestion is to just fix point 1 below and audit the rest :)
> > "
>
> Oh well, I don't care enough to fight this battle in my current state so
I wish you to get well soon Ben!
> unless Dave has more stamina than I have today, I'm ok with the patch.
Well it doesn't really matter in the end what is decided as long as
something is decided :). I was asked through a forward so I only
expressed my preference...
next prev parent reply other threads:[~2012-06-06 13:14 UTC|newest]
Thread overview: 17+ messages / expand[flat|nested] mbox.gz Atom feed top
2012-06-05 13:55 [PATCH] powerpc: Fix assmption of end_of_DRAM() returns end address Bharat Bhushan
2012-06-05 22:17 ` Benjamin Herrenschmidt
2012-06-05 22:17 ` Benjamin Herrenschmidt
2012-06-05 22:20 ` David Miller
2012-06-05 22:20 ` David Miller
2012-06-06 0:46 ` Bhushan Bharat-R65777
2012-06-06 0:46 ` Bhushan Bharat-R65777
2012-06-06 0:46 ` Bhushan Bharat-R65777
2012-06-06 5:30 ` Benjamin Herrenschmidt
2012-06-06 5:30 ` Benjamin Herrenschmidt
2012-06-06 5:30 ` Benjamin Herrenschmidt
2012-06-06 13:14 ` Andrea Arcangeli [this message]
2012-06-06 13:14 ` Andrea Arcangeli
2012-06-06 13:14 ` Andrea Arcangeli
2012-06-06 16:03 ` David Miller
2012-06-06 16:03 ` David Miller
2012-06-06 16:03 ` David Miller
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20120606131442.GN21339@redhat.com \
--to=aarcange@redhat.com \
--cc=R65777@freescale.com \
--cc=benh@kernel.crashing.org \
--cc=davem@davemloft.net \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-mm@kvack.org \
--cc=linuxppc-dev@lists.ozlabs.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.