From: Steffen Trumtrar <s.trumtrar@pengutronix.de>
To: Rob Clark <robdclark@gmail.com>
Cc: devicetree-discuss@lists.ozlabs.org,
David Airlie <airlied@linux.ie>,
Rob Herring <robherring2@gmail.com>,
linux-fbdev@vger.kernel.org, dri-devel@lists.freedesktop.org,
Laurent Pinchart <laurent.pinchart@ideasonboard.com>,
Thierry Reding <thierry.reding@avionic-design.de>,
Guennady Liakhovetski <g.liakhovetski@gmx.de>,
linux-media@vger.kernel.org,
Tomi Valkeinen <tomi.valkeinen@ti.com>,
Stephen Warren <swarren@wwwdotorg.org>,
Florian Tobias Schandinat <FlorianSchandinat@gmx.de>,
Leela Krishna Amudala <leelakrishna.a@gmail.com>,
"Mohammed, Afzal" <afzal@ti.com>,
kernel@pengutronix.de
Subject: Re: [PATCH v16 RESEND 0/7] of: add display helper
Date: Wed, 23 Jan 2013 09:12:02 +0000 [thread overview]
Message-ID: <20130123091202.GA11828@pengutronix.de> (raw)
In-Reply-To: <CAF6AEGvFNA1gc_5XWqL_baEnn8DTn0R-xqui034rg3Eo-V_6Qw@mail.gmail.com>
On Tue, Jan 22, 2013 at 03:50:48PM -0600, Rob Clark wrote:
> On Mon, Jan 21, 2013 at 5:07 AM, Steffen Trumtrar
> <s.trumtrar@pengutronix.de> wrote:
> > Hi!
> >
> > There was still no maintainer, that commented, ack'd, nack'd, apply'd the
> > series. So, this is just a resend.
> > The patches were tested with:
> >
> > - v15 on Tegra by Thierry
> > - sh-mobile-lcdcfb by Laurent
> > - MX53QSB by Marek
> > - Exynos: smdk5250 by Leela
> > - AM335X EVM & AM335X EVM-SK by Afzal
> > - imx6q: sabrelite, sabresd by Philipp and me
> > - imx53: tqma53/mba53 by me
>
>
> btw, you can add my tested-by for this series.. I've been using them
> for the tilcdc lcd-panel output driver support.
>
Thanks. The more drivers the merrier ;-)
Steffen
> >
> >
> > Changes since v15:
> > - move include/linux/{videomode,display_timing}.h to include/video
> > - move include/linux/of_{videomode,display_timing}.h to include/video
> > - reimplement flags: add VESA flags and data flags
> > - let pixelclock in struct videomode be unsigned long
> > - rename of_display_timings_exists to of_display_timings_exist
> > - revise logging/error messages: replace __func__ with np->full_name
> > - rename pixelclk-inverted to pixelclk-active
> > - revise comments in code
> >
> > Changes since v14:
> > - fix "const struct *" warning
> > (reported by: Leela Krishna Amudala <l.krishna@samsung.com>)
> > - return -EINVAL when htotal or vtotal are zero
> > - remove unreachable code in of_get_display_timings
> > - include headers in .c files and not implicit in .h
> > - sort includes alphabetically
> > - fix lower/uppercase in binding documentation
> > - rebase onto v3.7-rc7
> >
> > Changes since v13:
> > - fix "const struct *" warning
> > (reported by: Laurent Pinchart <laurent.pinchart@ideasonboard.com>)
> > - prevent division by zero in fb_videomode_from_videomode
> >
> > Changes since v12:
> > - rename struct display_timing to via_display_timing in via subsystem
> > - fix refreshrate calculation
> > - fix "const struct *" warnings
> > (reported by: Manjunathappa, Prakash <prakash.pm@ti.com>)
> > - some CodingStyle fixes
> > - rewrite parts of commit messages and display-timings.txt
> > - let display_timing_get_value get all values instead of just typical
> >
> > Changes since v11:
> > - make pointers const where applicable
> > - add reviewed-by Laurent Pinchart
> >
> > Changes since v10:
> > - fix function name (drm_)display_mode_from_videomode
> > - add acked-by, reviewed-by, tested-by
> >
> > Changes since v9:
> > - don't leak memory when previous timings were correct
> > - CodingStyle fixes
> > - move blank lines around
> >
> > Changes since v8:
> > - fix memory leaks
> > - change API to be more consistent (foo_from_bar(struct bar, struct foo))
> > - include headers were necessary
> > - misc minor bugfixes
> >
> > Changes since v7:
> > - move of_xxx to drivers/video
> > - remove non-binding documentation from display-timings.txt
> > - squash display_timings and videomode in one patch
> > - misc minor fixes
> >
> > Changes since v6:
> > - get rid of some empty lines etc.
> > - move functions to their subsystems
> > - split of_ from non-of_ functions
> > - add at least some kerneldoc to some functions
> >
> > Changes since v5:
> > - removed all display stuff and just describe timings
> >
> > Changes since v4:
> > - refactored functions
> >
> > Changes since v3:
> > - print error messages
> > - free alloced memory
> > - general cleanup
> >
> > Changes since v2:
> > - use hardware-near property-names
> > - provide a videomode structure
> > - allow ranges for all properties (<min,typ,max>)
> > - functions to get display_mode or fb_videomode
> >
> >
> > Regards,
> > Steffen
> >
> >
> > Steffen Trumtrar (7):
> > viafb: rename display_timing to via_display_timing
> > video: add display_timing and videomode
> > video: add of helper for display timings/videomode
> > fbmon: add videomode helpers
> > fbmon: add of_videomode helpers
> > drm_modes: add videomode helpers
> > drm_modes: add of_videomode helpers
> >
> > .../devicetree/bindings/video/display-timing.txt | 109 +++++++++
> > drivers/gpu/drm/drm_modes.c | 70 ++++++
> > drivers/video/Kconfig | 21 ++
> > drivers/video/Makefile | 4 +
> > drivers/video/display_timing.c | 24 ++
> > drivers/video/fbmon.c | 94 ++++++++
> > drivers/video/of_display_timing.c | 239 ++++++++++++++++++++
> > drivers/video/of_videomode.c | 54 +++++
> > drivers/video/via/hw.c | 6 +-
> > drivers/video/via/hw.h | 2 +-
> > drivers/video/via/lcd.c | 2 +-
> > drivers/video/via/share.h | 2 +-
> > drivers/video/via/via_modesetting.c | 8 +-
> > drivers/video/via/via_modesetting.h | 6 +-
> > drivers/video/videomode.c | 39 ++++
> > include/drm/drmP.h | 9 +
> > include/linux/fb.h | 8 +
> > include/video/display_timing.h | 124 ++++++++++
> > include/video/of_display_timing.h | 20 ++
> > include/video/of_videomode.h | 18 ++
> > include/video/videomode.h | 48 ++++
> > 21 files changed, 894 insertions(+), 13 deletions(-)
> > create mode 100644 Documentation/devicetree/bindings/video/display-timing.txt
> > create mode 100644 drivers/video/display_timing.c
> > create mode 100644 drivers/video/of_display_timing.c
> > create mode 100644 drivers/video/of_videomode.c
> > create mode 100644 drivers/video/videomode.c
> > create mode 100644 include/video/display_timing.h
> > create mode 100644 include/video/of_display_timing.h
> > create mode 100644 include/video/of_videomode.h
> > create mode 100644 include/video/videomode.h
> >
> > --
> > 1.7.10.4
> >
>
--
Pengutronix e.K. | |
Industrial Linux Solutions | http://www.pengutronix.de/ |
Peiner Str. 6-8, 31137 Hildesheim, Germany | Phone: +49-5121-206917-0 |
Amtsgericht Hildesheim, HRA 2686 | Fax: +49-5121-206917-5555 |
WARNING: multiple messages have this Message-ID (diff)
From: Steffen Trumtrar <s.trumtrar@pengutronix.de>
To: Rob Clark <robdclark@gmail.com>
Cc: devicetree-discuss@lists.ozlabs.org,
David Airlie <airlied@linux.ie>,
Rob Herring <robherring2@gmail.com>,
linux-fbdev@vger.kernel.org, dri-devel@lists.freedesktop.org,
Laurent Pinchart <laurent.pinchart@ideasonboard.com>,
Thierry Reding <thierry.reding@avionic-design.de>,
Guennady Liakhovetski <g.liakhovetski@gmx.de>,
linux-media@vger.kernel.org,
Tomi Valkeinen <tomi.valkeinen@ti.com>,
Stephen Warren <swarren@wwwdotorg.org>,
Florian Tobias Schandinat <FlorianSchandinat@gmx.de>,
Leela Krishna Amudala <leelakrishna.a@gmail.com>,
"Mohammed, Afzal" <afzal@ti.com>,
kernel@pengutronix.de
Subject: Re: [PATCH v16 RESEND 0/7] of: add display helper
Date: Wed, 23 Jan 2013 10:12:02 +0100 [thread overview]
Message-ID: <20130123091202.GA11828@pengutronix.de> (raw)
In-Reply-To: <CAF6AEGvFNA1gc_5XWqL_baEnn8DTn0R-xqui034rg3Eo-V_6Qw@mail.gmail.com>
On Tue, Jan 22, 2013 at 03:50:48PM -0600, Rob Clark wrote:
> On Mon, Jan 21, 2013 at 5:07 AM, Steffen Trumtrar
> <s.trumtrar@pengutronix.de> wrote:
> > Hi!
> >
> > There was still no maintainer, that commented, ack'd, nack'd, apply'd the
> > series. So, this is just a resend.
> > The patches were tested with:
> >
> > - v15 on Tegra by Thierry
> > - sh-mobile-lcdcfb by Laurent
> > - MX53QSB by Marek
> > - Exynos: smdk5250 by Leela
> > - AM335X EVM & AM335X EVM-SK by Afzal
> > - imx6q: sabrelite, sabresd by Philipp and me
> > - imx53: tqma53/mba53 by me
>
>
> btw, you can add my tested-by for this series.. I've been using them
> for the tilcdc lcd-panel output driver support.
>
Thanks. The more drivers the merrier ;-)
Steffen
> >
> >
> > Changes since v15:
> > - move include/linux/{videomode,display_timing}.h to include/video
> > - move include/linux/of_{videomode,display_timing}.h to include/video
> > - reimplement flags: add VESA flags and data flags
> > - let pixelclock in struct videomode be unsigned long
> > - rename of_display_timings_exists to of_display_timings_exist
> > - revise logging/error messages: replace __func__ with np->full_name
> > - rename pixelclk-inverted to pixelclk-active
> > - revise comments in code
> >
> > Changes since v14:
> > - fix "const struct *" warning
> > (reported by: Leela Krishna Amudala <l.krishna@samsung.com>)
> > - return -EINVAL when htotal or vtotal are zero
> > - remove unreachable code in of_get_display_timings
> > - include headers in .c files and not implicit in .h
> > - sort includes alphabetically
> > - fix lower/uppercase in binding documentation
> > - rebase onto v3.7-rc7
> >
> > Changes since v13:
> > - fix "const struct *" warning
> > (reported by: Laurent Pinchart <laurent.pinchart@ideasonboard.com>)
> > - prevent division by zero in fb_videomode_from_videomode
> >
> > Changes since v12:
> > - rename struct display_timing to via_display_timing in via subsystem
> > - fix refreshrate calculation
> > - fix "const struct *" warnings
> > (reported by: Manjunathappa, Prakash <prakash.pm@ti.com>)
> > - some CodingStyle fixes
> > - rewrite parts of commit messages and display-timings.txt
> > - let display_timing_get_value get all values instead of just typical
> >
> > Changes since v11:
> > - make pointers const where applicable
> > - add reviewed-by Laurent Pinchart
> >
> > Changes since v10:
> > - fix function name (drm_)display_mode_from_videomode
> > - add acked-by, reviewed-by, tested-by
> >
> > Changes since v9:
> > - don't leak memory when previous timings were correct
> > - CodingStyle fixes
> > - move blank lines around
> >
> > Changes since v8:
> > - fix memory leaks
> > - change API to be more consistent (foo_from_bar(struct bar, struct foo))
> > - include headers were necessary
> > - misc minor bugfixes
> >
> > Changes since v7:
> > - move of_xxx to drivers/video
> > - remove non-binding documentation from display-timings.txt
> > - squash display_timings and videomode in one patch
> > - misc minor fixes
> >
> > Changes since v6:
> > - get rid of some empty lines etc.
> > - move functions to their subsystems
> > - split of_ from non-of_ functions
> > - add at least some kerneldoc to some functions
> >
> > Changes since v5:
> > - removed all display stuff and just describe timings
> >
> > Changes since v4:
> > - refactored functions
> >
> > Changes since v3:
> > - print error messages
> > - free alloced memory
> > - general cleanup
> >
> > Changes since v2:
> > - use hardware-near property-names
> > - provide a videomode structure
> > - allow ranges for all properties (<min,typ,max>)
> > - functions to get display_mode or fb_videomode
> >
> >
> > Regards,
> > Steffen
> >
> >
> > Steffen Trumtrar (7):
> > viafb: rename display_timing to via_display_timing
> > video: add display_timing and videomode
> > video: add of helper for display timings/videomode
> > fbmon: add videomode helpers
> > fbmon: add of_videomode helpers
> > drm_modes: add videomode helpers
> > drm_modes: add of_videomode helpers
> >
> > .../devicetree/bindings/video/display-timing.txt | 109 +++++++++
> > drivers/gpu/drm/drm_modes.c | 70 ++++++
> > drivers/video/Kconfig | 21 ++
> > drivers/video/Makefile | 4 +
> > drivers/video/display_timing.c | 24 ++
> > drivers/video/fbmon.c | 94 ++++++++
> > drivers/video/of_display_timing.c | 239 ++++++++++++++++++++
> > drivers/video/of_videomode.c | 54 +++++
> > drivers/video/via/hw.c | 6 +-
> > drivers/video/via/hw.h | 2 +-
> > drivers/video/via/lcd.c | 2 +-
> > drivers/video/via/share.h | 2 +-
> > drivers/video/via/via_modesetting.c | 8 +-
> > drivers/video/via/via_modesetting.h | 6 +-
> > drivers/video/videomode.c | 39 ++++
> > include/drm/drmP.h | 9 +
> > include/linux/fb.h | 8 +
> > include/video/display_timing.h | 124 ++++++++++
> > include/video/of_display_timing.h | 20 ++
> > include/video/of_videomode.h | 18 ++
> > include/video/videomode.h | 48 ++++
> > 21 files changed, 894 insertions(+), 13 deletions(-)
> > create mode 100644 Documentation/devicetree/bindings/video/display-timing.txt
> > create mode 100644 drivers/video/display_timing.c
> > create mode 100644 drivers/video/of_display_timing.c
> > create mode 100644 drivers/video/of_videomode.c
> > create mode 100644 drivers/video/videomode.c
> > create mode 100644 include/video/display_timing.h
> > create mode 100644 include/video/of_display_timing.h
> > create mode 100644 include/video/of_videomode.h
> > create mode 100644 include/video/videomode.h
> >
> > --
> > 1.7.10.4
> >
>
--
Pengutronix e.K. | |
Industrial Linux Solutions | http://www.pengutronix.de/ |
Peiner Str. 6-8, 31137 Hildesheim, Germany | Phone: +49-5121-206917-0 |
Amtsgericht Hildesheim, HRA 2686 | Fax: +49-5121-206917-5555 |
next prev parent reply other threads:[~2013-01-23 9:12 UTC|newest]
Thread overview: 35+ messages / expand[flat|nested] mbox.gz Atom feed top
2013-01-21 11:07 [PATCH v16 RESEND 0/7] of: add display helper Steffen Trumtrar
2013-01-21 11:07 ` Steffen Trumtrar
2013-01-21 11:07 ` [PATCH v16 RESEND 1/7] viafb: rename display_timing to via_display_timing Steffen Trumtrar
2013-01-21 11:07 ` Steffen Trumtrar
2013-01-21 11:07 ` [PATCH v16 RESEND 2/7] video: add display_timing and videomode Steffen Trumtrar
2013-01-21 11:07 ` Steffen Trumtrar
2013-01-21 11:07 ` =?UTF-8?q?=5BPATCH=20v16=20RESEND=203/7=5D=20video=3A=20add=20of=20helper=20for=20display=20timings/ Steffen Trumtrar
2013-01-21 11:07 ` [PATCH v16 RESEND 3/7] video: add of helper for display timings/videomode Steffen Trumtrar
2013-01-21 11:07 ` [PATCH v16 RESEND 4/7] fbmon: add videomode helpers Steffen Trumtrar
2013-01-21 11:07 ` Steffen Trumtrar
2013-01-21 11:08 ` [PATCH v16 RESEND 5/7] fbmon: add of_videomode helpers Steffen Trumtrar
2013-01-21 11:08 ` Steffen Trumtrar
2013-01-21 11:08 ` [PATCH v16 RESEND 6/7] drm_modes: add videomode helpers Steffen Trumtrar
2013-01-21 11:08 ` Steffen Trumtrar
2013-01-21 11:08 ` [PATCH v16 RESEND 7/7] drm_modes: add of_videomode helpers Steffen Trumtrar
2013-01-21 11:08 ` Steffen Trumtrar
2013-01-22 21:50 ` [PATCH v16 RESEND 0/7] of: add display helper Rob Clark
2013-01-22 21:50 ` Rob Clark
2013-01-23 9:12 ` Steffen Trumtrar [this message]
2013-01-23 9:12 ` Steffen Trumtrar
2013-01-24 0:15 ` Dave Airlie
2013-01-24 0:15 ` Dave Airlie
2013-01-24 7:56 ` Steffen Trumtrar
2013-01-24 7:56 ` Steffen Trumtrar
[not found] ` <20130123091202.GA11828-bIcnvbaLZ9MEGnE8C9+IrQ@public.gmane.org>
2013-01-24 5:14 ` Leela Krishna Amudala
2013-01-24 5:26 ` Leela Krishna Amudala
2013-01-24 5:14 ` Leela Krishna Amudala
2013-01-24 8:19 ` Steffen Trumtrar
2013-01-24 8:19 ` Steffen Trumtrar
2013-01-24 8:47 ` Mohammed, Afzal
2013-01-24 8:47 ` Mohammed, Afzal
2013-01-25 8:04 ` Steffen Trumtrar
2013-01-25 8:04 ` Steffen Trumtrar
2013-02-01 7:40 ` Jingoo Han
2013-02-01 7:40 ` Jingoo Han
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20130123091202.GA11828@pengutronix.de \
--to=s.trumtrar@pengutronix.de \
--cc=FlorianSchandinat@gmx.de \
--cc=afzal@ti.com \
--cc=airlied@linux.ie \
--cc=devicetree-discuss@lists.ozlabs.org \
--cc=dri-devel@lists.freedesktop.org \
--cc=g.liakhovetski@gmx.de \
--cc=kernel@pengutronix.de \
--cc=laurent.pinchart@ideasonboard.com \
--cc=leelakrishna.a@gmail.com \
--cc=linux-fbdev@vger.kernel.org \
--cc=linux-media@vger.kernel.org \
--cc=robdclark@gmail.com \
--cc=robherring2@gmail.com \
--cc=swarren@wwwdotorg.org \
--cc=thierry.reding@avionic-design.de \
--cc=tomi.valkeinen@ti.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.