From: Daniel Vetter <daniel@ffwll.ch>
To: Chris Wilson <chris@chris-wilson.co.uk>,
jeff.mcgee@intel.com, intel-gfx@lists.freedesktop.org
Subject: Re: [PATCH 0/5] Add power feature debugfs disabling
Date: Tue, 4 Feb 2014 12:33:28 +0100 [thread overview]
Message-ID: <20140204113328.GP17001@phenom.ffwll.local> (raw)
In-Reply-To: <20140201171422.GZ29091@nuc-i3427.alporthouse.com>
On Sat, Feb 01, 2014 at 05:14:22PM +0000, Chris Wilson wrote:
> On Fri, Jan 31, 2014 at 03:42:47PM -0600, jeff.mcgee@intel.com wrote:
> > From: Jeff McGee <jeff.mcgee@intel.com>
> >
> > This series has recently been accepted into the Haswell Android kernel and
> > helps with debugging and profiling these power features. I would like it
> > to be considered for upstream incorporation. The patches here have been
> > rebased (minimal changes required) and compile-tested only.
> >
> > Broad device support is provided, accept for RPS and RC6 with Broadwell
> > and Valleyview. Both of these were somewhat of a moving target and I
> > didn't have devices to work with. Support can of course be added with
> > help from appropriate folks.
> >
> > The hooks introduce some amount of overhead as an additional check is
> > often needed to determine whether the feature is on or off - similar to
> > the module parameters that already exist. I felt that the overhead was
> > minimal enough and didn't want to ugly up the code with CONFIG_DEBUG_FS
> > compile conditionals. But I'm open to the list's thoughts on this.
> >
> > IGT tests of these new interfaces can certainly be added. I wanted to
> > make sure there was sufficient interest in having these interfaces before
> > starting on the tests. So please provide feedback.
>
> I can see the value of adding this for power testing and the code looks
> quite neat and self-contained. (The one bikeshed I have is that I would
> like the parameter check and debug.disable check combined into a single
> function call, similar to intel_enable_rc6() so that all the similar
> logic is together, well commented and easy to verify, and hard for
> callers to get wrong.) Longer term, should we not consider this for
> our /sys/drm/card0/power API? i.e. do we see value beyond debugging and
> testing?
For fbc/psr/ips I'd even use a connector/crtc property if we really need
to frob this. Would be a good excuse for some better kms cmdline
utilities ...
-Daniel
--
Daniel Vetter
Software Engineer, Intel Corporation
+41 (0) 79 365 57 48 - http://blog.ffwll.ch
next prev parent reply other threads:[~2014-02-04 11:33 UTC|newest]
Thread overview: 15+ messages / expand[flat|nested] mbox.gz Atom feed top
2014-01-31 21:42 [PATCH 0/5] Add power feature debugfs disabling jeff.mcgee
2014-01-31 21:42 ` [PATCH 1/5] drm/i915: Add RPS debugfs manual mode jeff.mcgee
2014-02-04 11:31 ` Daniel Vetter
2014-02-04 11:40 ` Chris Wilson
2014-02-04 16:04 ` Jeff McGee
2014-01-31 21:42 ` [PATCH 2/5] drm/i915: Add RC6 debugfs disabling jeff.mcgee
2014-01-31 21:42 ` [PATCH 3/5] drm/i915: Add IPS " jeff.mcgee
2014-01-31 21:42 ` [PATCH 4/5] drm/i915: Add FBC " jeff.mcgee
2014-01-31 21:42 ` [PATCH 5/5] drm/i915: Add CxSR " jeff.mcgee
2014-02-01 17:14 ` [PATCH 0/5] Add power feature " Chris Wilson
2014-02-04 11:33 ` Daniel Vetter [this message]
2014-02-04 11:30 ` Daniel Vetter
2014-02-06 15:44 ` Jeff McGee
2014-02-06 16:37 ` Daniel Vetter
2014-02-07 16:43 ` Jeff McGee
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20140204113328.GP17001@phenom.ffwll.local \
--to=daniel@ffwll.ch \
--cc=chris@chris-wilson.co.uk \
--cc=intel-gfx@lists.freedesktop.org \
--cc=jeff.mcgee@intel.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.