From: Brian Norris <computersforpeace@gmail.com>
To: Rob Herring <robh+dt@kernel.org>, Pawel Moll <pawel.moll@arm.com>,
Mark Rutland <mark.rutland@arm.com>,
Ian Campbell <ijc+devicetree@hellion.org.uk>,
Kumar Gala <galak@codeaurora.org>
Cc: "Marek Vasut" <marex@denx.de>,
devicetree@vger.kernel.org,
"Stephen Warren" <swarren@wwwdotorg.org>,
"Rafał Miłecki" <zajec5@gmail.com>,
linux-kernel@vger.kernel.org, linux-mtd@lists.infradead.org,
"Geert Uytterhoeven" <geert@linux-m68k.org>
Subject: Re: [PATCH] Documentation: dt: mtd: replace "nor-jedec" binding with "jedec,spi-nor"
Date: Fri, 15 May 2015 12:55:41 -0700 [thread overview]
Message-ID: <20150515195541.GL11598@ld-irv-0074> (raw)
In-Reply-To: <1431624773-4165-1-git-send-email-computersforpeace@gmail.com>
It really helps if I test patches...
On Thu, May 14, 2015 at 10:32:53AM -0700, Brian Norris wrote:
> In commit 8ff16cf77ce3 ("Documentation: devicetree: m25p80: add "nor-jedec"
> binding"), we added a generic "nor-jedec" binding to catch all
> mostly-compatible SPI NOR flash which can be detected via the READ ID
> opcode (0x9F). This was discussed and reviewed at the time, however
> objections have come up since then as part of this discussion:
>
> http://lkml.kernel.org/g/20150511224646.GJ32500@ld-irv-0074
>
> It seems the parties involved agree that "jedec,spi-nor" does a better
> job of capturing the fact that this is SPI-specific, not just any NOR
> flash.
>
> This binding was only merged for v4.1-rc1, so it's still OK to change
> the naming.
>
> At the same time, let's move the documentation to a better name.
>
> Next up: prune the m25p_ids[] table to the minimal necessary listing, so
> we can stop referring to code (drivers/mtd/devices/m25p80.c) from the
> documentation.
>
> Signed-off-by: Brian Norris <computersforpeace@gmail.com>
> Cc: Stephen Warren <swarren@wwwdotorg.org>
> Cc: Geert Uytterhoeven <geert@linux-m68k.org>
> Cc: Marek Vasut <marex@denx.de>
> Cc: Rafał Miłecki <zajec5@gmail.com>
> Cc: Rob Herring <robh+dt@kernel.org>
> Cc: Pawel Moll <pawel.moll@arm.com>
> Cc: Mark Rutland <mark.rutland@arm.com>
> Cc: Ian Campbell <ijc+devicetree@hellion.org.uk>
> Cc: Kumar Gala <galak@codeaurora.org>
> Cc: devicetree@vger.kernel.org
> ---
> I'd *really* like to get an 'ack' from a DT maintainer for this, those those
> are apparently very hard to come by. And I'd really not like to have to revisit
> this again in a few weeks. We have patches getting queued up for 4.2 that are
> using the "nor-jedec" binding, and I'd like to nip those in the bud ASAP.
>
> .../devicetree/bindings/mtd/{m25p80.txt => jedec,spi-nor.txt} | 6 +++---
> drivers/mtd/devices/m25p80.c | 6 +++---
> 2 files changed, 6 insertions(+), 6 deletions(-)
> rename Documentation/devicetree/bindings/mtd/{m25p80.txt => jedec,spi-nor.txt} (85%)
>
...
> diff --git a/drivers/mtd/devices/m25p80.c b/drivers/mtd/devices/m25p80.c
> index 7c8b1694a134..3d59ebc16b6e 100644
> --- a/drivers/mtd/devices/m25p80.c
> +++ b/drivers/mtd/devices/m25p80.c
> @@ -223,7 +223,7 @@ static int m25p_probe(struct spi_device *spi)
> */
> if (data && data->type)
> flash_name = data->type;
> - else if (!strcmp(spi->modalias, "nor-jedec"))
> + else if (!strcmp(spi->modalias, "jedec,spi-nor"))
> flash_name = NULL; /* auto-detect */
> else
> flash_name = spi->modalias;
> @@ -255,7 +255,7 @@ static int m25p_remove(struct spi_device *spi)
> * since most of these flash are compatible to some extent, and their
> * differences can often be differentiated by the JEDEC read-ID command, we
> * encourage new users to add support to the spi-nor library, and simply bind
> - * against a generic string here (e.g., "nor-jedec").
> + * against a generic string here (e.g., "jedec,spi-nor").
> *
> * Many flash names are kept here in this list (as well as in spi-nor.c) to
> * keep them available as module aliases for existing platforms.
> @@ -305,7 +305,7 @@ static const struct spi_device_id m25p_ids[] = {
> * Generic support for SPI NOR that can be identified by the JEDEC READ
> * ID opcode (0x9F). Use this, if possible.
> */
> - {"nor-jedec"},
> + {"jedec,spi-nor"},
So I forgot (again; we hit this before) that the SPI/OF framework strips
everything before the first comma before binding devices. See
of_modalias_node(). So I'll have to squash in the patch below to get a
usable binding.
> { },
> };
> MODULE_DEVICE_TABLE(spi, m25p_ids);
This patch will make the code bind against anything like
"<foo>,spi-nor", but we'll leave the comment to recommend
using "jedec,spi-nor".
Signed-off-by: Brian Norris <computersforpeace@gmail.com>
diff --git a/drivers/mtd/devices/m25p80.c b/drivers/mtd/devices/m25p80.c
index 3d59ebc16b6e..3af137f49ac9 100644
--- a/drivers/mtd/devices/m25p80.c
+++ b/drivers/mtd/devices/m25p80.c
@@ -223,7 +223,7 @@ static int m25p_probe(struct spi_device *spi)
*/
if (data && data->type)
flash_name = data->type;
- else if (!strcmp(spi->modalias, "jedec,spi-nor"))
+ else if (!strcmp(spi->modalias, "spi-nor"))
flash_name = NULL; /* auto-detect */
else
flash_name = spi->modalias;
@@ -305,7 +305,7 @@ static const struct spi_device_id m25p_ids[] = {
* Generic support for SPI NOR that can be identified by the JEDEC READ
* ID opcode (0x9F). Use this, if possible.
*/
- {"jedec,spi-nor"},
+ {"spi-nor"},
{ },
};
MODULE_DEVICE_TABLE(spi, m25p_ids);
WARNING: multiple messages have this Message-ID (diff)
From: Brian Norris <computersforpeace@gmail.com>
To: Rob Herring <robh+dt@kernel.org>, Pawel Moll <pawel.moll@arm.com>,
Mark Rutland <mark.rutland@arm.com>,
Ian Campbell <ijc+devicetree@hellion.org.uk>,
Kumar Gala <galak@codeaurora.org>
Cc: linux-mtd@lists.infradead.org, devicetree@vger.kernel.org,
linux-kernel@vger.kernel.org,
"Stephen Warren" <swarren@wwwdotorg.org>,
"Geert Uytterhoeven" <geert@linux-m68k.org>,
"Marek Vasut" <marex@denx.de>, "Rafał Miłecki" <zajec5@gmail.com>
Subject: Re: [PATCH] Documentation: dt: mtd: replace "nor-jedec" binding with "jedec,spi-nor"
Date: Fri, 15 May 2015 12:55:41 -0700 [thread overview]
Message-ID: <20150515195541.GL11598@ld-irv-0074> (raw)
In-Reply-To: <1431624773-4165-1-git-send-email-computersforpeace@gmail.com>
It really helps if I test patches...
On Thu, May 14, 2015 at 10:32:53AM -0700, Brian Norris wrote:
> In commit 8ff16cf77ce3 ("Documentation: devicetree: m25p80: add "nor-jedec"
> binding"), we added a generic "nor-jedec" binding to catch all
> mostly-compatible SPI NOR flash which can be detected via the READ ID
> opcode (0x9F). This was discussed and reviewed at the time, however
> objections have come up since then as part of this discussion:
>
> http://lkml.kernel.org/g/20150511224646.GJ32500@ld-irv-0074
>
> It seems the parties involved agree that "jedec,spi-nor" does a better
> job of capturing the fact that this is SPI-specific, not just any NOR
> flash.
>
> This binding was only merged for v4.1-rc1, so it's still OK to change
> the naming.
>
> At the same time, let's move the documentation to a better name.
>
> Next up: prune the m25p_ids[] table to the minimal necessary listing, so
> we can stop referring to code (drivers/mtd/devices/m25p80.c) from the
> documentation.
>
> Signed-off-by: Brian Norris <computersforpeace@gmail.com>
> Cc: Stephen Warren <swarren@wwwdotorg.org>
> Cc: Geert Uytterhoeven <geert@linux-m68k.org>
> Cc: Marek Vasut <marex@denx.de>
> Cc: Rafał Miłecki <zajec5@gmail.com>
> Cc: Rob Herring <robh+dt@kernel.org>
> Cc: Pawel Moll <pawel.moll@arm.com>
> Cc: Mark Rutland <mark.rutland@arm.com>
> Cc: Ian Campbell <ijc+devicetree@hellion.org.uk>
> Cc: Kumar Gala <galak@codeaurora.org>
> Cc: devicetree@vger.kernel.org
> ---
> I'd *really* like to get an 'ack' from a DT maintainer for this, those those
> are apparently very hard to come by. And I'd really not like to have to revisit
> this again in a few weeks. We have patches getting queued up for 4.2 that are
> using the "nor-jedec" binding, and I'd like to nip those in the bud ASAP.
>
> .../devicetree/bindings/mtd/{m25p80.txt => jedec,spi-nor.txt} | 6 +++---
> drivers/mtd/devices/m25p80.c | 6 +++---
> 2 files changed, 6 insertions(+), 6 deletions(-)
> rename Documentation/devicetree/bindings/mtd/{m25p80.txt => jedec,spi-nor.txt} (85%)
>
...
> diff --git a/drivers/mtd/devices/m25p80.c b/drivers/mtd/devices/m25p80.c
> index 7c8b1694a134..3d59ebc16b6e 100644
> --- a/drivers/mtd/devices/m25p80.c
> +++ b/drivers/mtd/devices/m25p80.c
> @@ -223,7 +223,7 @@ static int m25p_probe(struct spi_device *spi)
> */
> if (data && data->type)
> flash_name = data->type;
> - else if (!strcmp(spi->modalias, "nor-jedec"))
> + else if (!strcmp(spi->modalias, "jedec,spi-nor"))
> flash_name = NULL; /* auto-detect */
> else
> flash_name = spi->modalias;
> @@ -255,7 +255,7 @@ static int m25p_remove(struct spi_device *spi)
> * since most of these flash are compatible to some extent, and their
> * differences can often be differentiated by the JEDEC read-ID command, we
> * encourage new users to add support to the spi-nor library, and simply bind
> - * against a generic string here (e.g., "nor-jedec").
> + * against a generic string here (e.g., "jedec,spi-nor").
> *
> * Many flash names are kept here in this list (as well as in spi-nor.c) to
> * keep them available as module aliases for existing platforms.
> @@ -305,7 +305,7 @@ static const struct spi_device_id m25p_ids[] = {
> * Generic support for SPI NOR that can be identified by the JEDEC READ
> * ID opcode (0x9F). Use this, if possible.
> */
> - {"nor-jedec"},
> + {"jedec,spi-nor"},
So I forgot (again; we hit this before) that the SPI/OF framework strips
everything before the first comma before binding devices. See
of_modalias_node(). So I'll have to squash in the patch below to get a
usable binding.
> { },
> };
> MODULE_DEVICE_TABLE(spi, m25p_ids);
This patch will make the code bind against anything like
"<foo>,spi-nor", but we'll leave the comment to recommend
using "jedec,spi-nor".
Signed-off-by: Brian Norris <computersforpeace@gmail.com>
diff --git a/drivers/mtd/devices/m25p80.c b/drivers/mtd/devices/m25p80.c
index 3d59ebc16b6e..3af137f49ac9 100644
--- a/drivers/mtd/devices/m25p80.c
+++ b/drivers/mtd/devices/m25p80.c
@@ -223,7 +223,7 @@ static int m25p_probe(struct spi_device *spi)
*/
if (data && data->type)
flash_name = data->type;
- else if (!strcmp(spi->modalias, "jedec,spi-nor"))
+ else if (!strcmp(spi->modalias, "spi-nor"))
flash_name = NULL; /* auto-detect */
else
flash_name = spi->modalias;
@@ -305,7 +305,7 @@ static const struct spi_device_id m25p_ids[] = {
* Generic support for SPI NOR that can be identified by the JEDEC READ
* ID opcode (0x9F). Use this, if possible.
*/
- {"jedec,spi-nor"},
+ {"spi-nor"},
{ },
};
MODULE_DEVICE_TABLE(spi, m25p_ids);
next prev parent reply other threads:[~2015-05-15 19:56 UTC|newest]
Thread overview: 71+ messages / expand[flat|nested] mbox.gz Atom feed top
2015-05-14 17:32 [PATCH] Documentation: dt: mtd: replace "nor-jedec" binding with "jedec, spi-nor" Brian Norris
2015-05-14 17:32 ` [PATCH] Documentation: dt: mtd: replace "nor-jedec" binding with "jedec,spi-nor" Brian Norris
2015-05-14 17:46 ` Stephen Warren
2015-05-14 17:46 ` Stephen Warren
2015-05-14 17:46 ` Stephen Warren
2015-05-14 20:26 ` [PATCH] Documentation: dt: mtd: replace "nor-jedec" binding with "jedec, spi-nor" Geert Uytterhoeven
2015-05-14 20:26 ` [PATCH] Documentation: dt: mtd: replace "nor-jedec" binding with "jedec,spi-nor" Geert Uytterhoeven
2015-05-15 20:02 ` Brian Norris
2015-05-15 20:02 ` Brian Norris
2015-05-15 20:52 ` [PATCH] Documentation: dt: mtd: replace "nor-jedec" binding with "jedec, spi-nor" Rafał Miłecki
2015-05-15 20:52 ` [PATCH] Documentation: dt: mtd: replace "nor-jedec" binding with "jedec,spi-nor" Rafał Miłecki
2015-05-15 20:52 ` Rafał Miłecki
2015-05-18 14:42 ` Stephen Warren
2015-05-18 14:42 ` Stephen Warren
2015-05-18 14:42 ` Stephen Warren
2015-05-15 10:17 ` Mark Rutland
2015-05-15 10:17 ` Mark Rutland
2015-05-15 10:17 ` Mark Rutland
2015-05-15 19:55 ` Brian Norris [this message]
2015-05-15 19:55 ` Brian Norris
2015-05-18 10:45 ` Mark Rutland
2015-05-18 10:45 ` Mark Rutland
2015-05-18 10:45 ` Mark Rutland
2015-05-18 18:34 ` Brian Norris
2015-05-18 18:34 ` Brian Norris
2015-05-18 18:51 ` [PATCH] Documentation: dt: mtd: replace "nor-jedec" binding with "jedec, spi-nor" Geert Uytterhoeven
2015-05-18 18:51 ` [PATCH] Documentation: dt: mtd: replace "nor-jedec" binding with "jedec,spi-nor" Geert Uytterhoeven
2015-05-18 18:51 ` Geert Uytterhoeven
2015-05-19 1:34 ` Brian Norris
2015-05-19 1:34 ` Brian Norris
2015-05-19 7:27 ` [PATCH] Documentation: dt: mtd: replace "nor-jedec" binding with "jedec, spi-nor" Rafał Miłecki
2015-05-19 7:27 ` [PATCH] Documentation: dt: mtd: replace "nor-jedec" binding with "jedec,spi-nor" Rafał Miłecki
2015-05-20 21:35 ` Brian Norris
2015-05-20 21:35 ` Brian Norris
2015-05-20 21:35 ` Brian Norris
2015-05-21 7:12 ` [PATCH] Documentation: dt: mtd: replace "nor-jedec" binding with "jedec, spi-nor" Rafał Miłecki
2015-05-21 7:12 ` [PATCH] Documentation: dt: mtd: replace "nor-jedec" binding with "jedec,spi-nor" Rafał Miłecki
2015-05-21 7:12 ` Rafał Miłecki
2015-05-21 7:25 ` Brian Norris
2015-05-21 7:25 ` Brian Norris
2015-05-21 8:01 ` [PATCH] Documentation: dt: mtd: replace "nor-jedec" binding with "jedec, spi-nor" Rafał Miłecki
2015-05-21 8:01 ` [PATCH] Documentation: dt: mtd: replace "nor-jedec" binding with "jedec,spi-nor" Rafał Miłecki
2015-05-21 8:01 ` Rafał Miłecki
2015-05-21 8:15 ` Brian Norris
2015-05-21 8:15 ` Brian Norris
2015-05-21 8:15 ` Brian Norris
2015-05-21 8:25 ` [PATCH] Documentation: dt: mtd: replace "nor-jedec" binding with "jedec, spi-nor" Rafał Miłecki
2015-05-21 8:25 ` [PATCH] Documentation: dt: mtd: replace "nor-jedec" binding with "jedec,spi-nor" Rafał Miłecki
2015-05-21 8:25 ` Rafał Miłecki
2015-05-21 8:39 ` [PATCH] Documentation: dt: mtd: replace "nor-jedec" binding with "jedec, spi-nor" Geert Uytterhoeven
2015-05-21 8:39 ` [PATCH] Documentation: dt: mtd: replace "nor-jedec" binding with "jedec,spi-nor" Geert Uytterhoeven
2015-05-21 8:39 ` Geert Uytterhoeven
2015-05-21 8:50 ` [PATCH] Documentation: dt: mtd: replace "nor-jedec" binding with "jedec, spi-nor" Rafał Miłecki
2015-05-21 8:50 ` [PATCH] Documentation: dt: mtd: replace "nor-jedec" binding with "jedec,spi-nor" Rafał Miłecki
2015-05-21 8:50 ` Rafał Miłecki
2015-05-21 8:58 ` [PATCH] Documentation: dt: mtd: replace "nor-jedec" binding with "jedec, spi-nor" Geert Uytterhoeven
2015-05-21 8:58 ` [PATCH] Documentation: dt: mtd: replace "nor-jedec" binding with "jedec,spi-nor" Geert Uytterhoeven
2015-05-21 8:58 ` Geert Uytterhoeven
2015-05-21 9:31 ` [PATCH] Documentation: dt: mtd: replace "nor-jedec" binding with "jedec, spi-nor" Rafał Miłecki
2015-05-21 9:31 ` [PATCH] Documentation: dt: mtd: replace "nor-jedec" binding with "jedec,spi-nor" Rafał Miłecki
2015-05-21 9:31 ` Rafał Miłecki
2015-05-21 9:39 ` [PATCH] Documentation: dt: mtd: replace "nor-jedec" binding with "jedec, spi-nor" Geert Uytterhoeven
2015-05-21 9:39 ` [PATCH] Documentation: dt: mtd: replace "nor-jedec" binding with "jedec,spi-nor" Geert Uytterhoeven
2015-05-21 9:47 ` [PATCH] Documentation: dt: mtd: replace "nor-jedec" binding with "jedec, spi-nor" Rafał Miłecki
2015-05-21 9:47 ` [PATCH] Documentation: dt: mtd: replace "nor-jedec" binding with "jedec,spi-nor" Rafał Miłecki
2015-05-21 9:47 ` Rafał Miłecki
2015-05-21 9:57 ` [PATCH] Documentation: dt: mtd: replace "nor-jedec" binding with "jedec, spi-nor" Rafał Miłecki
2015-05-21 9:57 ` [PATCH] Documentation: dt: mtd: replace "nor-jedec" binding with "jedec,spi-nor" Rafał Miłecki
2015-05-21 9:57 ` Rafał Miłecki
2015-07-21 16:57 ` Brian Norris
2015-07-21 16:57 ` Brian Norris
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20150515195541.GL11598@ld-irv-0074 \
--to=computersforpeace@gmail.com \
--cc=devicetree@vger.kernel.org \
--cc=galak@codeaurora.org \
--cc=geert@linux-m68k.org \
--cc=ijc+devicetree@hellion.org.uk \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-mtd@lists.infradead.org \
--cc=marex@denx.de \
--cc=mark.rutland@arm.com \
--cc=pawel.moll@arm.com \
--cc=robh+dt@kernel.org \
--cc=swarren@wwwdotorg.org \
--cc=zajec5@gmail.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.