All of lore.kernel.org
 help / color / mirror / Atom feed
From: Dmitry Torokhov <dmitry.torokhov@gmail.com>
To: Baole Ni <baolex.ni@intel.com>
Cc: hal.rosenstock@gmail.com, dledford@redhat.com,
	sean.hefty@intel.com, bp@alien8.de, linux-input@vger.kernel.org,
	linux-kernel@vger.kernel.org, haibo.chen@freescale.com,
	andrey.gelman@compulab.co.il, broonie@kernel.org, afd@ti.com,
	javier@osg.samsung.com, chuansheng.liu@intel.com
Subject: Re: [PATCH 0290/1285] Replace numeric parameter like 0444 with macro
Date: Tue, 2 Aug 2016 10:27:56 -0700	[thread overview]
Message-ID: <20160802172756.GA5012@dtor-ws> (raw)
In-Reply-To: <20160802105711.703-1-baolex.ni@intel.com>

On Tue, Aug 02, 2016 at 06:57:11PM +0800, Baole Ni wrote:
> I find that the developers often just specified the numeric value
> when calling a macro which is defined with a parameter for access permission.
> As we know, these numeric value for access permission have had the corresponding macro,
> and that using macro can improve the robustness and readability of the code,
> thus, I suggest replacing the numeric parameter with the macro.
> 
> Signed-off-by: Chuansheng Liu <chuansheng.liu@intel.com>
> Signed-off-by: Baole Ni <baolex.ni@intel.com>
> ---
>  drivers/input/touchscreen/ads7846.c | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
> 
> diff --git a/drivers/input/touchscreen/ads7846.c b/drivers/input/touchscreen/ads7846.c
> index a61b215..0f882cb 100644
> --- a/drivers/input/touchscreen/ads7846.c
> +++ b/drivers/input/touchscreen/ads7846.c
> @@ -591,7 +591,7 @@ static ssize_t ads7846_disable_store(struct device *dev,
>  	return count;
>  }
>  
> -static DEVICE_ATTR(disable, 0664, ads7846_disable_show, ads7846_disable_store);
> +static DEVICE_ATTR(disable, S_IRUSR | S_IWUSR | S_IRGRP | S_IWGRP | S_IROTH, ads7846_disable_show, ads7846_disable_store);

No, this does not improve neither robustness nor readability.

Thanks.

-- 
Dmitry

      parent reply	other threads:[~2016-08-02 17:27 UTC|newest]

Thread overview: 5+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2016-08-02 10:57 [PATCH 0290/1285] Replace numeric parameter like 0444 with macro Baole Ni
2016-08-02 14:31 ` Mark Brown
2016-08-02 14:51   ` Andrew F. Davis
2016-08-02 14:51     ` Andrew F. Davis
2016-08-02 17:27 ` Dmitry Torokhov [this message]

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20160802172756.GA5012@dtor-ws \
    --to=dmitry.torokhov@gmail.com \
    --cc=afd@ti.com \
    --cc=andrey.gelman@compulab.co.il \
    --cc=baolex.ni@intel.com \
    --cc=bp@alien8.de \
    --cc=broonie@kernel.org \
    --cc=chuansheng.liu@intel.com \
    --cc=dledford@redhat.com \
    --cc=haibo.chen@freescale.com \
    --cc=hal.rosenstock@gmail.com \
    --cc=javier@osg.samsung.com \
    --cc=linux-input@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=sean.hefty@intel.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.