* [PATCH] generic/45[34]: fix the xfs_scrub probe test
@ 2017-09-27 1:04 Darrick J. Wong
0 siblings, 0 replies; only message in thread
From: Darrick J. Wong @ 2017-09-27 1:04 UTC (permalink / raw)
To: Eryu Guan; +Cc: fstests
We changed the name of the xfs_scrub verb from 'test' to 'probe', so
fix xfstests to follow.
Signed-off-by: Darrick J. Wong <darrick.wong@oracle.com>
---
tests/generic/453 | 2 +-
tests/generic/454 | 2 +-
2 files changed, 2 insertions(+), 2 deletions(-)
diff --git a/tests/generic/453 b/tests/generic/453
index d8fb1bd..ff29736 100755
--- a/tests/generic/453
+++ b/tests/generic/453
@@ -148,7 +148,7 @@ check_xfs_scrub() {
fi
# Does the ioctl work?
- if $XFS_IO_PROG -x -c "scrub test 0" $SCRATCH_MNT 2>&1 | \
+ if $XFS_IO_PROG -x -c "scrub probe 0" $SCRATCH_MNT 2>&1 | \
grep -q "Inappropriate ioctl"; then
return 1
fi
diff --git a/tests/generic/454 b/tests/generic/454
index 385e6de..01279ee 100755
--- a/tests/generic/454
+++ b/tests/generic/454
@@ -144,7 +144,7 @@ check_xfs_scrub() {
fi
# Does the ioctl work?
- if $XFS_IO_PROG -x -c "scrub test 0" $SCRATCH_MNT 2>&1 | \
+ if $XFS_IO_PROG -x -c "scrub probe 0" $SCRATCH_MNT 2>&1 | \
grep -q "Inappropriate ioctl"; then
return 1
fi
^ permalink raw reply related [flat|nested] only message in thread
only message in thread, other threads:[~2017-09-27 1:04 UTC | newest]
Thread overview: (only message) (download: mbox.gz follow: Atom feed
-- links below jump to the message on this page --
2017-09-27 1:04 [PATCH] generic/45[34]: fix the xfs_scrub probe test Darrick J. Wong
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.