All of lore.kernel.org
 help / color / mirror / Atom feed
From: Markus Armbruster <armbru@redhat.com>
To: qemu-devel@nongnu.org
Cc: thuth@redhat.com, f4bug@amsat.org, eblake@redhat.com
Subject: [Qemu-devel] [PATCH v3 09/23] test-qobject-input-visitor: Avoid format string ambiguity
Date: Mon,  6 Aug 2018 08:53:30 +0200	[thread overview]
Message-ID: <20180806065344.7103-10-armbru@redhat.com> (raw)
In-Reply-To: <20180806065344.7103-1-armbru@redhat.com>

When visitor_input_test_init_internal()'s argument @ap is null, then
@json_string is interpreted literally, else it's gets %-escapes
interpolated.  This is awkward.

One caller always passes null @ap, and the others never do.  Lift the
building of the QObject into the callers, where it can be done without
such ambiguity.

Signed-off-by: Markus Armbruster <armbru@redhat.com>
Reviewed-by: Eric Blake <eblake@redhat.com>
---
 tests/test-qobject-input-visitor.c | 19 ++++++++++---------
 1 file changed, 10 insertions(+), 9 deletions(-)

diff --git a/tests/test-qobject-input-visitor.c b/tests/test-qobject-input-visitor.c
index 0f4d234c3f..caa90b3d7e 100644
--- a/tests/test-qobject-input-visitor.c
+++ b/tests/test-qobject-input-visitor.c
@@ -47,15 +47,13 @@ static void visitor_input_teardown(TestInputVisitorData *data,
 /* The various test_init functions are provided instead of a test setup
    function so that the JSON string used by the tests are kept in the test
    functions (and not in main()). */
-static Visitor *visitor_input_test_init_internal(TestInputVisitorData *data,
-                                                 bool keyval,
-                                                 const char *json_string,
-                                                 va_list *ap)
+
+static Visitor *test_init_internal(TestInputVisitorData *data, bool keyval,
+                                   QObject *obj)
 {
     visitor_input_teardown(data, NULL);
 
-    data->obj = qobject_from_jsonv(json_string, ap, &error_abort);
-    g_assert(data->obj);
+    data->obj = obj;
 
     if (keyval) {
         data->qiv = qobject_input_visitor_new_keyval(data->obj);
@@ -75,7 +73,8 @@ Visitor *visitor_input_test_init_full(TestInputVisitorData *data,
     va_list ap;
 
     va_start(ap, json_string);
-    v = visitor_input_test_init_internal(data, keyval, json_string, &ap);
+    v = test_init_internal(data, keyval,
+                           qobject_from_vjsonf_nofail(json_string, ap));
     va_end(ap);
     return v;
 }
@@ -88,7 +87,8 @@ Visitor *visitor_input_test_init(TestInputVisitorData *data,
     va_list ap;
 
     va_start(ap, json_string);
-    v = visitor_input_test_init_internal(data, false, json_string, &ap);
+    v = test_init_internal(data, false,
+                           qobject_from_vjsonf_nofail(json_string, ap));
     va_end(ap);
     return v;
 }
@@ -103,7 +103,8 @@ Visitor *visitor_input_test_init(TestInputVisitorData *data,
 static Visitor *visitor_input_test_init_raw(TestInputVisitorData *data,
                                             const char *json_string)
 {
-    return visitor_input_test_init_internal(data, false, json_string, NULL);
+    return test_init_internal(data, false,
+                              qobject_from_json(json_string, &error_abort));
 }
 
 static void test_visitor_in_int(TestInputVisitorData *data,
-- 
2.17.1

  parent reply	other threads:[~2018-08-06  6:53 UTC|newest]

Thread overview: 26+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2018-08-06  6:53 [Qemu-devel] [PATCH v3 00/23] tests: Compile-time format string checking for libqtest.h Markus Armbruster
2018-08-06  6:53 ` [Qemu-devel] [PATCH v3 01/23] libqtest: Rename functions to send QMP messages Markus Armbruster
2018-08-06  6:53 ` [Qemu-devel] [PATCH v3 02/23] libqtest: Clean up how we read device_del messages Markus Armbruster
2018-08-06  6:53 ` [Qemu-devel] [PATCH v3 03/23] libqtest: Clean up how we read the QMP greeting Markus Armbruster
2018-08-06  6:53 ` [Qemu-devel] [PATCH v3 04/23] libqtest: Remove qtest_qmp_discard_response() & friends Markus Armbruster
2018-08-06  7:02   ` Thomas Huth
2018-08-06  6:53 ` [Qemu-devel] [PATCH v3 05/23] libqtest: Document calling conventions Markus Armbruster
2018-08-06  6:53 ` [Qemu-devel] [PATCH v3 06/23] qobject: Replace qobject_from_jsonf() by qobject_from_jsonf_nofail() Markus Armbruster
2018-08-06  6:53 ` [Qemu-devel] [PATCH v3 07/23] qobject: New qobject_from_vjsonf_nofail(), qdict_from_vjsonf_nofail() Markus Armbruster
2018-08-06  6:53 ` [Qemu-devel] [PATCH v3 08/23] libqtest: Simplify qmp_fd_vsend() a bit Markus Armbruster
2018-08-06  6:53 ` Markus Armbruster [this message]
2018-08-06  6:53 ` [Qemu-devel] [PATCH v3 10/23] qobject: qobject_from_jsonv() is dangerous, hide it away Markus Armbruster
2018-08-06  6:53 ` [Qemu-devel] [PATCH v3 11/23] tests: Pass literal format strings directly to qmp_FOO() Markus Armbruster
2018-08-06  6:53 ` [Qemu-devel] [PATCH v3 12/23] tests: Clean up string interpolation into QMP input (simple cases) Markus Armbruster
2018-08-06  6:53 ` [Qemu-devel] [PATCH v3 13/23] cpu-plug-test: Don't pass integers as strings to device_add Markus Armbruster
2018-08-06  6:53 ` [Qemu-devel] [PATCH v3 14/23] tests: Clean up string interpolation around qtest_qmp_device_add() Markus Armbruster
2018-08-06  6:53 ` [Qemu-devel] [PATCH v3 15/23] migration-test: Make wait_command() return the "return" member Markus Armbruster
2018-08-06  6:53 ` [Qemu-devel] [PATCH v3 16/23] tests: New helper qtest_qmp_receive_success() Markus Armbruster
2018-08-06  6:53 ` [Qemu-devel] [PATCH v3 17/23] migration-test: Make wait_command() cope with '%' Markus Armbruster
2018-08-06  6:53 ` [Qemu-devel] [PATCH v3 18/23] migration-test: Clean up string interpolation into QMP, part 1 Markus Armbruster
2018-08-06  6:53 ` [Qemu-devel] [PATCH v3 19/23] migration-test: Clean up string interpolation into QMP, part 2 Markus Armbruster
2018-08-06  6:53 ` [Qemu-devel] [PATCH v3 20/23] migration-test: Clean up string interpolation into QMP, part 3 Markus Armbruster
2018-08-06  6:53 ` [Qemu-devel] [PATCH v3 21/23] libqtest: Enable compile-time format string checking Markus Armbruster
2018-08-06  6:53 ` [Qemu-devel] [PATCH v3 22/23] libqtest: Replace qtest_startf() by qtest_initf() Markus Armbruster
2018-08-06  6:53 ` [Qemu-devel] [PATCH v3 23/23] libqtest: Rename qtest_FOOv() to qtest_vFOO() for consistency Markus Armbruster
2018-08-12 10:02   ` Paolo Bonzini

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20180806065344.7103-10-armbru@redhat.com \
    --to=armbru@redhat.com \
    --cc=eblake@redhat.com \
    --cc=f4bug@amsat.org \
    --cc=qemu-devel@nongnu.org \
    --cc=thuth@redhat.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.