From: Markus Armbruster <armbru@redhat.com>
To: qemu-devel@nongnu.org
Cc: thuth@redhat.com, f4bug@amsat.org, eblake@redhat.com
Subject: [Qemu-devel] [PATCH v3 23/23] libqtest: Rename qtest_FOOv() to qtest_vFOO() for consistency
Date: Mon, 6 Aug 2018 08:53:44 +0200 [thread overview]
Message-ID: <20180806065344.7103-24-armbru@redhat.com> (raw)
In-Reply-To: <20180806065344.7103-1-armbru@redhat.com>
13 of 13 C99 library function pairs taking ... or a va_list parameter
are called FOO() and vFOO(). In QEMU, we sometimes call the one
taking a va_list FOOv() instead. Bad taste. libqtest.h uses both
spellings. Normalize it to the standard spelling.
Signed-off-by: Markus Armbruster <armbru@redhat.com>
Reviewed-by: Eric Blake <eblake@redhat.com>
---
tests/libqtest.c | 12 ++++++------
tests/libqtest.h | 4 ++--
2 files changed, 8 insertions(+), 8 deletions(-)
diff --git a/tests/libqtest.c b/tests/libqtest.c
index a0d44793fa..3706f30aa2 100644
--- a/tests/libqtest.c
+++ b/tests/libqtest.c
@@ -538,7 +538,7 @@ QDict *qmp_fdv(int fd, const char *fmt, va_list ap)
return qmp_fd_receive(fd);
}
-QDict *qtest_qmpv(QTestState *s, const char *fmt, va_list ap)
+QDict *qtest_vqmp(QTestState *s, const char *fmt, va_list ap)
{
qtest_qmp_vsend(s, fmt, ap);
@@ -572,7 +572,7 @@ QDict *qtest_qmp(QTestState *s, const char *fmt, ...)
QDict *response;
va_start(ap, fmt);
- response = qtest_qmpv(s, fmt, ap);
+ response = qtest_vqmp(s, fmt, ap);
va_end(ap);
return response;
}
@@ -608,7 +608,7 @@ void qtest_qmp_eventwait(QTestState *s, const char *event)
qobject_unref(response);
}
-char *qtest_hmpv(QTestState *s, const char *fmt, va_list ap)
+char *qtest_vhmp(QTestState *s, const char *fmt, va_list ap)
{
char *cmd;
QDict *resp;
@@ -637,7 +637,7 @@ char *qtest_hmp(QTestState *s, const char *fmt, ...)
char *ret;
va_start(ap, fmt);
- ret = qtest_hmpv(s, fmt, ap);
+ ret = qtest_vhmp(s, fmt, ap);
va_end(ap);
return ret;
}
@@ -943,7 +943,7 @@ QDict *qmp(const char *fmt, ...)
QDict *response;
va_start(ap, fmt);
- response = qtest_qmpv(global_qtest, fmt, ap);
+ response = qtest_vqmp(global_qtest, fmt, ap);
va_end(ap);
return response;
}
@@ -963,7 +963,7 @@ char *hmp(const char *fmt, ...)
char *ret;
va_start(ap, fmt);
- ret = qtest_hmpv(global_qtest, fmt, ap);
+ ret = qtest_vhmp(global_qtest, fmt, ap);
va_end(ap);
return ret;
}
diff --git a/tests/libqtest.h b/tests/libqtest.h
index b92a8070a5..def1edaafa 100644
--- a/tests/libqtest.h
+++ b/tests/libqtest.h
@@ -106,7 +106,7 @@ void qtest_qmp_send(QTestState *s, const char *fmt, ...)
*
* Sends a QMP message to QEMU and returns the response.
*/
-QDict *qtest_qmpv(QTestState *s, const char *fmt, va_list ap)
+QDict *qtest_vqmp(QTestState *s, const char *fmt, va_list ap)
GCC_FMT_ATTR(2, 0);
/**
@@ -189,7 +189,7 @@ char *qtest_hmp(QTestState *s, const char *fmt, ...) GCC_FMT_ATTR(2, 3);
*
* Returns: the command's output. The caller should g_free() it.
*/
-char *qtest_hmpv(QTestState *s, const char *fmt, va_list ap)
+char *qtest_vhmp(QTestState *s, const char *fmt, va_list ap)
GCC_FMT_ATTR(2, 0);
/**
--
2.17.1
next prev parent reply other threads:[~2018-08-06 6:53 UTC|newest]
Thread overview: 27+ messages / expand[flat|nested] mbox.gz Atom feed top
2018-08-06 6:53 [Qemu-devel] [PATCH v3 00/23] tests: Compile-time format string checking for libqtest.h Markus Armbruster
2018-08-06 6:53 ` [Qemu-devel] [PATCH v3 01/23] libqtest: Rename functions to send QMP messages Markus Armbruster
2018-08-06 6:53 ` [Qemu-devel] [PATCH v3 02/23] libqtest: Clean up how we read device_del messages Markus Armbruster
2018-08-06 6:53 ` [Qemu-devel] [PATCH v3 03/23] libqtest: Clean up how we read the QMP greeting Markus Armbruster
2018-08-06 6:53 ` [Qemu-devel] [PATCH v3 04/23] libqtest: Remove qtest_qmp_discard_response() & friends Markus Armbruster
2018-08-06 7:02 ` Thomas Huth
2018-08-06 6:53 ` [Qemu-devel] [PATCH v3 05/23] libqtest: Document calling conventions Markus Armbruster
2018-08-06 6:53 ` [Qemu-devel] [PATCH v3 06/23] qobject: Replace qobject_from_jsonf() by qobject_from_jsonf_nofail() Markus Armbruster
2018-08-06 6:53 ` [Qemu-devel] [PATCH v3 07/23] qobject: New qobject_from_vjsonf_nofail(), qdict_from_vjsonf_nofail() Markus Armbruster
2018-08-06 6:53 ` [Qemu-devel] [PATCH v3 08/23] libqtest: Simplify qmp_fd_vsend() a bit Markus Armbruster
2018-08-06 6:53 ` [Qemu-devel] [PATCH v3 09/23] test-qobject-input-visitor: Avoid format string ambiguity Markus Armbruster
2018-08-06 6:53 ` [Qemu-devel] [PATCH v3 10/23] qobject: qobject_from_jsonv() is dangerous, hide it away Markus Armbruster
2018-08-06 6:53 ` [Qemu-devel] [PATCH v3 11/23] tests: Pass literal format strings directly to qmp_FOO() Markus Armbruster
2018-08-06 6:53 ` [Qemu-devel] [PATCH v3 12/23] tests: Clean up string interpolation into QMP input (simple cases) Markus Armbruster
2018-08-06 6:53 ` [Qemu-devel] [PATCH v3 13/23] cpu-plug-test: Don't pass integers as strings to device_add Markus Armbruster
2018-08-06 6:53 ` [Qemu-devel] [PATCH v3 14/23] tests: Clean up string interpolation around qtest_qmp_device_add() Markus Armbruster
2018-08-06 6:53 ` [Qemu-devel] [PATCH v3 15/23] migration-test: Make wait_command() return the "return" member Markus Armbruster
2018-08-06 6:53 ` [Qemu-devel] [PATCH v3 16/23] tests: New helper qtest_qmp_receive_success() Markus Armbruster
2018-08-06 6:53 ` [Qemu-devel] [PATCH v3 17/23] migration-test: Make wait_command() cope with '%' Markus Armbruster
2018-08-06 6:53 ` [Qemu-devel] [PATCH v3 18/23] migration-test: Clean up string interpolation into QMP, part 1 Markus Armbruster
2018-08-06 6:53 ` [Qemu-devel] [PATCH v3 19/23] migration-test: Clean up string interpolation into QMP, part 2 Markus Armbruster
2018-08-06 6:53 ` [Qemu-devel] [PATCH v3 20/23] migration-test: Clean up string interpolation into QMP, part 3 Markus Armbruster
2018-08-06 6:53 ` [Qemu-devel] [PATCH v3 21/23] libqtest: Enable compile-time format string checking Markus Armbruster
2018-08-06 6:53 ` [Qemu-devel] [PATCH v3 22/23] libqtest: Replace qtest_startf() by qtest_initf() Markus Armbruster
2018-08-06 6:53 ` Markus Armbruster [this message]
2018-08-12 10:02 ` [Qemu-devel] [PATCH v3 23/23] libqtest: Rename qtest_FOOv() to qtest_vFOO() for consistency Paolo Bonzini
-- strict thread matches above, loose matches on Subject: below --
2018-07-30 8:32 [Qemu-devel] [PATCH v3 00/23] tests: Compile-time format string checking for libqtest.h Markus Armbruster
2018-07-30 8:33 ` [Qemu-devel] [PATCH v3 23/23] libqtest: Rename qtest_FOOv() to qtest_vFOO() for consistency Markus Armbruster
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20180806065344.7103-24-armbru@redhat.com \
--to=armbru@redhat.com \
--cc=eblake@redhat.com \
--cc=f4bug@amsat.org \
--cc=qemu-devel@nongnu.org \
--cc=thuth@redhat.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.