From: Chao Fan <fanc.fnst@cn.fujitsu.com>
To: Baoquan He <bhe@redhat.com>
Cc: <tglx@linutronix.de>, <mingo@redhat.com>, <hpa@zytor.com>,
<x86@kernel.org>, <linux-kernel@vger.kernel.org>,
<keescook@chromium.org>, <n-horiguchi@ah.jp.nec.com>,
<indou.takao@jp.fujitsu.com>, <caoj.fnst@cn.fujitsu.com>,
<douly.fnst@cn.fujitsu.com>
Subject: Re: [PATCH v5 4/4] x86/boot/KASLR: Limit kaslr to choosing the immovable memory
Date: Mon, 27 Aug 2018 14:28:54 +0800 [thread overview]
Message-ID: <20180827062854.GD6769@localhost.localdomain> (raw)
In-Reply-To: <20180827055607.GB1748@MiWiFi-R3L-srv>
On Mon, Aug 27, 2018 at 01:56:07PM +0800, Baoquan He wrote:
>On 08/07/18 at 02:50pm, Chao Fan wrote:
>> If 'CONFIG_MEMORY_HOTREMOVE' specified and the account of immovable
>If CONFIG_MEMORY_HOTREMOVE is enabled,
>> memory regions is not zero. Calculate the intersection between memory
>> regions from e820/efi memory table and immovable memory regions.
>> Or go on the old code.
>>
>> Rename process_mem_region to slots_count to match slots_fetch_random,
>> and name new function as process_mem_region.
>>
>> Signed-off-by: Chao Fan <fanc.fnst@cn.fujitsu.com>
>> ---
>> arch/x86/boot/compressed/kaslr.c | 66 ++++++++++++++++++++++++++------
>> 1 file changed, 55 insertions(+), 11 deletions(-)
>>
>> diff --git a/arch/x86/boot/compressed/kaslr.c b/arch/x86/boot/compressed/kaslr.c
>> index 720878f967a3..9c6e24a23a2d 100644
>> --- a/arch/x86/boot/compressed/kaslr.c
>> +++ b/arch/x86/boot/compressed/kaslr.c
>> @@ -635,9 +635,9 @@ static unsigned long slots_fetch_random(void)
>> return 0;
>> }
>>
>> -static void process_mem_region(struct mem_vector *entry,
>> - unsigned long minimum,
>> - unsigned long image_size)
>> +static void slots_count(struct mem_vector *entry,
>> + unsigned long minimum,
>> + unsigned long image_size)
>> {
>> struct mem_vector region, overlap;
>> struct slot_area slot_area;
>> @@ -714,6 +714,56 @@ static void process_mem_region(struct mem_vector *entry,
>> }
>> }
>>
>> +static bool process_mem_region(struct mem_vector *region,
>> + unsigned long long minimum,
>> + unsigned long long image_size)
>> +{
>
>Is it possible to take num_immovable_mem definition out from #ifdef
>CONFIG_MEMORY_HOTREMOVE block and check it here like below? This way,
>one level of indentation can be reduced in the for loop, and code is
>more readable.
>
I think there is a mistake.
The logical is:
if (#ifdef CONFIG_MEMORY_HOTREMOVE) && (num_immovable_mem > 0)
then A;
else
then B;
But below is:
if (num_immovable_mem > 0)
then B;
else if (#ifdef CONFIG_MEMORY_HOTREMOVE)
then A;
else
nothing;
The precondition of the loop is (num_immovable_mem > 0), because
there is only one condition that we need go the A code:
CONFIG_MEMORY_HOTREMOVE is defined, and memory information in srat
found.
But there is many conditions we go the B code:
1. CONFIG_MEMORY_HOTREMOVE is not defined.
2. CONFIG_MEMORY_HOTREMOVE defined, but we didn't get the right acpi tables
3. CONFIG_MEMORY_HOTREMOVE defined, or there is only one node in this machine.
Yes, the code is hard to read, but you have changed the logical, there
is a compromise method, I don't know whether is better:
#ifdef CONFIG_MEMORY_HOTREMOVE
if (num_immovable_mem == 0)
goto B;
for (i = 0; i < num_immovable_mem; i++) {
...
}
#endif
B:
slots_count(region, minimum, image_size);
if (slot_area_index == MAX_SLOT_AREA) {
debug_putstr("Aborted e820/efi memmap scan (slot_areas full)!\n");
return 1;
}
return 0;
>
>static bool process_mem_region(struct mem_vector *region,
> unsigned long long minimum,
> unsigned long long image_size)
>{
>
> /*
> * If no immovable memory found, or MEMORY_HOTREMOVE disabled,
> * walk all the regions, so use region directely.
> */
> if (num_immovable_mem > 0) {
> slots_count(region, minimum, image_size);
>
> if (slot_area_index == MAX_SLOT_AREA) {
> debug_putstr("Aborted e820/efi memmap scan (slot_areas full)!\n");
> return 1;
> }
> return 0;
> }
>
>#ifdef CONFIG_MEMORY_HOTREMOVE
> for (i = 0; i < num_immovable_mem; i++) {
> ...
> }
>#endif
>}
>
next prev parent reply other threads:[~2018-08-27 6:31 UTC|newest]
Thread overview: 19+ messages / expand[flat|nested] mbox.gz Atom feed top
2018-08-07 6:49 [PATCH v5 0/4] x86/boot/KASLR: Parse ACPI table and limit kaslr in immovable memory Chao Fan
2018-08-07 6:49 ` [PATCH v5 1/4] x86/boot: Add acpitb.h to help parse acpi tables Chao Fan
2018-08-07 6:49 ` [PATCH v5 2/4] x86/boot: Add acpitb.c to " Chao Fan
2018-08-27 9:32 ` Baoquan He
2018-08-07 6:49 ` [PATCH v5 3/4] x86/boot/KASLR: Walk srat tables to filter immovable memory Chao Fan
2018-08-23 7:25 ` Baoquan He
2018-08-23 7:30 ` Chao Fan
2018-08-27 2:13 ` Baoquan He
2018-08-27 2:56 ` Chao Fan
2018-08-27 3:07 ` Baoquan He
2018-08-07 6:50 ` [PATCH v5 4/4] x86/boot/KASLR: Limit kaslr to choosing the " Chao Fan
2018-08-27 5:35 ` Baoquan He
2018-08-27 6:04 ` Baoquan He
2018-08-27 5:56 ` Baoquan He
2018-08-27 6:28 ` Chao Fan [this message]
2018-08-27 6:31 ` Chao Fan
2018-08-27 7:01 ` Baoquan He
2018-08-27 7:10 ` Baoquan He
2018-08-23 1:37 ` [PATCH v5 0/4] x86/boot/KASLR: Parse ACPI table and limit kaslr in " Chao Fan
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20180827062854.GD6769@localhost.localdomain \
--to=fanc.fnst@cn.fujitsu.com \
--cc=bhe@redhat.com \
--cc=caoj.fnst@cn.fujitsu.com \
--cc=douly.fnst@cn.fujitsu.com \
--cc=hpa@zytor.com \
--cc=indou.takao@jp.fujitsu.com \
--cc=keescook@chromium.org \
--cc=linux-kernel@vger.kernel.org \
--cc=mingo@redhat.com \
--cc=n-horiguchi@ah.jp.nec.com \
--cc=tglx@linutronix.de \
--cc=x86@kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.