All of lore.kernel.org
 help / color / mirror / Atom feed
From: David Gibson <david@gibson.dropbear.id.au>
To: "Philippe Mathieu-Daudé" <philmd@redhat.com>
Cc: Markus Armbruster <armbru@redhat.com>,
	qemu-devel@nongnu.org, peter.maydell@linaro.org,
	alistair.francis@wdc.com, slp@redhat.com
Subject: Re: [Qemu-devel] [PATCH for-4.0-maybe] device_tree: Fix integer overflowing in load_device_tree()
Date: Wed, 10 Apr 2019 10:29:30 +1000	[thread overview]
Message-ID: <20190410002930.GM16627@umbus.fritz.box> (raw)
In-Reply-To: <f018f4d8-7fb2-9037-3b5a-b34f1c5d876d@redhat.com>

[-- Attachment #1: Type: text/plain, Size: 1679 bytes --]

On Tue, Apr 09, 2019 at 08:59:55PM +0200, Philippe Mathieu-Daudé wrote:
> On 4/9/19 7:40 PM, Markus Armbruster wrote:
> > If the value of get_image_size() exceeds INT_MAX / 2 - 10000, the
> > computation of @dt_size overflows to a negative number, which then
> > gets converted to a very large size_t for g_malloc0() and
> > load_image_size().  In the (fortunately improbable) case g_malloc0()
> > succeeds and load_image_size() survives, we'd assign the negative
> > number to *sizep.  What that would do to the callers I can't say, but
> > it's unlikely to be good.
> > 
> > Fix by rejecting images whose size would overflow.
> > 
> > Signed-off-by: Markus Armbruster <armbru@redhat.com>
> > ---
> >  device_tree.c | 4 ++++
> >  1 file changed, 4 insertions(+)
> > 
> > diff --git a/device_tree.c b/device_tree.c
> > index 296278e12a..f8b46b3c73 100644
> > --- a/device_tree.c
> > +++ b/device_tree.c
> > @@ -84,6 +84,10 @@ void *load_device_tree(const char *filename_path, int *sizep)
> >                       filename_path);
> >          goto fail;
> >      }
> > +    if (dt_size > INT_MAX / 2 - 10000) {
> 
> We should avoid magic number duplication.
> That said, this patch looks safe.
> 
> Reviewed-by: Philippe Mathieu-Daudé <philmd@redhat.com>

As Philippe says, the test condition is kinda ugly and I hope we can
refine it in future.  But since it fixes a real problem for now,

Reviewed-by: David Gibson <david@gibson.dropbear.id.au>

-- 
David Gibson			| I'll have my music baroque, and my code
david AT gibson.dropbear.id.au	| minimalist, thank you.  NOT _the_ _other_
				| _way_ _around_!
http://www.ozlabs.org/~dgibson

[-- Attachment #2: signature.asc --]
[-- Type: application/pgp-signature, Size: 833 bytes --]

WARNING: multiple messages have this Message-ID (diff)
From: David Gibson <david@gibson.dropbear.id.au>
To: "Philippe Mathieu-Daudé" <philmd@redhat.com>
Cc: peter.maydell@linaro.org, alistair.francis@wdc.com,
	Markus Armbruster <armbru@redhat.com>,
	slp@redhat.com, qemu-devel@nongnu.org
Subject: Re: [Qemu-devel] [PATCH for-4.0-maybe] device_tree: Fix integer overflowing in load_device_tree()
Date: Wed, 10 Apr 2019 10:29:30 +1000	[thread overview]
Message-ID: <20190410002930.GM16627@umbus.fritz.box> (raw)
Message-ID: <20190410002930.JBLBqazrES_V3ZEuygGhyVZZzmXvH4-5qdrFsYpL1SY@z> (raw)
In-Reply-To: <f018f4d8-7fb2-9037-3b5a-b34f1c5d876d@redhat.com>

[-- Attachment #1: Type: text/plain, Size: 1679 bytes --]

On Tue, Apr 09, 2019 at 08:59:55PM +0200, Philippe Mathieu-Daudé wrote:
> On 4/9/19 7:40 PM, Markus Armbruster wrote:
> > If the value of get_image_size() exceeds INT_MAX / 2 - 10000, the
> > computation of @dt_size overflows to a negative number, which then
> > gets converted to a very large size_t for g_malloc0() and
> > load_image_size().  In the (fortunately improbable) case g_malloc0()
> > succeeds and load_image_size() survives, we'd assign the negative
> > number to *sizep.  What that would do to the callers I can't say, but
> > it's unlikely to be good.
> > 
> > Fix by rejecting images whose size would overflow.
> > 
> > Signed-off-by: Markus Armbruster <armbru@redhat.com>
> > ---
> >  device_tree.c | 4 ++++
> >  1 file changed, 4 insertions(+)
> > 
> > diff --git a/device_tree.c b/device_tree.c
> > index 296278e12a..f8b46b3c73 100644
> > --- a/device_tree.c
> > +++ b/device_tree.c
> > @@ -84,6 +84,10 @@ void *load_device_tree(const char *filename_path, int *sizep)
> >                       filename_path);
> >          goto fail;
> >      }
> > +    if (dt_size > INT_MAX / 2 - 10000) {
> 
> We should avoid magic number duplication.
> That said, this patch looks safe.
> 
> Reviewed-by: Philippe Mathieu-Daudé <philmd@redhat.com>

As Philippe says, the test condition is kinda ugly and I hope we can
refine it in future.  But since it fixes a real problem for now,

Reviewed-by: David Gibson <david@gibson.dropbear.id.au>

-- 
David Gibson			| I'll have my music baroque, and my code
david AT gibson.dropbear.id.au	| minimalist, thank you.  NOT _the_ _other_
				| _way_ _around_!
http://www.ozlabs.org/~dgibson

[-- Attachment #2: signature.asc --]
[-- Type: application/pgp-signature, Size: 833 bytes --]

  reply	other threads:[~2019-04-10  0:37 UTC|newest]

Thread overview: 24+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2019-04-09 17:40 [Qemu-devel] [PATCH for-4.0-maybe] device_tree: Fix integer overflowing in load_device_tree() Markus Armbruster
2019-04-09 17:40 ` Markus Armbruster
2019-04-09 18:59 ` Philippe Mathieu-Daudé
2019-04-10  0:29   ` David Gibson [this message]
2019-04-10  0:29     ` David Gibson
2019-04-10  5:28   ` Markus Armbruster
2019-04-10  5:28     ` Markus Armbruster
2019-04-10  5:44     ` Philippe Mathieu-Daudé
2019-04-10  5:44       ` Philippe Mathieu-Daudé
2019-04-10  5:59       ` Markus Armbruster
2019-04-10  6:34         ` Alistair Francis
2019-04-10  6:34           ` Alistair Francis
2019-04-10 15:47           ` Philippe Mathieu-Daudé
2019-04-11  4:31             ` Markus Armbruster
2019-04-11  4:31               ` Markus Armbruster
2019-04-09 20:08 ` Peter Maydell
2019-04-09 20:08   ` Peter Maydell
2019-04-09 20:13   ` Alistair Francis
2019-04-09 20:13     ` Alistair Francis
2019-04-09 20:28     ` Peter Maydell
2019-04-09 20:28       ` Peter Maydell
2019-04-10  5:30       ` Markus Armbruster
2019-04-10  5:30         ` Markus Armbruster
2019-04-10  5:25   ` Philippe Mathieu-Daudé

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20190410002930.GM16627@umbus.fritz.box \
    --to=david@gibson.dropbear.id.au \
    --cc=alistair.francis@wdc.com \
    --cc=armbru@redhat.com \
    --cc=peter.maydell@linaro.org \
    --cc=philmd@redhat.com \
    --cc=qemu-devel@nongnu.org \
    --cc=slp@redhat.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.