From: Peter Zijlstra <peterz@infradead.org>
To: Alex Kogan <alex.kogan@oracle.com>
Cc: linux-arch@vger.kernel.org, guohanjun@huawei.com, arnd@arndb.de,
dave.dice@oracle.com, jglauber@marvell.com, x86@kernel.org,
will.deacon@arm.com, linux@armlinux.org.uk,
steven.sistare@oracle.com, linux-kernel@vger.kernel.org,
rahul.x.yadav@oracle.com, mingo@redhat.com, bp@alien8.de,
hpa@zytor.com, longman@redhat.com, tglx@linutronix.de,
daniel.m.jordan@oracle.com, linux-arm-kernel@lists.infradead.org
Subject: Re: [PATCH v3 3/5] locking/qspinlock: Introduce CNA into the slow path of qspinlock
Date: Wed, 17 Jul 2019 10:59:00 +0200 [thread overview]
Message-ID: <20190717085900.GS3463@hirez.programming.kicks-ass.net> (raw)
In-Reply-To: <20190717083944.GR3463@hirez.programming.kicks-ass.net>
On Wed, Jul 17, 2019 at 10:39:44AM +0200, Peter Zijlstra wrote:
> On Tue, Jul 16, 2019 at 08:47:24PM +0200, Peter Zijlstra wrote:
> > My primary concern was readability; I find the above suggestion much
> > more readable. Maybe it can be written differently; you'll have to play
> > around a bit.
>
> static void cna_splice_tail(struct cna_node *cn, struct cna_node *head, struct cna_node *tail)
> {
> struct cna_node *list;
>
> /* remove [head,tail] */
> WRITE_ONCE(cn->mcs.next, tail->mcs.next);
> tail->mcs.next = NULL;
>
> /* stick [head,tail] on the secondary list tail */
> if (cn->mcs.locked <= 1) {
> /* create secondary list */
> head->tail = tail;
> cn->mcs.locked = head->encoded_tail;
> } else {
> /* add to tail */
> list = (struct cna_node *)decode_tail(cn->mcs.locked);
> list->tail->next = head;
> list->tail = tail;
> }
> }
>
> static struct cna_node *cna_find_next(struct mcs_spinlock *node)
> {
> struct cna_node *cni, *cn = (struct cna_node *)node;
> struct cna_node *head, *tail = NULL;
>
> /* find any next lock from 'our' node */
> for (head = cni = (struct cna_node *)READ_ONCE(cn->mcs.next);
> cni && cni->node != cn->node;
> tail = cni, cni = (struct cna_node *)READ_ONCE(cni->mcs.next))
> ;
I think we can do away with those READ_ONCE()s, at this point those
pointers should be stable. But please double check.
> /* when found, splice any skipped locks onto the secondary list */
> if (cni && tail)
> cna_splice_tail(cn, head, tail);
>
> return cni;
> }
>
> How's that?
WARNING: multiple messages have this Message-ID (diff)
From: Peter Zijlstra <peterz@infradead.org>
To: Alex Kogan <alex.kogan@oracle.com>
Cc: linux@armlinux.org.uk, mingo@redhat.com, will.deacon@arm.com,
arnd@arndb.de, longman@redhat.com, linux-arch@vger.kernel.org,
linux-arm-kernel@lists.infradead.org,
linux-kernel@vger.kernel.org, tglx@linutronix.de, bp@alien8.de,
hpa@zytor.com, x86@kernel.org, guohanjun@huawei.com,
jglauber@marvell.com, steven.sistare@oracle.com,
daniel.m.jordan@oracle.com, dave.dice@oracle.com,
rahul.x.yadav@oracle.com
Subject: Re: [PATCH v3 3/5] locking/qspinlock: Introduce CNA into the slow path of qspinlock
Date: Wed, 17 Jul 2019 10:59:00 +0200 [thread overview]
Message-ID: <20190717085900.GS3463@hirez.programming.kicks-ass.net> (raw)
Message-ID: <20190717085900.q4keMVeaU7X2OS5Xh7RMjq2EjRaDbKfDjzcaN3OrBzo@z> (raw)
In-Reply-To: <20190717083944.GR3463@hirez.programming.kicks-ass.net>
On Wed, Jul 17, 2019 at 10:39:44AM +0200, Peter Zijlstra wrote:
> On Tue, Jul 16, 2019 at 08:47:24PM +0200, Peter Zijlstra wrote:
> > My primary concern was readability; I find the above suggestion much
> > more readable. Maybe it can be written differently; you'll have to play
> > around a bit.
>
> static void cna_splice_tail(struct cna_node *cn, struct cna_node *head, struct cna_node *tail)
> {
> struct cna_node *list;
>
> /* remove [head,tail] */
> WRITE_ONCE(cn->mcs.next, tail->mcs.next);
> tail->mcs.next = NULL;
>
> /* stick [head,tail] on the secondary list tail */
> if (cn->mcs.locked <= 1) {
> /* create secondary list */
> head->tail = tail;
> cn->mcs.locked = head->encoded_tail;
> } else {
> /* add to tail */
> list = (struct cna_node *)decode_tail(cn->mcs.locked);
> list->tail->next = head;
> list->tail = tail;
> }
> }
>
> static struct cna_node *cna_find_next(struct mcs_spinlock *node)
> {
> struct cna_node *cni, *cn = (struct cna_node *)node;
> struct cna_node *head, *tail = NULL;
>
> /* find any next lock from 'our' node */
> for (head = cni = (struct cna_node *)READ_ONCE(cn->mcs.next);
> cni && cni->node != cn->node;
> tail = cni, cni = (struct cna_node *)READ_ONCE(cni->mcs.next))
> ;
I think we can do away with those READ_ONCE()s, at this point those
pointers should be stable. But please double check.
> /* when found, splice any skipped locks onto the secondary list */
> if (cni && tail)
> cna_splice_tail(cn, head, tail);
>
> return cni;
> }
>
> How's that?
WARNING: multiple messages have this Message-ID (diff)
From: Peter Zijlstra <peterz@infradead.org>
To: Alex Kogan <alex.kogan@oracle.com>
Cc: linux-arch@vger.kernel.org, guohanjun@huawei.com, arnd@arndb.de,
dave.dice@oracle.com, jglauber@marvell.com, x86@kernel.org,
will.deacon@arm.com, linux@armlinux.org.uk,
steven.sistare@oracle.com, linux-kernel@vger.kernel.org,
rahul.x.yadav@oracle.com, mingo@redhat.com, bp@alien8.de,
hpa@zytor.com, longman@redhat.com, tglx@linutronix.de,
daniel.m.jordan@oracle.com, linux-arm-kernel@lists.infradead.org
Subject: Re: [PATCH v3 3/5] locking/qspinlock: Introduce CNA into the slow path of qspinlock
Date: Wed, 17 Jul 2019 10:59:00 +0200 [thread overview]
Message-ID: <20190717085900.GS3463@hirez.programming.kicks-ass.net> (raw)
In-Reply-To: <20190717083944.GR3463@hirez.programming.kicks-ass.net>
On Wed, Jul 17, 2019 at 10:39:44AM +0200, Peter Zijlstra wrote:
> On Tue, Jul 16, 2019 at 08:47:24PM +0200, Peter Zijlstra wrote:
> > My primary concern was readability; I find the above suggestion much
> > more readable. Maybe it can be written differently; you'll have to play
> > around a bit.
>
> static void cna_splice_tail(struct cna_node *cn, struct cna_node *head, struct cna_node *tail)
> {
> struct cna_node *list;
>
> /* remove [head,tail] */
> WRITE_ONCE(cn->mcs.next, tail->mcs.next);
> tail->mcs.next = NULL;
>
> /* stick [head,tail] on the secondary list tail */
> if (cn->mcs.locked <= 1) {
> /* create secondary list */
> head->tail = tail;
> cn->mcs.locked = head->encoded_tail;
> } else {
> /* add to tail */
> list = (struct cna_node *)decode_tail(cn->mcs.locked);
> list->tail->next = head;
> list->tail = tail;
> }
> }
>
> static struct cna_node *cna_find_next(struct mcs_spinlock *node)
> {
> struct cna_node *cni, *cn = (struct cna_node *)node;
> struct cna_node *head, *tail = NULL;
>
> /* find any next lock from 'our' node */
> for (head = cni = (struct cna_node *)READ_ONCE(cn->mcs.next);
> cni && cni->node != cn->node;
> tail = cni, cni = (struct cna_node *)READ_ONCE(cni->mcs.next))
> ;
I think we can do away with those READ_ONCE()s, at this point those
pointers should be stable. But please double check.
> /* when found, splice any skipped locks onto the secondary list */
> if (cni && tail)
> cna_splice_tail(cn, head, tail);
>
> return cni;
> }
>
> How's that?
_______________________________________________
linux-arm-kernel mailing list
linux-arm-kernel@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/linux-arm-kernel
next prev parent reply other threads:[~2019-07-17 8:59 UTC|newest]
Thread overview: 75+ messages / expand[flat|nested] mbox.gz Atom feed top
2019-07-15 19:25 [PATCH v3 0/5] Add NUMA-awareness to qspinlock Alex Kogan
2019-07-15 19:25 ` Alex Kogan
2019-07-15 19:25 ` [PATCH v3 1/5] locking/qspinlock: Make arch_mcs_spin_unlock_contended more generic Alex Kogan
2019-07-15 19:25 ` Alex Kogan
2019-07-16 10:23 ` Peter Zijlstra
2019-07-16 10:23 ` Peter Zijlstra
2019-07-16 10:23 ` Peter Zijlstra
2019-07-15 19:25 ` [PATCH v3 2/5] locking/qspinlock: Refactor the qspinlock slow path Alex Kogan
2019-07-15 19:25 ` Alex Kogan
2019-07-15 19:25 ` Alex Kogan
2019-07-16 10:20 ` Peter Zijlstra
2019-07-16 10:20 ` Peter Zijlstra
2019-07-16 10:20 ` Peter Zijlstra
2019-07-16 14:53 ` Alex Kogan
2019-07-16 14:53 ` Alex Kogan
2019-07-16 15:58 ` Peter Zijlstra
2019-07-16 15:58 ` Peter Zijlstra
2019-07-15 19:25 ` [PATCH v3 3/5] locking/qspinlock: Introduce CNA into the slow path of qspinlock Alex Kogan
2019-07-15 19:25 ` Alex Kogan
2019-07-15 21:30 ` Waiman Long
2019-07-15 21:30 ` Waiman Long
2019-07-16 11:04 ` Peter Zijlstra
2019-07-16 11:04 ` Peter Zijlstra
2019-07-16 11:04 ` Peter Zijlstra
2019-07-16 14:26 ` Alex Kogan
2019-07-16 14:26 ` Alex Kogan
2019-07-16 14:44 ` Waiman Long
2019-07-16 14:44 ` Waiman Long
[not found] ` <aa73b86d-902a-bb6f-d372-8645c8299a6d@redhat.com>
[not found] ` <C1C55A40-FDB1-43B5-B551-F9B8BE776DF8@oracle.com>
2019-07-16 14:50 ` Waiman Long
2019-07-16 14:50 ` Waiman Long
2019-07-17 17:44 ` Alex Kogan
2019-07-17 17:44 ` Alex Kogan
2019-07-17 17:58 ` Waiman Long
2019-07-17 17:58 ` Waiman Long
2019-07-16 11:05 ` Peter Zijlstra
2019-07-16 11:05 ` Peter Zijlstra
2019-07-16 11:05 ` Peter Zijlstra
2019-07-16 14:30 ` Alex Kogan
2019-07-16 14:30 ` Alex Kogan
2019-07-16 15:50 ` Peter Zijlstra
2019-07-16 15:50 ` Peter Zijlstra
2019-07-16 15:50 ` Peter Zijlstra
2019-07-16 17:19 ` Alex Kogan
2019-07-16 17:19 ` Alex Kogan
2019-07-16 18:47 ` Peter Zijlstra
2019-07-16 18:47 ` Peter Zijlstra
2019-07-17 8:39 ` Peter Zijlstra
2019-07-17 8:39 ` Peter Zijlstra
2019-07-17 8:59 ` Peter Zijlstra [this message]
2019-07-17 8:59 ` Peter Zijlstra
2019-07-17 8:59 ` Peter Zijlstra
2019-07-17 14:52 ` Alex Kogan
2019-07-17 14:52 ` Alex Kogan
[not found] ` <FFC2D45A-24B3-40E1-ABBB-1D696E830B23@oracle.com>
2019-07-17 15:09 ` Peter Zijlstra
2019-07-17 15:09 ` Peter Zijlstra
2019-07-17 2:16 ` Waiman Long
2019-07-17 2:16 ` Waiman Long
2019-07-17 7:44 ` Peter Zijlstra
2019-07-17 7:44 ` Peter Zijlstra
2019-07-17 7:44 ` Peter Zijlstra
2019-07-17 13:35 ` Waiman Long
2019-07-17 13:35 ` Waiman Long
2019-07-17 14:42 ` Alex Kogan
2019-07-17 14:42 ` Alex Kogan
2019-07-15 19:25 ` [PATCH v3 4/5] locking/qspinlock: Introduce starvation avoidance into CNA Alex Kogan
2019-07-15 19:25 ` Alex Kogan
2019-07-16 15:59 ` Peter Zijlstra
2019-07-16 15:59 ` Peter Zijlstra
2019-07-15 19:25 ` [PATCH v3 5/5] locking/qspinlock: Introduce the shuffle reduction optimization " Alex Kogan
2019-07-15 19:25 ` Alex Kogan
2019-07-15 19:25 ` Alex Kogan
2019-07-16 11:47 ` [PATCH v3 0/5] Add NUMA-awareness to qspinlock Nicholas Piggin
2019-07-16 11:47 ` Nicholas Piggin
[not found] ` <7D29555E-8F72-4EDD-8A87-B1A59C3945A6@oracle.com>
2019-07-16 23:07 ` Nicholas Piggin
2019-07-16 23:07 ` Nicholas Piggin
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20190717085900.GS3463@hirez.programming.kicks-ass.net \
--to=peterz@infradead.org \
--cc=alex.kogan@oracle.com \
--cc=arnd@arndb.de \
--cc=bp@alien8.de \
--cc=daniel.m.jordan@oracle.com \
--cc=dave.dice@oracle.com \
--cc=guohanjun@huawei.com \
--cc=hpa@zytor.com \
--cc=jglauber@marvell.com \
--cc=linux-arch@vger.kernel.org \
--cc=linux-arm-kernel@lists.infradead.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux@armlinux.org.uk \
--cc=longman@redhat.com \
--cc=mingo@redhat.com \
--cc=rahul.x.yadav@oracle.com \
--cc=steven.sistare@oracle.com \
--cc=tglx@linutronix.de \
--cc=will.deacon@arm.com \
--cc=x86@kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.